Bug 382779 - Whole desktop hangs when more than two Delete Confirmation dialogs are shown
Summary: Whole desktop hangs when more than two Delete Confirmation dialogs are shown
Status: RESOLVED UPSTREAM
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 17.03.80
Platform: Other Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-27 07:17 UTC by Gregor Mi
Modified: 2018-04-15 16:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor Mi 2017-07-27 07:17:03 UTC
In order to provoke the kio message "The file or folder %1 does not exist." I tried to get dolphin delete a non-existing file and I found the following reproducible behavior.

1) Shift+Del on a file
2) Click behind the showing Delete Confirmation dialog to move the focus to the dolphin window
3) Shift+Del again on the same file (a subtle slowness is noticeable)
4) Shift+Del again on the same file
=> There are now three confirmation dialogs and dolphin hangs completely. Click on "Trash" or "Cancel" button has no effect. Even the Plasma Panel was blocked and the Ctrl+Esc shortcut to show System Monitor did not work. I helped myself with a pkill dolphin on a TTY.

Plasma 5.9.4 / Frameworks 5.34.0
Comment 1 Elvis Angelaccio 2017-07-27 15:04:48 UTC
Hi Gregor, I can reproduce the freeze...

(In reply to Gregor Mi from comment #0)
> In order to provoke the kio message "The file or folder %1 does not exist."
> I tried to get dolphin delete a non-existing file and I found the following
> reproducible behavior.
> 
> 1) Shift+Del on a file
> 2) Click behind the showing Delete Confirmation dialog to move the focus to
> the dolphin window

This should not happen. The dialog is modal *and* starts a nested event loop with exec().
Something must be really wrong here.
Comment 2 Elvis Angelaccio 2017-07-28 10:02:49 UTC
Imho this is a Qt bug. It should not be possible to trigger a QAction via shortcut if that action belongs to a window blocked by a modal dialog. Even if that dialog is not using a nested event loop.
Comment 3 Julian Steinmann 2018-04-12 16:45:15 UTC
I cannot reproduce this behavior using Dolphin 17.12.3, because a second dialog does not pop up when pressing Shift+Del again. Am I doing something wrong or has this dialog since been adjusted?
Comment 4 Gregor Mi 2018-04-12 22:06:08 UTC
(In reply to Julian Schraner from comment #3)
> I cannot reproduce this behavior using Dolphin 17.12.3, because a second
> dialog does not pop up when pressing Shift+Del again. Am I doing something
> wrong or has this dialog since been adjusted?

I also cannot reproduce the behavior anymore. Step 2) was to give the focus to the Dolphin main window despite the modal dialog. This is seemingly fixed by now. I close this ticket as UPSTREAM since it was probably a Qt bug.
Comment 5 Elvis Angelaccio 2018-04-15 15:15:46 UTC
Yes, I fixed the underlying problem in Qt. Thanks for closing this ticket!
Comment 6 Gregor Mi 2018-04-15 16:36:09 UTC
Cool :-)