Bug 382509 - Discover crash when removing aur package
Summary: Discover crash when removing aur package
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.10.4
Platform: Archlinux Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords: drkonqi
: 383246 384871 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-07-19 16:47 UTC by Stormrider
Modified: 2017-10-04 12:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.69 KB, text/plain)
2017-07-19 16:57 UTC, Stormrider
Details
New crash information added by DrKonqi (10.47 KB, text/plain)
2017-07-19 17:01 UTC, Stormrider
Details
New crash information added by DrKonqi (10.25 KB, text/plain)
2017-07-19 17:13 UTC, Stormrider
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stormrider 2017-07-19 16:47:08 UTC
Application: plasma-discover (5.10.4)

Qt Version: 5.9.1
Frameworks Version: 5.36.0
Operating System: Linux 4.11.9-1-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:
I searched in Discover for package viber and then clicked remove

-- Backtrace:
Application: Discover (plasma-discover), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8e03c897c0 (LWP 8451))]

Thread 11 (Thread 0x7f8db5a0e700 (LWP 8468)):
#0  0x00007f8dff42de9d in poll () at /usr/lib/libc.so.6
#1  0x00007f8df9d15c09 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8dffd62084 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f8dffd05ffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f8dffb1f40e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 10 (Thread 0x7f8db520d700 (LWP 8467)):
#0  0x00007f8dff42de9d in poll () at /usr/lib/libc.so.6
#1  0x00007f8df9aae8e0 in  () at /usr/lib/libxcb.so.1
#2  0x00007f8df9aaefad in  () at /usr/lib/libxcb.so.1
#3  0x00007f8df9aaf02d in xcb_writev () at /usr/lib/libxcb.so.1
#4  0x00007f8dfebf3f3e in _XSend () at /usr/lib/libX11.so.6
#5  0x00007f8dfebf4280 in _XFlush () at /usr/lib/libX11.so.6
#6  0x00007f8dfebd637a in XFlush () at /usr/lib/libX11.so.6
#7  0x00007f8debdf8d35 in  () at /usr/lib/qt/plugins/xcbglintegrations/libqxcb-glx-integration.so
#8  0x00007f8e00b3806f in QOpenGLContext::swapBuffers(QSurface*) () at /usr/lib/libQt5Gui.so.5
#9  0x00007f8e0305d043 in  () at /usr/lib/libQt5Quick.so.5
#10 0x00007f8e03061f08 in  () at /usr/lib/libQt5Quick.so.5
#11 0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#12 0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#13 0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 9 (Thread 0x7f8dc4e2a700 (LWP 8463)):
#0  0x00007f8dff42de9d in poll () at /usr/lib/libc.so.6
#1  0x00007f8df9d15c09 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d15fa2 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8dc6c37546 in  () at /usr/lib/libgio-2.0.so.0
#4  0x00007f8df9d3cae5 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7f8dc562b700 (LWP 8462)):
#0  0x00007f8df9d5aa84 in g_mutex_unlock () at /usr/lib/libglib-2.0.so.0
#1  0x00007f8df9d15abd in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8df9d15d61 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f8df9d3cae5 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 7 (Thread 0x7f8dd4bb7700 (LWP 8459)):
#0  0x00007f8dff429bad in read () at /usr/lib/libc.so.6
#1  0x00007f8df9d59730 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d156eb in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8df9d15bb0 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f8dffd62084 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f8dffd05ffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f8dffb1f40e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#9  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#10 0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7f8dd5a58700 (LWP 8458)):
#0  0x00007f8df9d5aa84 in g_mutex_unlock () at /usr/lib/libglib-2.0.so.0
#1  0x00007f8df9d15588 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d15bb0 in  () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#4  0x00007f8dffd62084 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f8dffd05ffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f8dffb1f40e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#7  0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7f8dd7dbc700 (LWP 8457)):
#0  0x00007f8dff42de9d in poll () at /usr/lib/libc.so.6
#1  0x00007f8df9d15c09 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8dffd62084 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f8dffd05ffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f8dffb1f40e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f8e02fe28d6 in  () at /usr/lib/libQt5Quick.so.5
#7  0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f8de3354700 (LWP 8456)):
#0  0x00007f8dff429bad in read () at /usr/lib/libc.so.6
#1  0x00007f8df9d59730 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d156eb in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8df9d15bb0 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f8dffd62084 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f8dffd05ffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f8dffb1f40e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f8e006e01d5 in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#11 0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f8de8a66700 (LWP 8454)):
#0  0x00007f8df9d153f1 in g_main_context_query () at /usr/lib/libglib-2.0.so.0
#1  0x00007f8df9d15b87 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f8dffd62084 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f8dffd05ffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f8dffb1f40e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f8e01e98396 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f8df0ea9700 (LWP 8453)):
#0  0x00007f8dff42de9d in poll () at /usr/lib/libc.so.6
#1  0x00007f8df9aae8e0 in  () at /usr/lib/libxcb.so.1
#2  0x00007f8df9ab0679 in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007f8df3a4472a in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f8dffb2415b in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f8dfbc6a049 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f8dff437f0f in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f8e03c897c0 (LWP 8451)):
[KCrash Handler]
#5  0x00007f8dff37d8c0 in raise () at /usr/lib/libc.so.6
#6  0x00007f8dff37ef72 in abort () at /usr/lib/libc.so.6
#7  0x00007f8dff782035 in __gnu_cxx::__verbose_terminate_handler() () at /build/gcc-multilib/src/gcc/libstdc++-v3/libsupc++/vterminate.cc:95
#8  0x00007f8dff77fc46 in __cxxabiv1::__terminate(void (*)()) (handler=<optimized out>) at /build/gcc-multilib/src/gcc/libstdc++-v3/libsupc++/eh_terminate.cc:47
#9  0x00007f8dff77fc91 in std::terminate() () at /build/gcc-multilib/src/gcc/libstdc++-v3/libsupc++/eh_terminate.cc:57
#10 0x00007f8dff77ff26 in __cxxabiv1::__cxa_rethrow() () at /build/gcc-multilib/src/gcc/libstdc++-v3/libsupc++/eh_throw.cc:131
#11 0x00007f8dffd409e4 in  () at /usr/lib/libQt5Core.so.5
#12 0x00007f8dffd39786 in QObjectPrivate::addConnection(int, QObjectPrivate::Connection*) () at /usr/lib/libQt5Core.so.5
#13 0x00007f8dffd3baf6 in QObjectPrivate::connectImpl(QObject const*, int, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#14 0x00007f8dffd3be2c in QObject::connectImpl(QObject const*, void**, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#15 0x00007f8dd610c629 in  () at /usr/lib/qt/plugins/discover/kns-backend.so
#16 0x00007f8dffd381d2 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#17 0x00007f8e012c1e4c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#18 0x00007f8e012c9926 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#19 0x00007f8dffd07bd0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#20 0x00007f8dffd0a426 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#21 0x00007f8dffd62a74 in  () at /usr/lib/libQt5Core.so.5
#22 0x00007f8df9d15a57 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#23 0x00007f8df9d15c88 in  () at /usr/lib/libglib-2.0.so.0
#24 0x00007f8df9d15d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#25 0x00007f8dffd62061 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#26 0x00007f8dffd05ffb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#27 0x00007f8dffd0f048 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#28 0x0000558a3e75aecf in  ()
#29 0x00007f8dff36a4ca in __libc_start_main () at /usr/lib/libc.so.6
#30 0x0000558a3e75b1fa in _start ()

Possible duplicates by query: bug 382439, bug 377656, bug 355966, bug 355218, bug 353304.

Reported using DrKonqi
Comment 1 Stormrider 2017-07-19 16:57:24 UTC
Created attachment 106733 [details]
New crash information added by DrKonqi

plasma-discover (5.10.4) using Qt 5.9.1

- What I was doing when the application crashed:
I searched for package viber and clicked remove

- Custom settings of the application:
I had updated a package with pacman, then opened discover and searched right-away for viber and then clicked remove

-- Backtrace (Reduced):
#5  0x00007ffa807486c0 in QObjectPrivate::addConnection(int, QObjectPrivate::Connection*) () at /usr/lib/libQt5Core.so.5
#6  0x00007ffa8074aaf6 in QObjectPrivate::connectImpl(QObject const*, int, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#7  0x00007ffa8074ae2c in QObject::connectImpl(QObject const*, void**, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#8  0x00007ffa56b1b629 in  () at /usr/lib/qt/plugins/discover/kns-backend.so
#9  0x00007ffa807471d2 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
Comment 2 Stormrider 2017-07-19 17:01:48 UTC
Created attachment 106734 [details]
New crash information added by DrKonqi

plasma-discover (5.10.4) using Qt 5.9.1

- What I was doing when the application crashed:
after the previous crash, I searched for viber, clicked on the info it worked fine.
I instantly closed Discover and reopened it, searched for viber, clicked on the info and it crashed.

I didn't click remove or update through pacman in the mean time (I did synchornise, though, but there was nothing to update)

Something peculiar is that when searching it keeps showing "still looking in the bottom". Maybe this thread is still left running and if you close and reopen it crashes, it finds the still running thread?

-- Backtrace (Reduced):
#5  0x00007f60daf0e6c3 in QObjectPrivate::addConnection(int, QObjectPrivate::Connection*) () at /usr/lib/libQt5Core.so.5
#6  0x00007f60daf10af6 in QObjectPrivate::connectImpl(QObject const*, int, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#7  0x00007f60daf10e2c in QObject::connectImpl(QObject const*, void**, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#8  0x00007f60b12e1629 in  () at /usr/lib/qt/plugins/discover/kns-backend.so
#9  0x00007f60daf0d1d2 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
Comment 3 Stormrider 2017-07-19 17:13:33 UTC
Created attachment 106736 [details]
New crash information added by DrKonqi

plasma-discover (5.10.4) using Qt 5.9.1

- What I was doing when the application crashed:
I'm testing to see what crashes, so far if you let discover "settle" it doesn't crash. What I mean is that if I let it search for updates and then search for a package and after a couple seconds click on the package it doesn't crash.
If I exit and launch discover again it works, if I again let it settle.

This crash was generated by searching for a package while Discover was still looking for updates and clicking on the first result. Again I was looking for viber , an AUR package installed

-- Backtrace (Reduced):
#5  0x00007f188886a6c3 in QObjectPrivate::addConnection(int, QObjectPrivate::Connection*) () at /usr/lib/libQt5Core.so.5
#6  0x00007f188886caf6 in QObjectPrivate::connectImpl(QObject const*, int, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#7  0x00007f188886ce2c in QObject::connectImpl(QObject const*, void**, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) () at /usr/lib/libQt5Core.so.5
#8  0x00007f185abfc629 in  () at /usr/lib/qt/plugins/discover/kns-backend.so
#9  0x00007f18888691d2 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
Comment 4 Aleix Pol 2017-08-02 14:21:55 UTC
I cannot reproduce :/
I'm running ArchLinux and I've tried to remove aur packages and it works just fine. It must be something else.
Comment 5 Stormrider 2017-08-02 14:36:50 UTC
I guess so, the same evening I got various crashes but haven't reproduced it since. Sorry
Comment 6 Christoph Feck 2017-10-04 12:51:55 UTC
*** Bug 383246 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2017-10-04 12:52:07 UTC
*** Bug 384871 has been marked as a duplicate of this bug. ***