Bug 382253 - Akonadi restart required to see new email in kmail
Summary: Akonadi restart required to see new email in kmail
Status: CLOSED DUPLICATE of bug 338658
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Gmail resource (show other bugs)
Version: 5.5.2
Platform: Neon Linux
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-11 20:36 UTC by thatskinnywhiteguy+kde
Modified: 2018-08-27 17:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thatskinnywhiteguy+kde 2017-07-11 20:36:17 UTC
As many as several times per day, KMail stops getting emails from a Google resource (the only resource currently configured) using IMAP/SMTP. Restarting akonadi (`akonadictl restart`) generally fixes it.

If I leave the terminal I used to restart akonadi open, I see a long list of errors that might be relevant. With some filtering intended to ignore kgapi errors, which are from a different resource and probably not relevant, and to protect my privacy, here are some examples:

org.kde.pim.akonadicore: Deleting items from the akonadi database failed: "No items found"
!org.kde.pim.akonadiserver: Payload file  "/home/peter/.local/share/akonadi/file_db_data/25/16125_r3"  could not be open for reading!
org.kde.pim.akonadiserver: Error:  "No such file or directory"
org.kde.pim.akonadiserver: Payload file  "/home/peter/.local/share/akonadi/file_db_data/24/16124_r3"  could not be open for reading!
org.kde.pim.akonadiserver: Error:  "No such file or directory"
org.kde.pim.akonadiserver: Payload file  "/home/peter/.local/share/akonadi/file_db_data/50/16350_r1"  could not be open for reading!
org.kde.pim.akonadiserver: Error:  "No such file or directory"
org.kde.pim.akonadiserver: Payload file  "/home/peter/.local/share/akonadi/file_db_data/48/16348_r1"  could not be open for reading!
org.kde.pim.akonadiserver: Error:  "No such file or directory"
org.kde.pim.akonadiserver: Payload file  "/home/peter/.local/share/akonadi/file_db_data/53/16353_r1"  could not be open for reading!
org.kde.pim.akonadiserver: Error:  "No such file or directory"
(There are many more lines like this)

org.kde.pim.akonadicore: Creating/updating items from the akonadi database failed: "Unknown error."
(Many copies of this last line)

org.kde.pim.akonadicore: Creating/updating items from the akonadi database failed: "Multiple merge candidates, aborting"
org.kde.pim.akonadicore: Error during ItemSync:  "Multiple merge candidates, aborting"

It seems unlikely to be a duplicate of #343114 but I thought I'd mention it in case it is; the two do seem to have some superficial similarities.

After a while, this became bad enough that I removed the resource entirely and re-authenticated (especially obnoxious because I had to make a new application-specific password for SMTP). It worked like a dream for a week or two and then the same problem cropped up with increasing frequency.

Note: I'm not really sure which version number to report. KMail says that it's 5.5.2 but apt says that it's 4:17.04.2-0neon+16.04+xenial+build23. akonadiconsole says it's 0.99. In both applications, the Libraries tab of the About window reports that the version of the KDE Frameworks is 5.35.0. Apt reports version 4:17.04.2-0neon+16.04+xenial+build31 for the akonadi-server package. I'm running a vanilla installation of KDE Neon.
Comment 1 thatskinnywhiteguy+kde 2017-07-12 16:07:50 UTC
It's a little hard to be sure when exactly things stop working, but there's some evidence that suggests that the last two lines (quoted again below) indicate what's actually breaking. That is, when they're there, it seems that the email sync no longer functions. Until they appear, it seems to work properly.

org.kde.pim.akonadicore: Creating/updating items from the akonadi database failed: "Multiple merge candidates, aborting"
org.kde.pim.akonadicore: Error during ItemSync:  "Multiple merge candidates, aborting"
Comment 2 davidblunkett 2018-03-05 16:07:46 UTC
Did this get a fix? I have a similar problem that is making kmail unusable...
Comment 3 Rolf Eike Beer 2018-06-09 09:06:46 UTC

*** This bug has been marked as a duplicate of bug 338658 ***
Comment 4 davidblunkett 2018-07-06 08:54:36 UTC
The duplicate this was marked as dates back to 2014.

Kmail has work fine between 2014 and 2017 and this problem which was reported in 2017 and is still with us doesn't seem likely to be the original 2014 problem so I'm unmarking the duplication and reopneing.
Comment 5 Christophe Giboudeaux 2018-07-06 09:32:14 UTC

*** This bug has been marked as a duplicate of bug 338658 ***
Comment 6 davidblunkett 2018-07-23 09:16:35 UTC
Can someone explain how a bug first reported in 2014 which did not affect me from 2014-2017 despite using gmail / kmail during this period suddenly starts to affect me during 2017/18? 

Unless there is some rational explanation for the 2017/18 bug to be an extant version of the 2014 bug that somehow did not cause me problems 2014-17 then this should not be marked as a duplicate of bug 338658!
Comment 7 davidblunkett 2018-08-27 17:06:53 UTC
I doubt this was ever a duplicate of 338658.

anyway for me it seems to be resolved in v5.7.3 - or at least I've managed five hours without a crash which is 4 hours more than with the last version