Bug 382115 - Rendering artifacts on desktop Icon Text after resume from suspend.
Summary: Rendering artifacts on desktop Icon Text after resume from suspend.
Status: RESOLVED UPSTREAM
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Desktop Containment (show other bugs)
Version: 5.10.3
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-08 06:24 UTC by dallas.johnston
Modified: 2019-06-21 12:06 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dallas.johnston 2017-07-08 06:24:03 UTC
Machine Environment:

Ubuntu 17.04 (64-bit)
Kernel: 4.10.0-26-generic

Graphics Cards: NVIDIA GeForce GTX 750 (3 monitors) Driver Version 381.22, Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (1 monitor) Driver is i915.
X-Server 7.7
XDG_SESSION_DESKTOP=plasma
GDMSESSION=plasma

Plasma 5.10.3 - All backported from Kubuntu
KDE Frameworks 5.35.0
Qt 5.7.1

⟩ cat /etc/systemd/system/display-manager.service
[Unit]
Description=Light Display Manager
Documentation=man:lightdm(1)
Conflicts=getty@tty7.service plymouth-quit.service
After=systemd-user-sessions.service getty@tty7.service plymouth-quit.service

[Service]
# temporary safety check until all DMs are converted to correct
# display-manager.service symlink handling
ExecStartPre=/bin/sh -c '[ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "lightdm" ]'
ExecStart=/usr/sbin/lightdm
Restart=always
BusName=org.freedesktop.DisplayManager

Steps to reproduce:
Click on "Plasma Start Icon > Leave > System:Suspend"
Resume computer from suspend mode.

Result:
http://i.imgur.com/t4S8kMS.png
Also seems to affect VS Code's minimap (http://i.imgur.com/UgFSZ2X.png)
Comment 1 Christoph Feck 2017-07-08 11:28:17 UTC

*** This bug has been marked as a duplicate of bug 344326 ***
Comment 2 Martin Flöser 2017-07-08 13:37:04 UTC
This is not a duplicate though the main issue is the same. Any application using OpenGL needs the same adjustments as KWin did. That is Qt needs to react on the context lost and recreate the QtQuick scene. AFAIK Qt does not create robust contexts, so it has no chance to react on that issue.
Comment 3 Owen 2017-07-13 09:34:30 UTC
Also having this issue

See this question on stackexchange:

https://unix.stackexchange.com/questions/372710/kde5-after-resume-from-suspend-i-have-corrupted-labels-under-icons/
Comment 4 Christoph Feck 2017-07-17 17:41:49 UTC
According to comment #2, this needs fixing in Qt for its OpenGL usage in QtQuick, similar to the fix in KWin for its OpenGL usage in the compositor.

Please report this issue directly to Qt developers via https://bugreports.qt.io/

The change in Qt should look similar to https://phabricator.kde.org/D6344
Comment 5 Owen 2017-07-19 11:35:33 UTC
(In reply to Christoph Feck from comment #4)
> According to comment #2, this needs fixing in Qt for its OpenGL usage in
> QtQuick, similar to the fix in KWin for its OpenGL usage in the compositor.
> 
> Please report this issue directly to Qt developers via
> https://bugreports.qt.io/
> 
> The change in Qt should look similar to https://phabricator.kde.org/D6344

OK, thanks, seems they are aware

https://bugreports.qt.io/browse/QTBUG-56610?jql=text%20~%20%22nvidia%22
Comment 6 Andrei Ivnitskii 2019-06-14 16:16:47 UTC
Kubuntu 19.04

KDE 5.15
Qt 5.12
Nvidia GTX 1060 (418 driver)

https://hostingkartinok.com/show-image.php?id=37f0bda79a62ad503d08309a6f5595d5

Bug still present. I try nouveau driver, but without success.
Comment 7 Andrei Ivnitskii 2019-06-21 12:06:54 UTC
Workaround https://bugs.kde.org/show_bug.cgi?id=364766#c78