Bug 381699 - Unhandled instruction RDRAND
Summary: Unhandled instruction RDRAND
Status: RESOLVED DUPLICATE of bug 353370
Alias: None
Product: valgrind
Classification: Developer tools
Component: memcheck (show other bugs)
Version: 3.11.0
Platform: Mint (Ubuntu based) Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-26 22:23 UTC by jeremy
Modified: 2017-06-26 22:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeremy 2017-06-26 22:23:41 UTC
rdrand instruction not recognized on Intel x64.

----------------------------------------------------------------------
vex amd64->IR: unhandled instruction bytes: 0x48 0xF 0xC7 0xF0 0x72 0x9 0xF 0x31
vex amd64->IR:   REX=1 REX.W=1 REX.R=0 REX.X=0 REX.B=0
vex amd64->IR:   VEX=0 VEX.L=0 VEX.nVVVV=0x0 ESC=0F
vex amd64->IR:   PFX.66=0 PFX.F2=0 PFX.F3=0
==10040== valgrind: Unrecognised instruction at address 0x4027dc.
----------------------------------------------------------------------
==10040== Memcheck, a memory error detector
==10040== Copyright (C) 2002-2015, and GNU GPL'd, by Julian Seward et al.
==10040== Using Valgrind-3.11.0 and LibVEX; rerun with -h for copyright info
==10040== Command: ./g g.c -c
==10040==
Comment 1 Mark Wielaard 2017-06-26 22:38:50 UTC

*** This bug has been marked as a duplicate of bug 353370 ***