Bug 381423 - Crash when adding RSS; crash every restart or launch
Summary: Crash when adding RSS; crash every restart or launch
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
: 386349 387544 389945 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-20 01:49 UTC by Tim LePés
Modified: 2021-02-08 23:47 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-25765-0.html (2.29 KB, text/html)
2021-01-09 17:33 UTC, Tim LePés
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim LePés 2017-06-20 01:49:58 UTC
Application: akregator (5.5.2)

Qt Version: 5.9.0
Frameworks Version: 5.35.0
Operating System: Linux 4.11.5-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:

Looking at Martin Graesslin's blog and deciding, as a KDE Plasma user, I should subscribe to his RSS feed.  As soon as I hit the "Subscribe Now" in Firefox (54.0 64bit) I got a system notification that Akregator crashed.  I tried restarting the applicaiton from the crash dialog, starting from the launcher, and by hitting the "Subscribe Now" button in Firefox again.  Each time, it crashed immediately.  So I ran it from the command line and got this output:

$ akregator
Invalid Context= "Apps" line for icon theme:  "/usr/share/icons/Paper/512x512@2x/apps/"
Invalid Context= "Mimetypes" line for icon theme:  "/usr/share/icons/Paper/512x512@2x/mimetypes/"
Invalid Context= "Mimetypes" line for icon theme:  "/usr/share/icons/Paper/scalable/mimetypes/"
org.kde.pim.webengineviewer:  It's not necessary to check database now
Error loading text-to-speech plug-in "flite"
 void AdblockManager::reloadConfig() false    AdBlock::AdblockManager(0xcd4260)
"Tag 'a' is not defined in message {<__kuit_internal_top__>For more information about using Akregator, check the <a ...}."
"Tag 'a' is not defined in message {<__kuit_internal_top__>For more information about using Akregator, check the <a ...}."
org.kde.pim.webengineviewer: Database already initialized. It's a bug in code if you call it twice.
 void AdblockManager::reloadConfig() false    AdBlock::AdblockManager(0xe05ab0)
"Tag 'a' is not defined in message {<__kuit_internal_top__>For more information about using Akregator, check the <a ...}."
"Tag 'a' is not defined in message {<__kuit_internal_top__>For more information about using Akregator, check the <a ...}."
 void AdblockManager::reloadConfig() false    AdBlock::AdblockManager(0xe8ad90)
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
"https://www.archlinux.org/feeds/news/"
"http://www.kde.org/dotkdeorg.rdf"
"http://planetkde.org/rss20.xml"
"https://www.linux.com/rss/feeds.php"
"http://pim.planetkde.org/rss20.xml"
"https://store.kde.org/content.rdf"
"http://planetkde.org/pt-br/rss20.xml"
"http://planet.kde-espana.org/atom.xml"
"https://fr.planetkde.org/rss20.xml"
"https://www.linux.com/feeds/news/rss"
"https://www.linux.com/feeds/blogs/open-source-professionals/rss"
"https://www.linux.com/feeds/tutorials/rss"
"https://feeds.feedburner.com/linuxtoday/linux?format=xml"
"https://linuxgizmos.com/feed/"
"https://lwn.net/headlines/rss"
"http://lxer.com/module/newswire/headlines.rss"
"https://opensource.com/feed"
"http://feeds.maketecheasier.com/MakeTechEasier"
"https://www.digitalocean.com/community/tutorials/feed"
"http://torrentfreak.com/category/dvdrip/feed/"
"https://insights.hpe.com/bin/rss"
 void AdblockManager::reloadConfig() false    AdBlock::AdblockManager(0xfbff70)
[2066:2066:0100/000000.309319:ERROR:broker_posix.cc(41)] Invalid node channel message
[2067:2067:0100/000000.309321:ERROR:broker_posix.cc(41)] Invalid node channel message
[2079:2079:0100/000000.309353:ERROR:broker_posix.cc(41)] Invalid node channel message
[2071:2071:0100/000000.309439:ERROR:broker_posix.cc(41)] Invalid node channel message
KCrash: Application 'akregator' crashing...
KCrash: Attempting to start /usr/lib/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0
[2061:2061:0100/000000.310735:ERROR:broker_posix.cc(41)] Invalid node channel message
[2070:2070:0100/000000.312136:ERROR:broker_posix.cc(41)] Invalid node channel message
[2063:2063:0100/000000.315324:ERROR:broker_posix.cc(41)] Invalid node channel message
[2078:2078:0100/000000.323665:ERROR:broker_posix.cc(41)] Invalid node channel message

[1]+  Stopped                 akregator

My distro is Arch Linux...
Kernel: x86_64 Linux 4.11.5-1-ARCH
KDE 5.35.0 / Plasma 5.10.2

Apparently after I got my prompt back in the shell, I got a bunch of this [warn] epoll_wait: Bad file descriptor stuff followed by a segfault (akregator)...

[warn] epoll_wait: Bad file descriptor
[warn] epoll_wait: Bad file descriptor
[warn] epoll_wait: Bad file descriptor
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
[warn] epoll_wait: Bad file descriptor
[warn] epoll_wait: Bad file descriptor
[warn] epoll_wait: Bad file descriptor
[warn] epoll_wait: Bad file descriptor
[warn] epoll_wait: Bad file descriptor
[warn] epoll_wait: Bad file descriptor
^C
[1]+  Segmentation fault      (core dumped) akregator

I think the Dr. Konqi error is because I am still filling out this crash report.  I was just getting started with Akgregator... it would be a shame if I can't use it.  Let me know what else I may try or infos I can gather that may help.  And thanks!

- Custom settings of the application:

$ cat .config/akregatorrc 

[$Version]
update_info=fonts_akregator.upd:Plasma_Fonts_Akregator

[Appearance]
Fixed Font=Hack
Sans Serif Font=Noto Sans
Serif Font=Noto Sans
Standard Font=Noto Sans

[ConfigurePluginsWidget]
splitter=49,49

[General]
ArticleListFeedHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAMBAAAAAAAAAAAAAAAEAgAAAAEAAAABAAAAZAAAA/QAAAAEAQEAAAAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAAEAAACQQAAAAEAAAAAAAAAAAAAAAEAAAAAAAABJQAAAAEAAAAAAAAAjgAAAAEAAAAAAAAD6AAAAABk
ArticleListGroupHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAMBAAAAAAAAAAAAAAAAAAAAAAAAAqgAAAAEAQEAAAAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAAEAAABUgAAAAEAAAAAAAAAZAAAAAEAAAAAAAAAZAAAAAEAAAAAAAAAjgAAAAEAAAAAAAAD6AAAAABk
SubscriptionListHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAAAAAAAAAAAAAAAAAADBgAAAAIAAAACAAAAZAAAAAEAAAADAAAAZAAAAAMBAAABAAAAAAAAAAAAAAAAZP////8AAACBAAAAAAAAAAMAAABkAAAAAQAAAAAAAAAAAAAAAQAAAAAAAAAAAAAAAQAAAAAAAAPoAAAAAGQ=

[HTML Settings]
Fonts=Noto Sans,Hack,Noto Sans,Noto Sans,Noto Sans,Noto Sans,0
MinimumFontSize=10

[MainWindow]
Height 1080=1009
Height 1350=1271
Height 1620=1525
MenuBar=Disabled
State=AAAA/wAAAAD9AAAAAAAACWAAAASyAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAA
ToolBarsMovable=Disabled
Width 1920=1920
Width 2400=2400
Width 2880=2880

[Migratekde4]
Version=1

[MimePartTree]
State=\x00\x00\x00�\x00\x00\x00\x00\x00\x00\x00\x01\x00\x00\x00\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x04�\x00\x00\x00\x03\x01\x00\x00\x01\x00\x00\x00\x00\x00\x00\x00\x00\x03\x00\x00\x00d����\x00\x00\x00�\x00\x00\x00\x03\x00\x00\x00\x03\x00\x00\x00h\x00\x00\x00\x01\x00\x00\x00\x03\x00\x00\x002\x00\x00\x00\x01\x00\x00\x00\x03\x00\x00\x04a\x00\x00\x00\x01\x00\x00\x00\x03\x00\x00\x03�\x00����

[Reader]
attachment-strategy=smart
header-plugin-style-name=standards-header

[View]
Splitter 1 Sizes=271,783
Splitter 2 Sizes=535,670

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f078d3f9900 (LWP 1191))]

Thread 22 (Thread 0x7f06e1e8c700 (LWP 1219)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f0775b68ac4 in ?? () from /usr/lib/libQt5Script.so.5
#2  0x00007f0775b68b09 in ?? () from /usr/lib/libQt5Script.so.5
#3  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#4  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 21 (Thread 0x7f06ebfff700 (LWP 1213)):
#0  0x00007f07892a92bd in poll () from /usr/lib/libc.so.6
#1  0x00007f0781474bf9 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f0781474d0c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f0789bd1e9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f0789b7821a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f078999a40a in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f078999ecbd in ?? () from /usr/lib/libQt5Core.so.5
#7  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#8  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 20 (Thread 0x7f0734ff9700 (LWP 1212)):
#0  0x00007f0767cf26ea in ?? () from /usr/lib/pulseaudio/libpulsecommon-10.0.so
#1  0x00007f0767cf55eb in ?? () from /usr/lib/pulseaudio/libpulsecommon-10.0.so
#2  0x00007f0767cf5989 in ?? () from /usr/lib/pulseaudio/libpulsecommon-10.0.so
#3  0x00007f0767cf620a in ?? () from /usr/lib/pulseaudio/libpulsecommon-10.0.so
#4  0x00007f076ff1f99c in pa_mainloop_dispatch () from /usr/lib/libpulse.so.0
#5  0x00007f076ff1fd9c in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#6  0x00007f076ff1fe40 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#7  0x00007f076ff2de29 in ?? () from /usr/lib/libpulse.so.0
#8  0x00007f0767d05fe8 in ?? () from /usr/lib/pulseaudio/libpulsecommon-10.0.so
#9  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 19 (Thread 0x7f07357fa700 (LWP 1211)):
#0  0x00007f07892c004b in __lll_lock_wait_private () from /usr/lib/libc.so.6
#1  0x00007f07892c1d04 in __fprintf_chk () from /usr/lib/libc.so.6
#2  0x00007f076d519b3e in ?? () from /usr/lib/libevent-2.0.so.5
#3  0x00007f076d519d34 in event_warn () from /usr/lib/libevent-2.0.so.5
#4  0x00007f076d51e4b8 in ?? () from /usr/lib/libevent-2.0.so.5
#5  0x00007f076d50845a in event_base_loop () from /usr/lib/libevent-2.0.so.5
#6  0x00007f0778919fe9 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#9  0x00007f077894aa06 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#10 0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#11 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#12 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 18 (Thread 0x7f0735ffb700 (LWP 1210)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f077893ec59 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ec87 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f07789199eb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f077894aa06 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 17 (Thread 0x7f07367fc700 (LWP 1209)):
#0  0x00007f07836d26cc in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f0778977ab2 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ebde in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f0778919a3b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f077894aa06 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 16 (Thread 0x7f0736ffd700 (LWP 1208)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f07791d9800 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077894a441 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 15 (Thread 0x7f07377fe700 (LWP 1207)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f077893ec59 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ec87 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f07789199eb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f077894aa06 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 14 (Thread 0x7f0737fff700 (LWP 1206)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f07789491c5 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f07789496a7 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f077894a441 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 13 (Thread 0x7f073cff9700 (LWP 1205)):
#0  0x00007f07892c004b in __lll_lock_wait_private () from /usr/lib/libc.so.6
#1  0x00007f07892c1d04 in __fprintf_chk () from /usr/lib/libc.so.6
#2  0x00007f076d519b3e in ?? () from /usr/lib/libevent-2.0.so.5
#3  0x00007f076d519d34 in event_warn () from /usr/lib/libevent-2.0.so.5
#4  0x00007f076d51e4b8 in ?? () from /usr/lib/libevent-2.0.so.5
#5  0x00007f076d50845a in event_base_loop () from /usr/lib/libevent-2.0.so.5
#6  0x00007f077891a123 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#9  0x00007f07781d0108 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#10 0x00007f07781d06bb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#11 0x00007f077894aab8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#12 0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#13 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#14 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 12 (Thread 0x7f073d7fa700 (LWP 1204)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f077893ec59 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ec87 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f07789199eb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f07781d0058 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f07781d06ab in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f077894aab8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#9  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#10 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 11 (Thread 0x7f073dffb700 (LWP 1203)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f077893ec59 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ec87 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f07789199eb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f07781cffa8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f07781d069b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f077894aab8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#9  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#10 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 10 (Thread 0x7f073e7fc700 (LWP 1202)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f077893ec59 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ec87 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f07789199eb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f07781cfef8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f07781d068b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f077894aab8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#9  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#10 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 9 (Thread 0x7f073effd700 (LWP 1201)):
#0  0x00007f07892a508d in write () from /usr/lib/libc.so.6
#1  0x00007f078923a26d in _IO_new_file_write () from /usr/lib/libc.so.6
#2  0x00007f078923954f in new_do_write () from /usr/lib/libc.so.6
#3  0x00007f078923aa2e in __GI__IO_file_xsputn () from /usr/lib/libc.so.6
#4  0x00007f0789211a7b in buffered_vfprintf () from /usr/lib/libc.so.6
#5  0x00007f078920edee in vfprintf () from /usr/lib/libc.so.6
#6  0x00007f07892c1d56 in __fprintf_chk () from /usr/lib/libc.so.6
#7  0x00007f076d519b3e in ?? () from /usr/lib/libevent-2.0.so.5
#8  0x00007f076d519d34 in event_warn () from /usr/lib/libevent-2.0.so.5
#9  0x00007f076d51e4b8 in ?? () from /usr/lib/libevent-2.0.so.5
#10 0x00007f076d50845a in event_base_loop () from /usr/lib/libevent-2.0.so.5
#11 0x00007f077891a03d in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#12 0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#13 0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#14 0x00007f07781cfe48 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#15 0x00007f07781d067b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#16 0x00007f077894aab8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#17 0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#18 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#19 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 8 (Thread 0x7f073f7fe700 (LWP 1200)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f077893ec59 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ec87 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f07789199eb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f07781cfd98 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f07781d066b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f077894aab8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#9  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#10 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 7 (Thread 0x7f073ffff700 (LWP 1199)):
#0  0x00007f07836d26cc in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f0778977ab2 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077894dcc9 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f077894e22b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 6 (Thread 0x7f074c862700 (LWP 1198)):
#0  0x00007f07836d26cc in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f0778977ab2 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077894dcc9 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f077894e22b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f074d063700 (LWP 1197)):
#0  0x00007f07836d239d in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f077893ec59 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#2  0x00007f077893ec87 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#3  0x00007f07789199eb in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#4  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#5  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#6  0x00007f077894aa06 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f074da71700 (LWP 1196)):
#0  0x00007f07892c004b in __lll_lock_wait_private () from /usr/lib/libc.so.6
#1  0x00007f07892c1d04 in __fprintf_chk () from /usr/lib/libc.so.6
#2  0x00007f076d519b3e in ?? () from /usr/lib/libevent-2.0.so.5
#3  0x00007f076d519d34 in event_warn () from /usr/lib/libevent-2.0.so.5
#4  0x00007f076d51e4b8 in ?? () from /usr/lib/libevent-2.0.so.5
#5  0x00007f076d50845a in event_base_loop () from /usr/lib/libevent-2.0.so.5
#6  0x00007f077891a03d in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#7  0x00007f07789162b8 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#8  0x00007f0778932e9b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#9  0x00007f077894aa06 in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#10 0x00007f0778946b0b in ?? () from /usr/lib/libQt5WebEngineCore.so.5
#11 0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#12 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f0754c3c700 (LWP 1193)):
#0  0x00007f07814b9a44 in g_mutex_unlock () from /usr/lib/libglib-2.0.so.0
#1  0x00007f07814743d9 in g_main_context_query () from /usr/lib/libglib-2.0.so.0
#2  0x00007f0781474b77 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0x00007f0781474d0c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0x00007f0789bd1e9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f0789b7821a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#6  0x00007f078999a40a in QThread::exec() () from /usr/lib/libQt5Core.so.5
#7  0x00007f078b572d45 in ?? () from /usr/lib/libQt5DBus.so.5
#8  0x00007f078999ecbd in ?? () from /usr/lib/libQt5Core.so.5
#9  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f075dbd8700 (LWP 1192)):
#0  0x00007f07892a92bd in poll () from /usr/lib/libc.so.6
#1  0x00007f078120d8e0 in ?? () from /usr/lib/libxcb.so.1
#2  0x00007f078120f679 in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#3  0x00007f075fce8d49 in ?? () from /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f078999ecbd in ?? () from /usr/lib/libQt5Core.so.5
#5  0x00007f07836cc297 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f07892b325f in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f078d3f9900 (LWP 1191)):
[KCrash Handler]
#5  0x0000000000000130 in ?? ()
#6  0x00007f0789b8bf13 in QMetaObject::invokeMethod(QObject*, char const*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) () from /usr/lib/libQt5Core.so.5
#7  0x00007f0754164e79 in Akregator::MainWidget::slotFramesChanged() () from /usr/lib/qt/plugins/akregatorpart.so
#8  0x00007f0789ba857f in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#9  0x00007f078cc9a2d1 in Akregator::FrameManager::signalFrameRemoved(int) () from /usr/lib/libakregatorprivate.so.5
#10 0x00007f078cc5d412 in Akregator::FrameManager::slotRemoveFrame(int) () from /usr/lib/libakregatorprivate.so.5
#11 0x00007f0789ba857f in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#12 0x00007f075417d361 in ?? () from /usr/lib/qt/plugins/akregatorpart.so
#13 0x00007f0754169420 in Akregator::MainWidget::slotOnShutdown() () from /usr/lib/qt/plugins/akregatorpart.so
#14 0x00007f075416965d in Akregator::MainWidget::~MainWidget() () from /usr/lib/qt/plugins/akregatorpart.so
#15 0x00007f0754169689 in Akregator::MainWidget::~MainWidget() () from /usr/lib/qt/plugins/akregatorpart.so
#16 0x00007f0789ba603b in QObjectPrivate::deleteChildren() () from /usr/lib/libQt5Core.so.5
#17 0x00007f078a8e0acc in QWidget::~QWidget() () from /usr/lib/libQt5Widgets.so.5
#18 0x00007f075412cca1 in ?? () from /usr/lib/qt/plugins/akregatorpart.so
#19 0x00007f0789ba8e90 in QObject::event(QEvent*) () from /usr/lib/libQt5Core.so.5
#20 0x00007f078a8e5473 in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#21 0x00007f078a9c42de in QFrame::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#22 0x00007f078a8a446c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#23 0x00007f078a8abcf4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#24 0x00007f0789b79b98 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#25 0x00007f0789b7c02d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQt5Core.so.5
#26 0x00007f0789bd1a63 in ?? () from /usr/lib/libQt5Core.so.5
#27 0x00007f0781474a47 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007f0781474c78 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0x00007f0781474d0c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007f0789bd1e7f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#31 0x00007f0789b7821a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#32 0x00007f0789b80a74 in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#33 0x00000000004084a9 in ?? ()
#34 0x00007f07891e643a in __libc_start_main () from /usr/lib/libc.so.6
#35 0x000000000040860a in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2017-11-08 15:35:15 UTC
*** Bug 386349 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2017-12-28 19:34:15 UTC
*** Bug 387544 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2018-02-22 02:40:42 UTC
*** Bug 389945 has been marked as a duplicate of this bug. ***
Comment 4 Justin Zobel 2020-12-17 05:35:34 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 5 Bug Janitor Service 2021-01-01 04:37:01 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Tim LePés 2021-01-09 17:33:47 UTC
Created attachment 134686 [details]
attachment-25765-0.html

Sorry for the late reply.  I was able to test this again using the same RSS
feed and it seems to be working fine now.  Thank you so much!  I believe
this is solved now.  Akregator

Version 5.16.0 (20.12.0) running under Manjaro KDE Linux 5.9.16-1-MANJARO
#1 SMP PREEMPT


Cheers,

Timothy LePés


On Thu, Dec 31, 2020 at 8:37 PM Bug Janitor Service <
bugzilla_noreply@kde.org> wrote:

> https://bugs.kde.org/show_bug.cgi?id=381423
>
> --- Comment #5 from Bug Janitor Service <bug-janitor@kde.org> ---
> Dear Bug Submitter,
>
> This bug has been in NEEDSINFO status with no change for at least
> 15 days. Please provide the requested information as soon as
> possible and set the bug status as REPORTED. Due to regular bug
> tracker maintenance, if the bug is still in NEEDSINFO status with
> no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
> due to lack of needed information.
>
> For more information about our bug triaging procedures please read the
> wiki located here:
> https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging
>
> If you have already provided the requested information, please
> mark the bug as REPORTED so that the KDE team knows that the bug is
> ready to be confirmed.
>
> Thank you for helping us make KDE software even better for everyone!
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 7 Bug Janitor Service 2021-01-24 04:33:14 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!