Bug 381221 - Akgregator crashes on launch
Summary: Akgregator crashes on launch
Status: RESOLVED DUPLICATE of bug 378513
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-06-15 09:42 UTC by Mark
Modified: 2017-06-19 12:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2017-06-15 09:42:48 UTC
Application: akregator (5.5.2)
 (Compiled from sources)
Qt Version: 5.9.0
Frameworks Version: 5.34.0
Operating System: Linux 4.9.26 x86_64
Distribution: "Linux From Scratch"

-- Information about the crash:
- What I was doing when the application crashed:
Launching from command prompt. Same result each attempt. Kmail starts but won't connect to akonadi. 16.12.3 was stable. Exactly the same build method was used for 17.04.2.

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
[KCrash Handler]
#6  0x0000000000000110 in  ()
#7  0x00007fc4862d88f9 in QMetaObject::cast(QObject const*) const () at /opt/qt5/lib/libQt5Core.so.5
#8  0x00007fc48b26cd4e in Akregator::FrameManager::saveProperties(KConfigGroup&) () at /opt/kf5/lib/libakregatorprivate.so.5
#9  0x00007fc455fe8c8f in Akregator::MainWidget::saveProperties(KConfigGroup&) () at /opt/kf5/lib/plugins/akregatorpart.so
#10 0x00007fc455fe4ee0 in  () at /opt/kf5/lib/plugins/akregatorpart.so
#11 0x00007fc455ffebbd in  () at /opt/kf5/lib/plugins/akregatorpart.so
#12 0x00007fc4862fb5c1 in QObject::event(QEvent*) () at /opt/qt5/lib/libQt5Core.so.5
#13 0x00007fc48701eaec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /opt/qt5/lib/libQt5Widgets.so.5
#14 0x00007fc487025df1 in QApplication::notify(QObject*, QEvent*) () at /opt/qt5/lib/libQt5Widgets.so.5
#15 0x00007fc4862cf758 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /opt/qt5/lib/libQt5Core.so.5
#16 0x00007fc4862d20dd in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /opt/qt5/lib/libQt5Core.so.5
#17 0x00007fc486321dc3 in  () at /opt/qt5/lib/libQt5Core.so.5
#18 0x00007fc47298afb7 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#19 0x00007fc47298b1e8 in  () at /usr/lib/libglib-2.0.so.0
#20 0x00007fc47298b28c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#21 0x00007fc4863221cf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /opt/qt5/lib/libQt5Core.so.5
#22 0x00007fc4862cdefa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /opt/qt5/lib/libQt5Core.so.5
#23 0x00007fc4862d63c4 in QCoreApplication::exec() () at /opt/qt5/lib/libQt5Core.so.5
#24 0x0000000000408c11 in  ()
#25 0x00007fc485443291 in __libc_start_main () at /lib/libc.so.6
#26 0x0000000000408dca in _start ()

Possible duplicates by query: bug 381137.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-06-19 12:30:31 UTC

*** This bug has been marked as a duplicate of bug 378513 ***