Bug 381166 - Korganizer / Kontakt crash [EventViews::AgendaView::placeDecorations]
Summary: Korganizer / Kontakt crash [EventViews::AgendaView::placeDecorations]
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: agendaview (weekview) (show other bugs)
Version: 5.4.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 352256 385025 388019 389365 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-13 18:04 UTC by Mike
Modified: 2019-11-16 17:18 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2017-06-13 18:04:58 UTC
This was an a recently upgraded (crashes since the upgrade) fedora 25 system. It crashes every time.  If a run kontact and choose calendar, to-do's, or journal, I get the same crash.

The korganizer rpm info:
korganizer.x86_64                       16.12.3-1.fc25             @updates     
korganizer-libs.x86_64                  16.12.3-1.fc25             @@commandline

Also the Crash Reporting Assistant comes up on a crash and that is where I got the backtrace below. But when I get to the dialog for logging into the KDE bug tracking system, the 'Login' button remains desensitized and I'm unable to login/use the assistant.


Application: KOrganizer (korganizer), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff92bd60980 (LWP 28746))]

Thread 6 (Thread 0x7ff913fff700 (LWP 28783)):
#0  0x00007ff93f98a879 in g_mutex_lock () at /lib64/libglib-2.0.so.0
#1  0x00007ff93f945060 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007ff93f94527c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007ff9515c66eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00007ff95157768a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007ff9513d45e3 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00007ff9513d89ca in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#7  0x00007ff94eba573a in start_thread () at /lib64/libpthread.so.0
#8  0x00007ff9507cbe7f in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7ff918a0b700 (LWP 28778)):
#0  0x00007ff9507bff3d in poll () at /lib64/libc.so.6
#1  0x00007ff93f945166 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007ff93f94527c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007ff9515c66eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00007ff95157768a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007ff9513d45e3 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00007ff9513d89ca in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#7  0x00007ff94eba573a in start_thread () at /lib64/libpthread.so.0
#8  0x00007ff9507cbe7f in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7ff91920c700 (LWP 28773)):
#0  0x00007ff9507bff3d in poll () at /lib64/libc.so.6
#1  0x00007ff93f945166 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007ff93f94527c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007ff9515c66eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00007ff95157768a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007ff9513d45e3 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00007ff95a785fb9 in QDBusConnectionManager::run() () at /lib64/libQt5DBus.so.5
#7  0x00007ff9513d89ca in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#8  0x00007ff94eba573a in start_thread () at /lib64/libpthread.so.0
#9  0x00007ff9507cbe7f in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7ff91120c700 (LWP 28772)):
#0  0x00007ff9507bff3d in poll () at /lib64/libc.so.6
#1  0x00007ff93f945166 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007ff93f9454f2 in g_main_loop_run () at /lib64/libglib-2.0.so.0
#3  0x00007ff92f80aa76 in gdbus_shared_thread_func () at /lib64/libgio-2.0.so.0
#4  0x00007ff93f96cb93 in g_thread_proxy () at /lib64/libglib-2.0.so.0
#5  0x00007ff94eba573a in start_thread () at /lib64/libpthread.so.0
#6  0x00007ff9507cbe7f in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7ff919a0d700 (LWP 28771)):
#0  0x00007ff9507bbb0d in read () at /lib64/libc.so.6
#1  0x00007ff93f9894d0 in g_wakeup_acknowledge () at /lib64/libglib-2.0.so.0
#2  0x00007ff93f944c83 in g_main_context_check () at /lib64/libglib-2.0.so.0
#3  0x00007ff93f945104 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#4  0x00007ff93f94527c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#5  0x00007ff93f9452c1 in glib_worker_main () at /lib64/libglib-2.0.so.0
#6  0x00007ff93f96cb93 in g_thread_proxy () at /lib64/libglib-2.0.so.0
#7  0x00007ff94eba573a in start_thread () at /lib64/libpthread.so.0
#8  0x00007ff9507cbe7f in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7ff92bd60980 (LWP 28746)):
[KCrash Handler]
#4  0x00007ff959a58275 in EventViews::AgendaView::placeDecorations(QList<EventViews::CalendarDecoration::Decoration*>&, QDate const&, QWidget*, bool) () at /lib64/libKF5EventViews.so.5
#5  0x00007ff959a62494 in EventViews::AgendaView::createDayLabels(bool) () at /lib64/libKF5EventViews.so.5
#6  0x00007ff959a63276 in EventViews::AgendaView::init(QDate const&, QDate const&) () at /lib64/libKF5EventViews.so.5
#7  0x00007ff959a63613 in EventViews::AgendaView::AgendaView(QSharedPointer<EventViews::Prefs> const&, QDate const&, QDate const&, bool, bool, QWidget*) () at /lib64/libKF5EventViews.so.5
#8  0x00007ff95a248630 in KOAgendaView::KOAgendaView(QWidget*, bool) () at /lib64/libkorganizerprivate.so.5
#9  0x00007ff95a23c3dd in KOViewManager::showAgendaView() () at /lib64/libkorganizerprivate.so.5
#10 0x00007ff95a23ce21 in KOViewManager::readSettings(KConfig*) () at /lib64/libkorganizerprivate.so.5
#11 0x00007ff95a201f90 in CalendarView::readSettings() () at /lib64/libkorganizerprivate.so.5
#12 0x00007ff95a1c82a2 in ActionManager::createCalendarAkonadi() () at /lib64/libkorganizerprivate.so.5
#13 0x0000561ee6bd9353 in KOrganizer::init(bool) ()
#14 0x0000561ee6bda283 in KOrganizerApp::processCalendar(QUrl const&) ()
#15 0x0000561ee6bdad5a in KOrganizerApp::activate(QStringList const&, QString const&) ()
#16 0x00007ff95a4d58dd in KontactInterface::PimUniqueApplication::start(QStringList const&, bool) () at /lib64/libKF5KontactInterface.so.5
#17 0x0000561ee6bd7dee in main ()
Comment 1 Christoph Feck 2017-06-27 21:53:32 UTC
*** Bug 352256 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2018-01-02 17:56:45 UTC
*** Bug 385025 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2018-01-02 17:56:50 UTC
*** Bug 388019 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2018-02-15 00:01:54 UTC
*** Bug 389365 has been marked as a duplicate of this bug. ***
Comment 5 Philippe Cloutier 2018-06-17 13:41:27 UTC
So you are saying that KOrganizer crashes immediately at startup, but Kontact for its part does not, and only crashes when choosing calendar, to-do's or journal. Is that correct? If so, issue #388019, which was marked as a duplicate, seems different.
Comment 6 Mike 2018-06-18 15:27:07 UTC
(In reply to Filipus Klutiero from comment #5)
> So you are saying that KOrganizer crashes immediately at startup, but
> Kontact for its part does not, and only crashes when choosing calendar,
> to-do's or journal. Is that correct? If so, issue #388019, which was marked
> as a duplicate, seems different.

Yes, that is what was happening. korganzer crashed and kontacts ran fine. I have since been able to update to a newer version of korganizer (and the other KDE tools), and the problem went away.  I don't know what the fix was, but korganizer runs okay for me now.  Currently using:

korganizer.x86_64                       17.12.3-1.fc26     
korganizer-libs.x86_64                  17.12.3-1.fc26
Comment 7 Philippe Cloutier 2018-06-20 01:58:15 UTC
Thank you for triaging Christoph