Bug 381079 - Oversaturated thumbs for sRGB images
Summary: Oversaturated thumbs for sRGB images
Status: RESOLVED DUPLICATE of bug 214856
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: Other (add details in bug description)
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-10 21:25 UTC by Unknown
Modified: 2017-11-16 00:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (297.19 KB, image/png)
2017-11-09 21:45 UTC, Unknown
Details
original image (716.46 KB, image/png)
2017-11-09 21:45 UTC, Unknown
Details
color settings (71.80 KB, image/png)
2017-11-09 22:32 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2017-06-10 21:25:57 UTC
gwenview5-16.08.2-1.1.x86_64 on openSUSE Leap 42.2 shows oversaturated thumbs (perhaps not color managed properly) for images which are properly displayed when viewed otherwise (after double clicking the thumb). It seems to happen for images without color profile or with embedded sRGB profile.
Comment 1 Nate Graham 2017-11-09 20:02:06 UTC
Can you attach a sample image?
Comment 2 Unknown 2017-11-09 21:45:16 UTC
Created attachment 108770 [details]
screenshot

[~]: rpm -q gwenview5
gwenview5-17.04.2-1.5.x86_64
Comment 3 Unknown 2017-11-09 21:45:34 UTC
Created attachment 108771 [details]
original image
Comment 4 Nate Graham 2017-11-09 21:58:05 UTC
Thank you! I wonder if this is related to or caused by https://bugs.kde.org/show_bug.cgi?id=359909...?
Comment 5 Unknown 2017-11-09 22:32:18 UTC
Created attachment 108772 [details]
color settings

(In reply to Nate Graham from comment #4)
> Thank you! I wonder if this is related to or caused by
> https://bugs.kde.org/show_bug.cgi?id=359909...?

TLDR: I use EIZO CG275W calibrated with ColorNavigator (in Windows environment). FWIW EIZO CG monitors store their calibration LUTs in the monitor hardware. I also have oyranos installed. The ICC profile in Linux is soft-linked to the ICC file on the Windows partition and assigned in KDE through Settings->Configure Desktop->Color Management->Devices. In Color Management settings I have relative colorimetric intent (see attachment). In other programs like RawTherapee or digikam there are no such discrepancies, so I don't think it is related to monitor profile in any way.

Please let me know if there any other settings which I need to check.
Comment 6 Christoph Feck 2017-11-16 00:00:29 UTC
Thumbnails are not created by Gwenview, but by the KIO thumbnailer, which unfortunately does not support color profiles yet.

*** This bug has been marked as a duplicate of bug 214856 ***