Bug 380831 - Konqueror crashed on start
Summary: Konqueror crashed on start
Status: RESOLVED DUPLICATE of bug 377129
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 5.0.97
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-06-04 17:11 UTC by tsipordey_ilya
Modified: 2017-06-13 19:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tsipordey_ilya 2017-06-04 17:11:08 UTC
Application: konqueror (5.0.97)

Qt Version: 5.7.1
Frameworks Version: 5.34.0
Operating System: Linux 4.8.0-53-generic x86_64
Distribution: KDE neon User Edition 5.10

-- Information about the crash:
- What I was doing when the application crashed: just open the konqueror after install

- Unusual behavior I noticed: crashed on start whithout any work

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fed939d7940 (LWP 8424))]

Thread 5 (Thread 0x7fed8533b700 (LWP 8430)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fed854b86f4 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007fed854b8739 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007fed9d59f6ba in start_thread (arg=0x7fed8533b700) at pthread_create.c:333
#4  0x00007feda62da82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fed86b4f700 (LWP 8427)):
#0  0x00007feda62ceb5d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fed9b4e238c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fed9b4e249c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007feda192275b in QEventDispatcherGlib::processEvents (this=0x7fed800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007feda18cd0ba in QEventLoop::exec (this=this@entry=0x7fed86b4ec50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#5  0x00007feda16fcf64 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:507
#6  0x00007feda6a32735 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007feda1701b48 in QThreadPrivate::start (arg=0x7feda6aa6d60) at thread/qthread_unix.cpp:368
#8  0x00007fed9d59f6ba in start_thread (arg=0x7fed86b4f700) at pthread_create.c:333
#9  0x00007feda62da82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fed87a4e700 (LWP 8426)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fed8b9950f3 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007fed8b994817 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007fed9d59f6ba in start_thread (arg=0x7fed87a4e700) at pthread_create.c:333
#4  0x00007feda62da82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fed915ad700 (LWP 8425)):
#0  0x00007feda62ceb5d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fed9cf1dc62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fed9cf1f8d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fed934ded79 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007feda1701b48 in QThreadPrivate::start (arg=0x19111c0) at thread/qthread_unix.cpp:368
#5  0x00007fed9d59f6ba in start_thread (arg=0x7fed915ad700) at pthread_create.c:333
#6  0x00007feda62da82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fed939d7940 (LWP 8424)):
[KCrash Handler]
#6  0x00007feda6209428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007feda620b02a in __GI_abort () at abort.c:89
#8  0x00007feda16e8811 in qt_message_fatal (context=..., message=<synthetic pointer>) at global/qlogging.cpp:1682
#9  QMessageLogger::fatal (this=this@entry=0x7ffc685f2720, msg=msg@entry=0x7fecfb4a80ad "Could not find %s") at global/qlogging.cpp:793
#10 0x00007fecf7d43ea6 in (anonymous namespace)::subProcessPath () at /workspace/build/src/core/web_engine_library_info.cpp:149
#11 WebEngineLibraryInfo::getPath (key=key@entry=4000) at /workspace/build/src/core/web_engine_library_info.cpp:268
#12 0x00007fecf7d3f41d in QtWebEngineCore::WebEngineContext::WebEngineContext (this=0x1dd4380) at /workspace/build/src/core/web_engine_context.cpp:276
#13 0x00007fecf7d40fa5 in QtWebEngineCore::WebEngineContext::current () at /workspace/build/src/core/web_engine_context.cpp:207
#14 0x00007fecf7d3169e in QtWebEngineCore::WebContentsAdapterPrivate::WebContentsAdapterPrivate (this=0x1dd8b80) at /workspace/build/src/core/web_contents_adapter.cpp:341
#15 0x00007fecf7d3454e in QtWebEngineCore::WebContentsAdapter::WebContentsAdapter (this=0x1dd4420, webContents=0x0) at /workspace/build/src/core/web_contents_adapter.cpp:380
#16 0x00007fecfc6d4fb1 in QWebEnginePagePrivate::QWebEnginePagePrivate(QWebEngineProfile*) () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#17 0x00007fecfc6d5b84 in QWebEnginePage::QWebEnginePage(QObject*) () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#18 0x00007fecfc7269a2 in WebEnginePage::WebEnginePage (this=0x1dd88c0, part=0x1dd2f50, parent=<optimized out>) at /workspace/build/webenginepart/src/webenginepage.cpp:73
#19 0x00007fecfc71f512 in WebEngineView::WebEngineView (this=0x1dd4910, part=0x1dd2f50, parent=<optimized out>) at /workspace/build/webenginepart/src/webengineview.cpp:69
#20 0x00007fecfc713a89 in WebEnginePart::WebEnginePart (this=0x1dd2f50, parentWidget=0x1dca9a0, parent=<optimized out>, cachedHistory=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /workspace/build/webenginepart/src/webenginepart.cpp:121
#21 0x00007fecfc979c6e in WebEngineFactory::create (this=this@entry=0x1d80960, iface=<optimized out>, parentWidget=parentWidget@entry=0x1dca9a0, parent=parent@entry=0x0, args=..., keyword=...) at /workspace/build/webenginepart/src/webenginepartfactory.cpp:45
#22 0x00007feda661c9ef in KPluginFactory::create<KParts::ReadOnlyPart> (args=..., keyword=..., parent=0x0, parentWidget=0x1dca9a0, this=0x1d80960) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:521
#23 KonqViewFactory::create (this=this@entry=0x7ffc685f2ee0, parentWidget=parentWidget@entry=0x1dca9a0, parent=parent@entry=0x0) at /workspace/build/src/konqfactory.cpp:64
#24 0x00007feda6608167 in KonqFrame::attach (this=0x1dca9a0, viewFactory=...) at /workspace/build/src/konqframe.cpp:144
#25 0x00007feda65f3dfc in KonqView::switchView (this=this@entry=0x1dd2b20, viewFactory=...) at /workspace/build/src/konqview.cpp:250
#26 0x00007feda65f4b34 in KonqView::KonqView (this=0x1dd2b20, viewFactory=..., viewFrame=<optimized out>, mainWindow=<optimized out>, service=..., partServiceOffers=..., appServiceOffers=..., serviceType=..., passiveMode=false) at /workspace/build/src/konqview.cpp:119
#27 0x00007feda65fc49b in KonqViewManager::setupView (this=this@entry=0x1b62aa0, parentContainer=0x1dbfcc8, viewFactory=..., service=..., partServiceOffers=..., appServiceOffers=..., serviceType=..., passiveMode=false, openAfterCurrentPage=false, pos=-1) at /workspace/build/src/konqviewmanager.cpp:846
#28 0x00007feda6601b42 in KonqViewManager::createFirstView (this=0x1b62aa0, mimeType=..., serviceName=...) at /workspace/build/src/konqviewmanager.cpp:80
#29 0x00007feda663d2f3 in KonqMainWindow::openView (this=this@entry=0x1b319e0, mimeType=..., _url=..., childView=childView@entry=0x0, req=...) at /workspace/build/src/konqmainwindow.cpp:881
#30 0x00007feda663e3d8 in KonqMainWindow::openUrl (this=this@entry=0x1b319e0, _view=_view@entry=0x0, _url=..., _mimeType=..., _req=..., trustedSource=trustedSource@entry=false) at /workspace/build/src/konqmainwindow.cpp:651
#31 0x00007feda663ee3a in KonqMainWindow::openFilteredUrl (this=this@entry=0x1b319e0, url=..., req=...) at /workspace/build/src/konqmainwindow.cpp:468
#32 0x00007feda663ef64 in KonqMainWindow::openFilteredUrl (this=this@entry=0x1b319e0, _url=..., inNewTab=inNewTab@entry=false, tempFile=tempFile@entry=false) at /workspace/build/src/konqmainwindow.cpp:485
#33 0x00007feda663ffbc in KonqMainWindow::KonqMainWindow (this=0x1b319e0, initialURL=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /workspace/build/src/konqmainwindow.cpp:296
#34 0x00007feda66245c0 in KonqPreloadingHandler::makePreloadedWindow (this=this@entry=0x7feda68b1db0 <s_preloadingHandler>) at /workspace/build/src/konqpreloadinghandler.cpp:87
#35 0x00007feda6624703 in KonqPreloadingHandler::registerAsPreloaded (this=this@entry=0x7feda68b1db0 <s_preloadingHandler>) at /workspace/build/src/konqpreloadinghandler.cpp:52
#36 0x00007feda666c5ff in kdemain (argc=2, argv=<optimized out>) at /workspace/build/src/konqmain.cpp:152
#37 0x00007feda61f4830 in __libc_start_main (main=0x4006e0 <main(int, char**)>, argc=2, argv=0x7ffc685f3af8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc685f3ae8) at ../csu/libc-start.c:291
#38 0x0000000000400719 in _start ()

Possible duplicates by query: bug 377996, bug 366235, bug 364721, bug 364342, bug 364090.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-06-13 19:32:55 UTC

*** This bug has been marked as a duplicate of bug 377129 ***