Bug 380485 - Akregator crashes on startup
Summary: Akregator crashes on startup
Status: RESOLVED DUPLICATE of bug 377129
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 5.5.1
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-06-02 22:44 UTC by Bogdan Olar
Modified: 2017-06-13 16:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bogdan Olar 2017-06-02 22:44:46 UTC
Application: akregator (5.5.1)

Qt Version: 5.7.1
Frameworks Version: 5.34.0
Operating System: Linux 4.8.0-53-generic x86_64
Distribution: KDE neon User Edition 5.10

-- Information about the crash:
Akregator crashes whenever it's launched.

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd370f179c0 (LWP 3523))]

Thread 2 (Thread 0x7fd36c8bf700 (LWP 3525)):
#0  0x00007fd39172ca79 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd3916e7b41 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd3916e8307 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd3916e849c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd39919075b in QEventDispatcherGlib::processEvents (this=0x7fd3600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007fd39913b0ba in QEventLoop::exec (this=this@entry=0x7fd36c8bebd0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007fd398f6af64 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:507
#7  0x00007fd39c0f4735 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007fd398f6fb48 in QThreadPrivate::start (arg=0x7fd39c168d60) at thread/qthread_unix.cpp:368
#9  0x00007fd3936bd6ba in start_thread (arg=0x7fd36c8bf700) at pthread_create.c:333
#10 0x00007fd39887c82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd370f179c0 (LWP 3523)):
[KCrash Handler]
#6  0x00007fd3987ab428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007fd3987ad02a in __GI_abort () at abort.c:89
#8  0x00007fd398f56811 in qt_message_fatal (context=..., message=<synthetic pointer>) at global/qlogging.cpp:1682
#9  QMessageLogger::fatal (this=this@entry=0x7ffcd64dbf90, msg=msg@entry=0x7fd38d4220ad "Could not find %s") at global/qlogging.cpp:793
#10 0x00007fd389cbdea6 in (anonymous namespace)::subProcessPath () at /workspace/build/src/core/web_engine_library_info.cpp:149
#11 WebEngineLibraryInfo::getPath (key=key@entry=4000) at /workspace/build/src/core/web_engine_library_info.cpp:268
#12 0x00007fd389cb941d in QtWebEngineCore::WebEngineContext::WebEngineContext (this=0x18f87f0) at /workspace/build/src/core/web_engine_context.cpp:276
#13 0x00007fd389cbafa5 in QtWebEngineCore::WebEngineContext::current () at /workspace/build/src/core/web_engine_context.cpp:207
#14 0x00007fd389c5deb1 in QtWebEngineCore::BrowserContextAdapter::defaultContext () at /workspace/build/src/core/browser_context_adapter.cpp:177
#15 0x00007fd39c080090 in QWebEngineProfile::defaultProfile() () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#16 0x00007fd39c084c19 in QWebEngineSettings::defaultSettings() () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#17 0x00007fd365588c06 in Akregator::Part::initFonts (this=this@entry=0x18f47a0) at /workspace/build/src/akregator_part.cpp:791
#18 0x00007fd36558b456 in Akregator::Part::Part (this=this@entry=0x18f47a0, parentWidget=parentWidget@entry=0x17b3540, parent=parent@entry=0x17b3540, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /workspace/build/src/akregator_part.cpp:259
#19 0x00007fd36558e481 in KPluginFactory::createPartInstance<Akregator::Part> (parentWidget=0x17b3540, parent=0x17b3540, args=...) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:485
#20 0x00007fd39a50397f in KPluginFactory::create (this=this@entry=0x18f7ec0, iface=0x7fd39b1e8258 "KParts::ReadOnlyPart", parentWidget=parentWidget@entry=0x17b3540, parent=parent@entry=0x17b3540, args=..., keyword=...) at /workspace/build/src/lib/plugin/kpluginfactory.cpp:145
#21 0x000000000040a3a8 in KPluginFactory::create<KParts::ReadOnlyPart> (args=..., parent=0x17b3540, this=0x18f7ec0) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:497
#22 Akregator::MainWindow::loadPart (this=this@entry=0x17b3540) at /workspace/build/src/mainwindow.cpp:110
#23 0x0000000000408c32 in Akregator::Application::activate (this=0x7ffcd64dce80, args=..., workingDir=...) at /workspace/build/src/main.cpp:65
#24 0x00007fd39bb5fa3d in KontactInterface::PimUniqueApplication::start (arguments=..., unique=unique@entry=true) at /workspace/build/src/pimuniqueapplication.cpp:135
#25 0x0000000000408462 in main (argc=1, argv=0x7ffcd64dcfe8) at /workspace/build/src/main.cpp:103

Possible duplicates by query: bug 377996, bug 364721, bug 364342, bug 361902, bug 355096.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-06-13 16:24:08 UTC

*** This bug has been marked as a duplicate of bug 377129 ***