Bug 379727 - Line height issues: too small, too large, broken :(
Summary: Line height issues: too small, too large, broken :(
Status: RESOLVED UPSTREAM
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 16.12
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL: https://bugreports.qt.io/browse/QTBUG...
Keywords: investigated, triaged
: 372629 382902 383005 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-11 15:19 UTC by Rafael Linux User
Modified: 2018-09-19 14:30 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Capture of Kate with the transversal lines (138.48 KB, image/png)
2017-05-11 15:19 UTC, Rafael Linux User
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Linux User 2017-05-11 15:19:19 UTC
Created attachment 105445 [details]
Capture of Kate with the transversal lines

Each time I load a file or resize Kate window, transversal lines of different thickness appears on Kate, till I scroll text, and so on.
Comment 1 Christoph Cullmann 2017-12-20 20:29:48 UTC
*** Bug 382902 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Cullmann 2017-12-20 21:32:00 UTC
*** Bug 372629 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Cullmann 2017-12-20 21:32:41 UTC
*** Bug 383005 has been marked as a duplicate of this bug. ***
Comment 4 RJVB 2017-12-25 09:28:27 UTC
Does this occur with all window managers?
Comment 5 Rafael Linux User 2017-12-26 11:55:51 UTC
Well, it happened to me in KDE. Don't know if in other UI is happening.
Comment 6 Christoph Cullmann 2018-01-27 15:54:14 UTC
I am actually able to reproduce this issue with any QTextLayout based applicaton.

Aka here my bugreport to Qt, using QtCreator as editor ;=)

https://bugreports.qt.io/browse/QTBUG-66036

=> Unfortunately I think, we can't fix that in KTextEditor.
I looked at the code and debugged the sizes, the layout sizes and the line height sizes match perfectly, in all zoom factors.
Just sometimes Qt renders too few pixels and that leads to the stray background leaking through, horizontally and vertically...
Comment 7 Nate Graham 2018-01-27 15:58:05 UTC
If we can't work around the issue in Kate, perhaps we should mark the bug as RESOLVED/NEEDINFO UPSTREAM?
Comment 8 Christoph Cullmann 2018-01-27 16:01:32 UTC
Guess you are right.
As we don't know where in the layouting/drawing Qt will leave gaps, there is no chance to fix that, even if we would start to try to "overpaint" more.
It even happens inside text glyph runs in some zoom factors...
Comment 9 Rafael Linux User 2018-04-08 01:03:46 UTC
I must say that nowadays, I can't reproduce again the bug, at any zoom I apply. I don't know exactly when it were fixed by some update. 

Kate
Versión 17.04.2
KDE Frameworks 5.32.0
Qt 5.6.2 (compilado con 5.6.2)
El sistema de ventanas xcb

So I can't help on this problems, cause for me is SOLVED.
Comment 10 Andrew Crouthamel 2018-09-19 14:30:04 UTC
This bug has had its resolution changed, but accidentally has been left in NEEDSINFO status. I am thus closing this bug and setting the status as RESOLVED to reflect the resolution change.