Bug 379687 - Kwin Crash
Summary: Kwin Crash
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.9.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-05-10 08:04 UTC by Seth Izenzon
Modified: 2017-05-10 15:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Seth Izenzon 2017-05-10 08:04:44 UTC
Application: kwin_x11 (5.9.4)

Qt Version: 5.7.1
Frameworks Version: 5.31.0
Operating System: Linux 4.10.0-20-generic x86_64
Distribution: Ubuntu 17.04

-- Information about the crash:
This may be related to my other bug reports, but I upgraded the Nvidia driver to the latest non beta and it still crashes even when OpenGL semas to be fixed. Maybe it is still broke?

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f55948e7900 (LWP 4022))]

Thread 5 (Thread 0x7f557499d700 (LWP 6218)):
#0  0x00007f5594322251 in __GI_ppoll (fds=0x7f556806ed38, nfds=1, timeout=<optimized out>, sigmask=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:39
#1  0x00007f5591bca251 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f5591bcbb4a in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f5591b7888a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f55919a5fe3 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f558c6f8df5 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f55919aac98 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f558d9a56da in start_thread (arg=0x7f557499d700) at pthread_create.c:456
#8  0x00007f559432e17f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 4 (Thread 0x7f555d765700 (LWP 4099)):
#0  0x00007f558d9ab510 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5590d262c4 in  () at /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007f5590d26309 in  () at /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007f558d9a56da in start_thread (arg=0x7f555d765700) at pthread_create.c:456
#4  0x00007f559432e17f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 3 (Thread 0x7f556efad700 (LWP 4086)):
#0  0x00007f5594322251 in __GI_ppoll (fds=0x7f5560000ac8, nfds=1, timeout=<optimized out>, sigmask=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:39
#1  0x00007f5591bca251 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f5591bcbb4a in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f5591b7888a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f55919a5fe3 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f558c6f8df5 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f55919aac98 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f558d9a56da in start_thread (arg=0x7f556efad700) at pthread_create.c:456
#8  0x00007f559432e17f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 2 (Thread 0x7f557d735700 (LWP 4034)):
#0  0x00007f559432218d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f5588f10576 in  () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5588f1068c in g_main_context_iteration () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5591bcef2b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5591b7888a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f55919a5fe3 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f558b8c65c5 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f55919aac98 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f558d9a56da in start_thread (arg=0x7f557d735700) at pthread_create.c:456
#9  0x00007f559432e17f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 1 (Thread 0x7f55948e7900 (LWP 4022)):
[KCrash Handler]
#6  0x0000000040c779bb in  ()
#7  0x00007f555f3bb074 in  () at /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.381.22
#8  0x00007f555f3c0348 in  () at /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.381.22
#9  0x00007f555ef8d938 in  () at /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.381.22
#10 0x00007f55923db484 in QOpenGLTextureGlyphCache::resizeTextureData(int, int) () at /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#11 0x00007f559237c156 in QTextureGlyphCache::fillInPendingGlyphs() () at /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#12 0x00007f558cdb1dc7 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f558cdafc74 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f558ce37b17 in QQuickTextNode::addGlyphs(QPointF const&, QGlyphRun const&, QColor const&, QQuickText::TextStyle, QColor const&, QSGNode*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f558ce3c824 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f558ce38a9c in QQuickTextNode::addTextLayout(QPointF const&, QTextLayout*, QColor const&, QQuickText::TextStyle, QColor const&, QColor const&, QColor const&, QColor const&, int, int, int, int) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007f558ce374f7 in QQuickText::updatePaintNode(QSGNode*, QQuickItem::UpdatePaintNodeData*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#18 0x00007f558cdf4810 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#19 0x00007f558cdf502b in QQuickWindowPrivate::updateDirtyNodes() () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#20 0x00007f558cdf609e in QQuickWindowPrivate::syncSceneGraph() () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#21 0x00007f558ceda72a in QQuickRenderControl::sync() () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#22 0x00007f556efcb070 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#23 0x00007f5591ba681e in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f5591bb2e38 in QTimer::timerEvent(QTimerEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007f5591ba7313 in QObject::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007f559285935c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#27 0x00007f5592860b11 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#28 0x00007f5591b7a8a0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f5591bcdeae in QTimerInfoList::activateTimers() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007f5591bcbdba in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007f557c7fa9fd in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#32 0x00007f5591b7888a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#33 0x00007f5591b80ffc in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#34 0x00007f55945f7112 in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#35 0x00007f55942463f1 in __libc_start_main (main=0x5601edf597e0, argc=3, argv=0x7ffcbfa80978, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffcbfa80968) at ../csu/libc-start.c:291
#36 0x00005601edf5981a in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2017-05-10 15:13:52 UTC
as a workaround use the breeze window decoration

*** This bug has been marked as a duplicate of bug 361236 ***