Bug 379189 - Delete does not work for multiselection
Summary: Delete does not work for multiselection
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: commands and actions (show other bugs)
Version: 5.4.3
Platform: Other Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-25 11:41 UTC by Martin van Es
Modified: 2017-10-16 16:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin van Es 2017-04-25 11:41:40 UTC
Since upgrade to Kmail 5.4.3 I'm unable to Delete mails when multiple mails are selected. Mind that I don't mean "Move to Trash". I'm talking about "Delete" (skip trash) which has default shortcut shift-del attached to it. When I select one mail I can shift-delete it. When I select two or more mails, this fails.
Comment 1 Martin van Es 2017-04-25 12:00:56 UTC
I've tested a little further and now notice that the mail list looses focus when (multi)selecting mails (it seems focus moves to the mail window, but I'm not sure). If I'm able to craftily refocus the maillist (while keeping the multiselection) I can shift-del the mails.
Comment 2 Tom Chiverton 2017-06-11 08:33:17 UTC
Still present in latest KDE Neon (v5.5.2).

Single delete on messages in my IMAP inbox works. Shift-select many and press delete, none of them are removed.
Comment 3 Laurent Montel 2017-06-12 04:38:03 UTC
see #380182

Fixed in 5.5.3
Comment 4 Kunszt Arpad 2017-08-21 06:39:43 UTC
Could you please reopen this bug as I'm using 5.5.3 and this bug is still persist on that version.
Comment 5 Martin van Es 2017-08-21 06:52:47 UTC
I doubt this is a duplicate of 380182. That bug speaks of inconsistent removals between kmail and server. This bug is about a focus problem on the mail list preventing deletion in the first place.
Comment 6 Kunszt Arpad 2017-08-21 06:59:27 UTC
I think #373969 might be the duplicate of this.
Comment 7 Martin van Es 2017-10-16 16:49:07 UTC
This is fixed for me after update to Ubuntu 17.10 Artful, Plasma 5.11, Kmail 5.5.3.