Bug 379182 - Akregator middle mouse button stopped working after update of KDE Applications to 17.04
Summary: Akregator middle mouse button stopped working after update of KDE Application...
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR crash with 25 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-25 04:21 UTC by avlas
Modified: 2021-01-16 04:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description avlas 2017-04-25 04:21:06 UTC
Application: akregator (5.5.0)

Qt Version: 5.7.1
Frameworks Version: 5.33.0
Operating System: Linux 4.10.0-20-generic x86_64
Distribution: KDE neon User Edition 5.9

-- Information about the crash:
Most of the times clicking on a link with the mouse middle button just fails to do anything, sometimes it is worse and makes Kontact crash. 

For this to happen, configuration of the middle button has to be set to open in a tab. If so, crashes are reproducible if first one opens the link in a tab via right mouse button, and then repeats the same but this time with the middle mouse button.

The crash can be reproduced every time. It happens when Akregator is used inside Kontact as well as when it is used as a separated application.

-- Backtrace:
A useful backtrace could not be generated. I installed the Debug symbols packages for Akregator and Kontact but the backtrace application fails to show any information at all wrt /usr/bin/kontact and /usr/bin/akregator.
Comment 1 avlas 2017-04-25 04:28:30 UTC
Just to be completely clear:

- "clicking on a link with the mouse middle button just fails to do anything" happens irrespective of the configuration of the middle mouse button

- crashes of Kontact/Akregator honly appen when mouse middle button is set to open link in a tab or in a background tab, and it is reproducible following the steps specified above.
Comment 2 Justin Zobel 2020-12-17 05:28:23 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 3 Bug Janitor Service 2021-01-01 04:36:44 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2021-01-16 04:35:45 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!