Bug 379104 - creating a plot or a fit must be improved
Summary: creating a plot or a fit must be improved
Status: RESOLVED FIXED
Alias: None
Product: LabPlot2
Classification: Applications
Component: frontend (show other bugs)
Version: 2.4.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Alexander Semke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-23 01:02 UTC by Uwe Stöhr
Modified: 2017-10-31 14:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Stöhr 2017-04-23 01:02:26 UTC
Take for example the case that you just have to make a fit.

At first how it is done in LabPlot 2.4:
1. create a new worksheet
2. create there an xy-plot
3. add there a xy-curve
4. select there the data
5. go back to xy-plot (very unintuitive)
6. use the menu Analysis -> Data fitting
7. select there the data again
8. do the fit

Now how it is done in MagicPlot:
1. highlight 2 columns of the spreadsheet and right-click
2. select "Create Fit Plot-> Line + Marker"
3. do the fit

This is very quick and intuitive. The plot is automatically created and the fit window is opened. Since one highlighted columns it is also already clear what data have to be fitted. If one needs something else, one can of course change the data source.

I think it is not unfair to use MagicPlot as reference. Its aim is very similar to LabPlot.
Comment 1 Alexander Semke 2017-04-23 07:11:36 UTC
Hi Uwe,

thanks for your feedback!

The steps 2, 3 and 4 in LabPlot are only required if you want to plot the original data, too. In case you only want to create a fit, you select/create a plot, add a fit-curve and specify the data for it.

But I agree with you in general. We need to improve the usability here. One idea is to add all those analysis functions to the context menu of the xy-curve. For the use-cases where you have the data already plotted in the plot, you simply right-click on the curve in the plot and select "Fit" - with this a new fit-curve will be created and the data for the fit will be already selected. This would improve the worksheet-centric workflows. For spreadsheet-centric workflows like in your example with MagicPlot we'll also add similar functionality to the context menu in the spreadsheet. This is all very easy to implement and is just a matter of time. Besides of this, we'll add  some more generic wizards where the user will be guided through such an analysis process like fitting and where worksheets+plots+curves will be created automatically at the end. This is currently work in progress and we'll release this for 2.5.

As to the comparison with MagicPlot: I had a brief look now at this program. I see some modal dialogs for editing the properties which overlapp the underlying objects, obsolete scroll bars, etc. This program looks similarly overloaded as Origin. LabPlot is not perfect (yet), but I think it's not unfair to say here that there many things that are solved better in LabPlot.

Regards,
Alexander
Comment 2 Uwe Stöhr 2017-04-29 11:58:43 UTC
(In reply to Alexander Semke from comment #1)

> The steps 2, 3 and 4 in LabPlot are only required if you want to plot the
> original data, too.

This is the normal case. For my needs I have to show always the data and the fit in one plot.

> But I agree with you in general.

Good.

> As to the comparison with MagicPlot: I had a brief look now at this program.
> I see some modal dialogs for editing the properties which overlapp the
> underlying objects, obsolete scroll bars, etc. This program looks similarly
> overloaded as Origin.

I cannot reproduce this. I use the latest full version 2.7.2 (purchased by my company) maybe the free version is different.
I like it much more than Origin because I can work faster and more intuitive and much cheaper too. The point with the intuition is that one doesn't need LabPlot and friends every day. And after maybe 3 weeks after the last usage I cannot remember everything. Therefore an intuitive UI is important in my opinion.

Concerning MagicPlot, I was in contact with the developers and they built in especially for fits things I requested so it is maybe a bit unfair to use it as reference because MagicPlot does it as I like it personally.
Comment 3 Alexander Semke 2017-09-04 06:45:31 UTC
Git commit 01198875275622fabfebc2f32595ae9e6bbe07b3 by Alexander Semke.
Committed on 04/09/2017 at 06:45.
Pushed by asemke into branch 'master'.

Finished the implementation of fitting initiated via spreadsheet's context menu.
FIXED-IN: 2.5

M  +48   -12   src/backend/worksheet/plots/cartesian/CartesianPlot.cpp
M  +12   -12   src/backend/worksheet/plots/cartesian/XYFitCurve.cpp
M  +3    -1    src/backend/worksheet/plots/cartesian/XYFitCurve.h
M  +5    -5    src/kdefrontend/spreadsheet/PlotDataDialog.cpp

https://commits.kde.org/labplot/01198875275622fabfebc2f32595ae9e6bbe07b3
Comment 4 Uwe Stöhr 2017-10-31 01:22:37 UTC
Many thanks for the patch. I would like to test it. How can I do this? In the version 2.4 I downloaded today I don't see any difference and I cannot find a version of LabPlot 2.5 to test.
Comment 5 Alexander Semke 2017-10-31 07:23:14 UTC
The improvements are part of the next release, 2.5, that we plan finish in December. Part of the improvements is described in the recent blog 
https://labplot.kde.org/2017/09/21/short-update-on-recent-ux-improvements/

Couple of other new features related to the fitting procedure will be subject of the next blog to appear soon. After this we'll produce a windows build (beta release) and make it available on our homepage.
Comment 6 Uwe Stöhr 2017-10-31 14:04:06 UTC
> The improvements are part of the next release, 2.5

These are great news! I will test the new features thoroughly as soon as I can get a Windows build of 2.5. nevertheless I think it would be better to leave bugs open that are not fixed in the current release. If for example a user of LP 2.4 encounters the same or a similar problem he will find the existing open bug and won't open a new one.

For LyX (www.lyx.org/trac) we do this and mark bugs fixed for the next release as "fixed in branch". I guess the KDE bugtracker allows such a keyword or tag as well. Once LP 2.5 is available you can easily close al tagged bugs as fixed.