Bug 378986 - KMail 5.4.3: Attachments with non-ASCII characters get strange name
Summary: KMail 5.4.3: Attachments with non-ASCII characters get strange name
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 5.4.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-20 08:00 UTC by Axel Braun
Modified: 2017-05-28 09:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2017-04-20 08:00:49 UTC
I have an attachment called 'Gründung.pdf' added to KMail.
Result: The attachment is renamed to 'application-pdf-attachment' (all other attachments keep their name!)
Windoze-user complain 'they cant open the attachement' although the content seems to be OK
Comment 1 Laurent Montel 2017-04-23 06:37:29 UTC
Could you provide a screenshot about "renaming" ?
it's in viewer ? 
in composerview ?
etc.
Comment 2 Axel Braun 2017-04-23 08:34:15 UTC
Actually I cant reproduce it at the moment - but there was an update to some libQT and libKF5 libraries installed yesterday. I will send an update once I can reproduce.
Thanks
Axel
Comment 3 Christoph Feck 2017-05-07 12:11:25 UTC
If you can provide the information requested in comment #1, please add it.
Comment 4 Laurent Montel 2017-05-25 07:52:29 UTC
Wait for new info
Comment 5 Axel Braun 2017-05-28 09:32:15 UTC
I cant reproduce it in current 5.5.1, therefore closing.
Thanks for looking into this!