Bug 378880 - kontact Signal: Segmentation fault (11)
Summary: kontact Signal: Segmentation fault (11)
Status: RESOLVED DUPLICATE of bug 362817
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 5.3.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-17 16:22 UTC by Don Curtis
Modified: 2017-12-20 15:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Complete crash report (70.85 KB, text/plain)
2017-04-17 16:22 UTC, Don Curtis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Don Curtis 2017-04-17 16:22:45 UTC
Created attachment 105061 [details]
Complete crash report

Application: kontact (5.3.0 (QtWebEngine))

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.4.57-18.3-default x86_64
Distribution: "openSUSE Leap 42.2"

-- Information about the crash:
- What I was doing when the application crashed:
In the Address Book, clicked the symbol to change an e-Mail address to the "preferred address".

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f050e7847c0 (LWP 11239))]

** Shortened crash dump -- complete dump is attached. **

Thread 1 (Thread 0x7f050e7847c0 (LWP 11239)):
[KCrash Handler]
#6  0x00007f050bc27254 in QSortFilterProxyModelPrivate::proxy_to_source(QModelIndex const&) const (this=0x1c1bf60, proxy_index=...) at itemmodels/qsortfilterproxymodel.cpp:185
#7  0x00007f050bc27254 in QSortFilterProxyModelPrivate::proxy_to_source(QModelIndex const&) const (this=0x1c1bf60, proxy_index=...) at itemmodels/qsortfilterproxymodel.cpp:377
#8  0x00007f050bc2732d in QSortFilterProxyModel::mapToSource(QModelIndex const&) const (this=<optimized out>, proxyIndex=...) at itemmodels/qsortfilterproxymodel.cpp:2750
#9  0x00007f050bc29fce in QSortFilterProxyModelPrivate::store_persistent_indexes() (this=this@entry=0x1c1bf60) at itemmodels/qsortfilterproxymodel.cpp:1018
#10 0x00007f050bc2e2a6 in QSortFilterProxyModelPrivate::_q_sourceDataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=0x1c1bf60, source_top_left=..., source_bottom_right=..., roles=...) at itemmodels/qsortfilterproxymodel.cpp:1218
#11 0x00007f050bc301d8 in QSortFilterProxyModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsortfilterproxymodel.cpp:202
#12 0x00007f050bc87bb1 in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0xa18d570, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcadccd250) at kernel/qobject.cpp:3730
#13 0x00007f050bc88717 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0xa18d570, m=m@entry=0x7f050c0a3ca0 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcadccd250) at kernel/qobject.cpp:3595
#14 0x00007f050bcfe04c in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=this@entry=0xa18d570, _t1=..., _t2=..., _t3=...) at .moc/moc_qabstractitemmodel.cpp:566
#15 0x00007f050bc2e413 in QSortFilterProxyModelPrivate::_q_sourceDataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=0xa18d590, source_top_left=..., source_bottom_right=..., roles=...) at itemmodels/qsortfilterproxymodel.cpp:1251
#16 0x00007f050bc301d8 in QSortFilterProxyModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsortfilterproxymodel.cpp:202
#17 0x00007f050bc87bb1 in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0x1ccbae0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcadccd580) at kernel/qobject.cpp:3730
#18 0x00007f050bc88717 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x1ccbae0, m=m@entry=0x7f050c0a3ca0 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcadccd580) at kernel/qobject.cpp:3595
#19 0x00007f050bcfe04c in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=this@entry=0x1ccbae0, _t1=..., _t2=..., _t3=...) at .moc/moc_qabstractitemmodel.cpp:566
#20 0x00007f050a7aad3f in Akonadi::EntityTreeModelPrivate::dataChanged(QModelIndex const&, QModelIndex const&) (this=this@entry=0x3b56300, top=..., bottom=...) at /usr/src/debug/akonadi-16.08.2/src/core/models/entitytreemodel_p.cpp:1703
#21 0x00007f050a7b198b in Akonadi::EntityTreeModelPrivate::monitoredItemChanged(Akonadi::Item const&, QSet<QByteArray> const&) (this=0x3b56300, item=...) at /usr/src/debug/akonadi-16.08.2/src/core/models/entitytreemodel_p.cpp:1167
#22 0x00007f050bc87bb1 in QMetaObject::activate(QObject*, int, int, void**) (sender=0x77e9940, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcadccd850) at kernel/qobject.cpp:3730
#23 0x00007f050bc88717 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=<optimized out>, m=m@entry=0x7f050aa46e00 <Akonadi::Monitor::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcadccd850) at kernel/qobject.cpp:3595
#24 0x00007f050a6f4467 in Akonadi::Monitor::itemChanged(Akonadi::Item const&, QSet<QByteArray> const&) (this=<optimized out>, _t1=..., _t2=...) at /usr/src/debug/akonadi-16.08.2/build/src/core/moc_monitor.cpp:828
#25 0x00007f050a7000c7 in Akonadi::MonitorPrivate::emitItemsNotification(Akonadi::Protocol::ChangeNotification const&, QVector<Akonadi::Item> const&, Akonadi::Collection const&, Akonadi::Collection const&) (this=this@entry=0x68a9ab0, msg_=..., items=..., collection=..., collectionDest=...) at /usr/src/debug/akonadi-16.08.2/src/core/monitor_p.cpp:956
#26 0x00007f050a700947 in Akonadi::MonitorPrivate::emitNotification(Akonadi::Protocol::ChangeNotification const&) (this=this@entry=0x68a9ab0, msg=...) at /usr/src/debug/akonadi-16.08.2/src/core/monitor_p.cpp:587
#27 0x00007f050a6b17d1 in Akonadi::ChangeRecorderPrivate::emitNotification(Akonadi::Protocol::ChangeNotification const&) (this=0x68a9ab0, msg=...) at /usr/src/debug/akonadi-16.08.2/src/core/changerecorder_p.cpp:499
#28 0x00007f050a6fdcaa in Akonadi::MonitorPrivate::flushPipeline() (this=this@entry=0x68a9ab0) at /usr/src/debug/akonadi-16.08.2/src/core/monitor_p.cpp:809
#29 0x00007f050a6fdeb9 in Akonadi::MonitorPrivate::dataAvailable() (this=0x68a9ab0) at /usr/src/debug/akonadi-16.08.2/src/core/monitor_p.cpp:818
#30 0x00007f050bc87bb1 in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0x3c96d60, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3730
#31 0x00007f050bc88717 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x3c96d60, m=m@entry=0x7f050aa46420 <Akonadi::EntityCacheBase::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3595
#32 0x00007f050a6d79a0 in Akonadi::EntityCacheBase::dataAvailable() (this=this@entry=0x3c96d60) at /usr/src/debug/akonadi-16.08.2/build/src/core/moc_entitycache_p.cpp:146
#33 0x00007f050a6ab00c in Akonadi::EntityListCache<Akonadi::Item, Akonadi::ItemFetchJob, Akonadi::ItemFetchScope>::processResult(KJob*) (this=<optimized out>, job=<optimized out>) at /usr/src/debug/akonadi-16.08.2/src/core/entitycache_p.h:499
#34 0x00007f050a6d7a04 in Akonadi::EntityCacheBase::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/akonadi-16.08.2/build/src/core/moc_entitycache_p.cpp:80
#35 0x00007f050bc87bb1 in QMetaObject::activate(QObject*, int, int, void**) (sender=0x3ce2670, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffcadcce0c0) at kernel/qobject.cpp:3730
#36 0x00007f050d301a62 in KJob::result(KJob*, KJob::QPrivateSignal) () at /usr/lib64/libKF5CoreAddons.so.5
#37 0x00007f050d30278f in KJob::finishJob(bool) () at /usr/lib64/libKF5CoreAddons.so.5
#38 0x00007f050a76e0b9 in Akonadi::Job::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/akonadi-16.08.2/build/src/core/moc_job.cpp:108
#39 0x00007f050bc89166 in QObject::event(QEvent*) (this=0x3ce2670, e=<optimized out>) at kernel/qobject.cpp:1256
#40 0x00007f050c968e3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x3ce2670, e=0x6e756b0) at kernel/qapplication.cpp:3804
#41 0x00007f050c96d49a in QApplication::notify(QObject*, QEvent*) (this=0x7ffcadcce9b0, receiver=0x3ce2670, e=0x6e756b0) at kernel/qapplication.cpp:3561
#42 0x00007f050bc5dfc5 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x3ce2670, event=event@entry=0x6e756b0) at kernel/qcoreapplication.cpp:1015
#43 0x00007f050bc5fdaa in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (event=0x6e756b0, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#44 0x00007f050bc5fdaa in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x13bcde0) at kernel/qcoreapplication.cpp:1650
#45 0x00007f050bc60358 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1508
#46 0x00007f050bcaec83 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x1434e50) at kernel/qeventdispatcher_glib.cpp:270
#47 0x00007f0506420134 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#48 0x00007f0506420388 in  () at /usr/lib64/libglib-2.0.so.0
#49 0x00007f050642042c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#50 0x00007f050bcae30c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x143c310, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#51 0x00007f050bc5bfdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffcadcce710, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#52 0x00007f050bc63ec6 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1285
#53 0x00000000004046bb in  ()
#54 0x00007f050b0bc6e5 in __libc_start_main () at /lib64/libc.so.6
#55 0x0000000000404bf9 in _start ()

Possible duplicates by query: bug 378283, bug 373729, bug 371759, bug 362817, bug 362308.
Comment 1 Christoph Feck 2017-12-20 15:18:41 UTC

*** This bug has been marked as a duplicate of bug 362817 ***