Bug 378858 - Crash trying to start akonadi after failed mysql connect
Summary: Crash trying to start akonadi after failed mysql connect
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Indexer (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-04-17 05:32 UTC by Con Kolivas
Modified: 2017-04-23 11:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Con Kolivas 2017-04-17 05:32:34 UTC
Application: akonadi_baloo_indexer (4.14)
KDE Platform Version: 4.14.22
Qt Version: 4.8.7
Operating System: Linux 4.10.0-ck1+ x86_64
Distribution: Ubuntu 16.10

-- Information about the crash:
- What I was doing when the application crashed:

My IMAP session was behaving very strangely where changes I made to my email were not being committed and deleted emails kept reappearing. I shut down kmail and tried browsing it in akonadi console which complained of 
akonadi failed to connect to database can't connect to local mysql server

I tried shutting down akonadi and restarting it - it crashed on attempted starting with akonadictl start

-- Backtrace:
Application: No such method 'agentName' in interface 'org.freedesktop.Akonadi.AgentManager' at object path '/AgentManager' (signature 'ss') (akonadi_baloo_indexer), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007fb7704c27ef in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:58
#7  0x00007fb7704c43ea in __GI_abort () at abort.c:89
#8  0x00007fb774097f15 in qt_message_output(QtMsgType, char const*) (msgType=<optimized out>, buf=0x1f63598 "akonadi_baloo_indexer(6706)/libakonadi: Unable to register service \"org.freedesktop.Akonadi.Agent.akonadi_baloo_indexer\" at dbus: \"\" ") at global/qglobal.cpp:2447
#9  0x00007fb772bdecc7 in  () at /usr/lib/libakonadi-kde.so.4
#10 0x00007fb772bde18a in  () at /usr/lib/libakonadi-kde.so.4
#11 0x00007fb7741ccd11 in QObject::event(QEvent*) (this=0x1e27340, e=<optimized out>) at kernel/qobject.cpp:1222
#12 0x00007fb77171c03c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x1ca3ae0, receiver=receiver@entry=0x1e27340, e=e@entry=0x1dff560) at kernel/qapplication.cpp:4570
#13 0x00007fb771722f76 in QApplication::notify(QObject*, QEvent*) (this=this@entry=0x7ffc107a3490, receiver=receiver@entry=0x1e27340, e=e@entry=0x1dff560) at kernel/qapplication.cpp:4356
#14 0x00007fb7724824ba in KApplication::notify(QObject*, QEvent*) (this=0x7ffc107a3490, receiver=0x1e27340, event=0x1dff560) at ./kdeui/kernel/kapplication.cpp:311
#15 0x00007fb7741b28ad in QCoreApplication::notifyInternal(QObject*, QEvent*) (this=0x7ffc107a3490, receiver=receiver@entry=0x1e27340, event=event@entry=0x1dff560) at kernel/qcoreapplication.cpp:955
#16 0x00007fb7741b6366 in QCoreApplication::sendEvent(QObject*, QEvent*) (event=0x1dff560, receiver=0x1e27340) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 0x00007fb7741b6366 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1c4e740) at kernel/qcoreapplication.cpp:1579
#18 0x00007fb7741b6643 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1472
#19 0x00007fb7741e309e in QCoreApplication::sendPostedEvents() () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 0x00007fb7741e309e in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x1c7ae30) at kernel/qeventdispatcher_glib.cpp:300
#21 0x00007fb76fb877d7 in g_main_dispatch (context=0x1c9c1a0) at ././glib/gmain.c:3203
#22 0x00007fb76fb877d7 in g_main_context_dispatch (context=context@entry=0x1c9c1a0) at ././glib/gmain.c:3856
#23 0x00007fb76fb87a40 in g_main_context_iterate (context=context@entry=0x1c9c1a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ././glib/gmain.c:3929
#24 0x00007fb76fb87aec in g_main_context_iteration (context=0x1c9c1a0, may_block=may_block@entry=1) at ././glib/gmain.c:3990
#25 0x00007fb7741e320e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x1c54e60, flags=...) at kernel/qeventdispatcher_glib.cpp:450
#26 0x00007fb7717c9666 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007fb7741b112f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffc107a3400, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007fb7741b1495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffc107a3400, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007fb7741b7459 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1227
#30 0x00007fb772bdb43d in Akonadi::AgentBase::init(Akonadi::AgentBase*) () at /usr/lib/libakonadi-kde.so.4
#31 0x000000000041111e in  ()
#32 0x00007fb7704ad3f1 in __libc_start_main (main=0x40a090, argc=3, argv=0x7ffc107a35a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc107a3598) at ../csu/libc-start.c:291
#33 0x000000000040a129 in _start ()

Reported using DrKonqi
Comment 1 Daniel Vrátil 2017-04-23 09:53:26 UTC
Sorry, KDEPIM 4 is not supported anymore.

The message (akonadi_baloo_indexer(6706)/libakonadi: Unable to register service \"org.freedesktop.Akonadi.Agent.akonadi_baloo_indexer\" at dbus) indicates that there's a problem with your DBus session, or that there's already another (stuck?) instance of akonadi_baloo_indexer running that holds the service.
Comment 2 Con Kolivas 2017-04-23 09:58:57 UTC
Eh that's most unusual, I'm not running kde4. I guess some kde4 packages are still around in kubuntu 16.10 and somehow this came up. I'm actually on kde frameworks 5.26 and qt 5.6.1 so I guess whatever crashed in the failing imap session on kmail 5.2.3 somehow triggered an... interaction with kde4 or something???
Comment 3 Laurent Montel 2017-04-23 11:27:31 UTC
Uninstall all kde4 apps from your distro.
See 
"Application: akonadi_baloo_indexer (4.14)
KDE Platform Version: 4.14.22"
so indeed it's kde4 here.