Bug 378857 - Kmail receive Gmail messages not working
Summary: Kmail receive Gmail messages not working
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kmail2
Classification: Applications
Component: misc (show other bugs)
Version: Git (master)
Platform: Kubuntu Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-17 03:47 UTC by dani_kase
Modified: 2017-04-22 16:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dani_kase 2017-04-17 03:47:37 UTC
I am able to send Gmail messages through Kmail but not receive. Not a single message is received by Kmail client. :( I'm very disappointed with the situation. It shouldn't be a pain to setup an email client with a famous email provider.
Comment 1 dani_kase 2017-04-17 03:52:31 UTC
The company utilizes gmail as the email provider. So I try to use imap.gmail.com. Once kmail detects that this is imap.gmail.com, several cocnfiguration options are disabled. It tries the first time, asks gmail login credentials through a limited web like interface. Even after providing the info, in the aftermath it doesn't work.
Comment 2 Andrea Scarpino 2017-04-21 19:01:24 UTC
Same for me, but maybe this is a duplicate of 378876?
Comment 3 Daniel Vrátil 2017-04-22 11:36:41 UTC
Git commit c9ae16363e68d6958db0cd835cb0180b340594b5 by Daniel Vrátil.
Committed on 22/04/2017 at 11:31.
Pushed by dvratil into branch 'Applications/17.04'.

[IMAP] Fix migration to new Gmail authentication

Currently the settings would be migrated only if user opened the
Settings dialog. The GmailPasswordRequester expects that the server
settings is migrated correctly and always tries to authenticate via
XOAUTH2, even if the configuration says "PLAIN" or other mechanism.
This breaks login as we try to send XOAUTH2 tokens as PLAIN credentials.

This change ensures that the encryption and auth mechanism settings
is correctly migrated on resource startup.
Related: bug 378876

M  +12   -0    resources/imap/settings.cpp

https://commits.kde.org/kdepim-runtime/c9ae16363e68d6958db0cd835cb0180b340594b5
Comment 4 Daniel Vrátil 2017-04-22 16:40:52 UTC
There's a bug in Kubuntu/Neon packages that breaks Gmail login: https://bugs.kde.org/show_bug.cgi?id=379089

Closing as downstream issue.