Bug 378782 - Kwin crashing when hidden Skype is reactivated
Summary: Kwin crashing when hidden Skype is reactivated
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.6
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-04-14 16:26 UTC by eldrad.ulthran
Modified: 2017-04-14 20:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eldrad.ulthran 2017-04-14 16:26:13 UTC
Application: kwin_x11 (5.8.6)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.4.57-18.3-default x86_64
Distribution: "openSUSE Leap 42.2"

-- Information about the crash:
- What I was doing when the application crashed:

Skype was running and hidden in the task bar. When I clicked on its symbol to create an active window kwin crashed and the screen flickered shortly. Kwin was restarted automatically and Skype was reactivated as desired. This happens sometimes, but not always.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe4cf2a8940 (LWP 1856))]

Thread 5 (Thread 0x7fe4a27fd700 (LWP 2170)):
#0  0x00007fe4cea10b03 in select () at /lib64/libc.so.6
#1  0x00007fe4cc0e0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007fe4cc0e20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007fe4cc0e2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fe4cc091fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fe4cbeccf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fe4c6ab79c8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007fe4cbed19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007fe4cecd9744 in start_thread () at /lib64/libpthread.so.0
#9  0x00007fe4cea17d3d in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7fe4a0a06700 (LWP 1939)):
#0  0x00007fe4cecde0bf in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fe4cb06093b in  () at /usr/lib64/libQt5Script.so.5
#2  0x00007fe4cb060969 in  () at /usr/lib64/libQt5Script.so.5
#3  0x00007fe4cecd9744 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fe4cea17d3d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7fe4a37fe700 (LWP 1929)):
#0  0x00007fe4cea10b03 in select () at /lib64/libc.so.6
#1  0x00007fe4cc0e0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007fe4cc0e20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007fe4cc0e2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fe4cc091fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fe4cbeccf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fe4c6ab79c8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007fe4cbed19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007fe4cecd9744 in start_thread () at /lib64/libpthread.so.0
#9  0x00007fe4cea17d3d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7fe4a98b4700 (LWP 1903)):
#0  0x00007fe4cea10b03 in select () at /lib64/libc.so.6
#1  0x00007fe4cc0e0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007fe4cc0e20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007fe4cc0e2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fe4cc091fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fe4cbeccf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fe4c5c981d5 in  () at /usr/lib64/libQt5DBus.so.5
#7  0x00007fe4cbed19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007fe4cecd9744 in start_thread () at /lib64/libpthread.so.0
#9  0x00007fe4cea17d3d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fe4cf2a8940 (LWP 1856)):
[KCrash Handler]
#6  0x00007fe4c6aa3de0 in QQmlBinding::write(QQmlPropertyData const&, QV4::Value const&, bool, QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib64/libQt5Qml.so.5
#7  0x00007fe4c6aa525a in QQmlBinding::update(QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib64/libQt5Qml.so.5
#8  0x00007fe4c6aae306 in  () at /usr/lib64/libQt5Qml.so.5
#9  0x00007fe4c6a3c94b in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () at /usr/lib64/libQt5Qml.so.5
#10 0x00007fe4c6a3ca07 in QQmlComponentPrivate::completeCreate() () at /usr/lib64/libQt5Qml.so.5
#11 0x00007fe4c6a3c890 in QQmlComponent::create(QQmlContext*) () at /usr/lib64/libQt5Qml.so.5
#12 0x00007fe4a838b7cf in  () at /usr/lib64/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#13 0x00007fe4ce639097 in  () at /usr/lib64/libkwin.so.5
#14 0x00007fe4ce51d761 in KWin::Client::createDecoration(QRect const&) () at /usr/lib64/libkwin.so.5
#15 0x00007fe4ce51e47b in KWin::Client::updateDecoration(bool, bool) () at /usr/lib64/libkwin.so.5
#16 0x00007fe4ce57fdb6 in KWin::Client::manage(unsigned int, bool) () at /usr/lib64/libkwin.so.5
#17 0x00007fe4ce5017e4 in KWin::Workspace::createClient(unsigned int, bool) () at /usr/lib64/libkwin.so.5
#18 0x00007fe4ce56dfc0 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () at /usr/lib64/libkwin.so.5
#19 0x00007fe4cc091270 in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () at /usr/lib64/libQt5Core.so.5
#20 0x00007fe4b53f9be4 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () at /usr/lib64/libQt5XcbQpa.so.5
#21 0x00007fe4b53fbc3b in QXcbConnection::processXcbEvents() () at /usr/lib64/libQt5XcbQpa.so.5
#22 0x00007fe4cc0bf166 in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#23 0x00007fe4ccd9ae3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#24 0x00007fe4ccd9f49a in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#25 0x00007fe4cc093fc5 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#26 0x00007fe4cc095daa in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQt5Core.so.5
#27 0x00007fe4cc0e24b4 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#28 0x00007fe4b545d94d in  () at /usr/lib64/libQt5XcbQpa.so.5
#29 0x00007fe4cc091fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#30 0x00007fe4cc099ec6 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#31 0x00007fe4ceef79cc in kdemain () at /usr/lib64/libkdeinit5_kwin_x11.so
#32 0x00007fe4ce94e6e5 in __libc_start_main () at /lib64/libc.so.6
#33 0x0000000000400809 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2017-04-14 17:52:41 UTC
As a workaround use the default breeze decoration.

*** This bug has been marked as a duplicate of bug 361236 ***
Comment 2 eldrad.ulthran 2017-04-14 20:15:27 UTC
(In reply to Martin Gräßlin from comment #1)
> As a workaround use the default breeze decoration.
> 
> *** This bug has been marked as a duplicate of bug 361236 ***

The workaround didn't help. After switching to breeze decoration and reboot a very similar crash occurred, only this time I pressed Ctrl-P in okular. But again kwin crashes if a program launches a new window.