Bug 378705 - [Wayland] KNotes crash
Summary: [Wayland] KNotes crash
Status: RESOLVED DUPLICATE of bug 370750
Alias: None
Product: knotes
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-12 16:48 UTC by Germano Massullo
Modified: 2017-04-26 23:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Germano Massullo 2017-04-12 16:48:34 UTC
Plasma 5.9.4, knotes-16.12.3-1.fc25.x86_64

Application: KNotes (knotes), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
84	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f7a76f80180 (LWP 19871))]

Thread 9 (Thread 0x7f7a5edee700 (LWP 20057)):
#0  0x00007fff63fde949 in  ()
#1  0x00007fff63fdebd9 in clock_gettime ()
#2  0x00007f7a8fbbf726 in __GI___clock_gettime (clock_id=clock_id@entry=1, tp=tp@entry=0x7f7a5eded9d0) at ../sysdeps/unix/clock_gettime.c:115
#3  0x00007f7a90854b31 in qt_clock_gettime (ts=0x7f7a5eded9d0, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:109
#4  0x00007f7a90854b31 in do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:164
#5  0x00007f7a90854b31 in qt_gettime() () at tools/qelapsedtimer_unix.cpp:173
#6  0x00007f7a909a9d99 in QTimerInfoList::updateCurrentTime() (this=this@entry=0x7f7a50002cd0) at kernel/qtimerinfo_unix.cpp:91
#7  0x00007f7a909aa195 in QTimerInfoList::timerWait(timespec&) (this=0x7f7a50002cd0, tm=...) at kernel/qtimerinfo_unix.cpp:388
#8  0x00007f7a909ab38c in timerSourcePrepareHelper(GTimerSource*, gint*) (src=<optimized out>, timeout=0x7f7a5ededab4) at kernel/qeventdispatcher_glib.cpp:132
#9  0x00007f7a909ab455 in timerSourcePrepare(GSource*, gint*) (source=<optimized out>, timeout=timeout@entry=0x7f7a5ededab4) at kernel/qeventdispatcher_glib.cpp:165
#10 0x00007f7a8244769d in g_main_context_prepare (context=context@entry=0x7f7a50000990, priority=priority@entry=0x7f7a5ededb40) at gmain.c:3501
#11 0x00007f7a8244808b in g_main_context_iterate (context=context@entry=0x7f7a50000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3909
#12 0x00007f7a8244827c in g_main_context_iteration (context=0x7f7a50000990, may_block=may_block@entry=1) at gmain.c:3990
#13 0x00007f7a909ab6eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f7a500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#14 0x00007f7a9095c68a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f7a5ededc80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#15 0x00007f7a907b95e3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#16 0x00007f7a907bd9ca in QThreadPrivate::start(void*) (arg=0x55b265cf61a0) at thread/qthread_unix.cpp:368
#17 0x00007f7a873e66ca in start_thread (arg=0x7f7a5edee700) at pthread_create.c:333
#18 0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 8 (Thread 0x7f7a5f5ef700 (LWP 20056)):
#0  0x00007f7a909ab334 in timerSourcePrepareHelper(GTimerSource*, gint*) (src=0x7f7a58002e70, timeout=0x7f7a5f5eeab4) at kernel/qeventdispatcher_glib.cpp:130
#1  0x00007f7a909ab455 in timerSourcePrepare(GSource*, gint*) (source=<optimized out>, timeout=timeout@entry=0x7f7a5f5eeab4) at kernel/qeventdispatcher_glib.cpp:165
#2  0x00007f7a8244769d in g_main_context_prepare (context=context@entry=0x7f7a58000990, priority=priority@entry=0x7f7a5f5eeb40) at gmain.c:3501
#3  0x00007f7a8244808b in g_main_context_iterate (context=context@entry=0x7f7a58000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3909
#4  0x00007f7a8244827c in g_main_context_iteration (context=0x7f7a58000990, may_block=may_block@entry=1) at gmain.c:3990
#5  0x00007f7a909ab6eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f7a580008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f7a9095c68a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f7a5f5eec80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#7  0x00007f7a907b95e3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#8  0x00007f7a907bd9ca in QThreadPrivate::start(void*) (arg=0x55b265d149e0) at thread/qthread_unix.cpp:368
#9  0x00007f7a873e66ca in start_thread (arg=0x7f7a5f5ef700) at pthread_create.c:333
#10 0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 7 (Thread 0x7f7a64907700 (LWP 20024)):
#0  0x00007f7a8fba501d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f7a82448166 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f7a60003220, timeout=<optimized out>, context=0x7f7a60000990) at gmain.c:4228
#2  0x00007f7a82448166 in g_main_context_iterate (context=context@entry=0x7f7a60000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3924
#3  0x00007f7a8244827c in g_main_context_iteration (context=0x7f7a60000990, may_block=may_block@entry=1) at gmain.c:3990
#4  0x00007f7a909ab6eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f7a600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f7a9095c68a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f7a64906c40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f7a907b95e3 in QThread::exec() (this=this@entry=0x7f7a98c78060 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:507
#7  0x00007f7a98c02739 in QDBusConnectionManager::run() (this=0x7f7a98c78060 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#8  0x00007f7a907bd9ca in QThreadPrivate::start(void*) (arg=0x7f7a98c78060 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:368
#9  0x00007f7a873e66ca in start_thread (arg=0x7f7a64907700) at pthread_create.c:333
#10 0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 6 (Thread 0x7f7a65694700 (LWP 20019)):
#0  0x00007f7a873ec460 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7a6b8dec5b in cnd_wait (mtx=0x55b265bc1d08, cond=0x55b265bc1d30) at ../../../include/c11/threads_posix.h:159
#2  0x00007f7a6b8dec5b in util_queue_thread_func (input=input@entry=0x55b265bc1270) at util/u_queue.c:76
#3  0x00007f7a6b8deab7 in impl_thrd_routine (p=<optimized out>) at ../../../include/c11/threads_posix.h:87
#4  0x00007f7a873e66ca in start_thread (arg=0x7f7a65694700) at pthread_create.c:333
#5  0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 5 (Thread 0x7f7a65e95700 (LWP 20018)):
#0  0x00007f7a873ec460 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7a6b8dec5b in cnd_wait (mtx=0x55b265bc1d08, cond=0x55b265bc1d30) at ../../../include/c11/threads_posix.h:159
#2  0x00007f7a6b8dec5b in util_queue_thread_func (input=input@entry=0x55b265be9b60) at util/u_queue.c:76
#3  0x00007f7a6b8deab7 in impl_thrd_routine (p=<optimized out>) at ../../../include/c11/threads_posix.h:87
#4  0x00007f7a873e66ca in start_thread (arg=0x7f7a65e95700) at pthread_create.c:333
#5  0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 4 (Thread 0x7f7a66696700 (LWP 20017)):
#0  0x00007f7a873ec460 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7a6b8dec5b in cnd_wait (mtx=0x55b265bc1d08, cond=0x55b265bc1d30) at ../../../include/c11/threads_posix.h:159
#2  0x00007f7a6b8dec5b in util_queue_thread_func (input=input@entry=0x55b265be1f00) at util/u_queue.c:76
#3  0x00007f7a6b8deab7 in impl_thrd_routine (p=<optimized out>) at ../../../include/c11/threads_posix.h:87
#4  0x00007f7a873e66ca in start_thread (arg=0x7f7a66696700) at pthread_create.c:333
#5  0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 3 (Thread 0x7f7a66e97700 (LWP 20016)):
#0  0x00007f7a873ec460 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7a6b8dec5b in cnd_wait (mtx=0x55b265bc1d08, cond=0x55b265bc1d30) at ../../../include/c11/threads_posix.h:159
#2  0x00007f7a6b8dec5b in util_queue_thread_func (input=input@entry=0x55b265be5d20) at util/u_queue.c:76
#3  0x00007f7a6b8deab7 in impl_thrd_routine (p=<optimized out>) at ../../../include/c11/threads_posix.h:87
#4  0x00007f7a873e66ca in start_thread (arg=0x7f7a66e97700) at pthread_create.c:333
#5  0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 2 (Thread 0x7f7a6789d700 (LWP 20015)):
#0  0x00007f7a873ec460 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7a6b8dec5b in cnd_wait (mtx=0x55b265ba9608, cond=0x55b265ba9630) at ../../../include/c11/threads_posix.h:159
#2  0x00007f7a6b8dec5b in util_queue_thread_func (input=input@entry=0x55b265be3540) at util/u_queue.c:76
#3  0x00007f7a6b8deab7 in impl_thrd_routine (p=<optimized out>) at ../../../include/c11/threads_posix.h:87
#4  0x00007f7a873e66ca in start_thread (arg=0x7f7a6789d700) at pthread_create.c:333
#5  0x00007f7a8fbb0f7f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 1 (Thread 0x7f7a76f80180 (LWP 19871)):
[KCrash Handler]
#6  0x00007f7a976c5a8f in XInternAtoms (dpy=0x55b265b58a80, names=0x7fff63fc0e90, count=2, onlyIfExists=0, atoms_return=0x7fff63fc0e80) at IntAtom.c:256
#7  0x000055b263fe2b08 in remove_sm_from_client_leader() () at /usr/src/debug/knotes-16.12.3/src/apps/main.cpp:94
#8  0x000055b263fe094b in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/knotes-16.12.3/src/apps/main.cpp:75
Comment 1 Christoph Feck 2017-04-26 23:28:14 UTC

*** This bug has been marked as a duplicate of bug 370750 ***