Bug 378489 - No operation after last Update
Summary: No operation after last Update
Status: RESOLVED DOWNSTREAM
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-06 06:49 UTC by Thorsten Oppels
Modified: 2017-04-07 08:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
/var/log/zypp/history > lastUpdate.txt (8.50 KB, text/plain)
2017-04-06 06:49 UTC, Thorsten Oppels
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Oppels 2017-04-06 06:49:31 UTC
Created attachment 104898 [details]
/var/log/zypp/history > lastUpdate.txt

Today, after installing the last patches:
Akregator disables when using in Kontact. When try to start Akregator in an terminal, I get this message:
:~> akregator 
akregator: symbol lookup error: /usr/lib64/libakregatorprivate.so.5: undefined symbol: _ZN15WebEngineViewer13WebEngineView14dragEnterEventEP15QDragEnterEvent
:~>
Comment 1 Sauerland 2017-04-06 08:27:54 UTC
Its an messaglib bug.
Install the old messagelib from the OSS Repo:

zypper se -s messagelib
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name             | Typ        | Version       | Arch   | Repository               
---+------------------+------------+---------------+--------+--------------------------
vl | messagelib       | Paket      | 16.08.2-2.3.1 | x86_64 | openSUSE-Leap-42.2-Update
il | messagelib       | Paket      | 16.08.2-1.1   | x86_64 | openSUSE-Leap-42.2-Oss   
   | messagelib       | Quellpaket | 16.08.2-2.3.1 | noarch | openSUSE-Leap-42.2-Update
   | messagelib-devel | Paket      | 16.08.2-2.3.1 | x86_64 | openSUSE-Leap-42.2-Update
   | messagelib-devel | Paket      | 16.08.2-1.1   | x86_64 | openSUSE-Leap-42.2-Oss
Comment 2 Wolfgang Bauer 2017-04-06 15:44:45 UTC
It's not a bug really, but akregator would need to be rebuilt against the messagelib update.

Anyway, it's a downstream problem in openSUSE, and it's tracked here:
https://bugzilla.opensuse.org/show_bug.cgi?id=1032754

As a workaround, you can revert the messagelib update as mentioned, or install akregator5 from here:
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/OBS_Maintained:/kdepim/openSUSE_Leap_42.2_Update/

Sorry for the inconvinience.
Comment 3 Wolfgang Bauer 2017-04-07 08:49:27 UTC
FYI, an update to kdepim has been released meanwhile too, so this should be fixed.