Bug 378391 - ics merging fails
Summary: ics merging fails
Status: RESOLVED DUPLICATE of bug 419836
Alias: None
Product: korganizer
Classification: Applications
Component: import/export (show other bugs)
Version: 5.7.1
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-03 10:05 UTC by Philippe ROUBACH
Modified: 2020-05-07 19:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
example of ics (2.71 KB, text/calendar)
2017-04-03 10:06 UTC, Philippe ROUBACH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2017-04-03 10:05:10 UTC
opensuse 42.2
1. korganizer 16.08

i click on an ics file
then
i open it with korganizer
then i add the event to the calendar (a google one)
then
the event is well sync to google calendar
the event is displayed in kontact "résumé"
but
the event is not displayed in korganizer.
the event is in akonadi db

2. korganizer 5.4.80b1 (17.03

i click on an ics file
then
i open it with korganizer
then i add the event to the calendar (a google one)
then
the event is not in akonadi db
the event is not sync to google calendar
the event is not displayed in kontact "résumé"
the event is not displayed in korganizer.
Comment 1 Philippe ROUBACH 2017-04-03 10:06:43 UTC
Created attachment 104855 [details]
example of ics
Comment 2 Denis Kurz 2018-01-31 17:12:39 UTC
KOrganizer seems to ignore items that do not have a UID set. The issue is easily reproduced by a minimal ics file with only one VTODO entry with only a SUMMARY, or a SUMMARY and a UID. The former is ignored, while the latter is displayed.

There should be some form of feedback about those (faulty?) TODO items.
Comment 3 John Scott 2020-05-07 19:13:48 UTC

*** This bug has been marked as a duplicate of bug 419836 ***