Bug 377499 - Find Messages not working unless Last Search folder deleted
Summary: Find Messages not working unless Last Search folder deleted
Status: RESOLVED DUPLICATE of bug 365753
Alias: None
Product: kmail2
Classification: Applications
Component: search (show other bugs)
Version: 5.2.3
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-11 16:51 UTC by solitone
Modified: 2017-04-09 17:45 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description solitone 2017-03-11 16:51:37 UTC
The "Find Messages..." functionality you get by right-clicking on a folder does not work, unless you first delete the "Last Search" folder on the bottom of the folder list.

This behaviour has been reported by a few other stretch users on the kdepim-users mailing list, on debian stretch as well as other platforms. It therefore looks like an upstream bug.
Comment 1 ianseeks 2017-03-11 18:04:47 UTC
I can confirm it also happens on kmail 5.4.2. but if you close the find dialog and reopen it but change the name of default name "Last Search" to something else, it seems to work but you do have to close the dialog before you do another search.
Its also very random as to what it seached for. I searched for subject containing "IMAP with KMail 4.14.10" and got every mail with kmail in the subject - it was almost like it searched for all words individually instead of the string.
opensuse:tumbleweed:20170309
Qt: 5.7.1
KDE Frameworks: 5.31.0
KDE Plasma: 5.9.2
kwin 5.9.3
kmail2 5.4.2
akonadiserver 5.4.2
Comment 2 John White 2017-03-11 18:44:41 UTC
"Find messages" on my Kmail pop3 system just stopped working about a month ago when I was on jessie.  Any search instantly produced zero results.  I moved to stretch in hopes that would help, but it did not help at all.
Comment 3 Sandro Knauß 2017-03-11 22:10:10 UTC
It is reported at debian under: https://bugs.debian.org/857279
Comment 4 Daniel Vrátil 2017-04-08 10:40:24 UTC

*** This bug has been marked as a duplicate of bug 365753 ***
Comment 5 John White 2017-04-08 20:29:52 UTC
I think this whole thing about "last search" and.changing name of that folder is leading everyone on a wild goose chase.  Doing anything with or to the last search folder doesn't help one bit. "Find messages" on my stretch machine just doesn't work.I created a new user and tried it there. Same problem, i.e. "Find Messages" instantly finds nothing.  I am the laughing stock of the windows users in my office because of this problem, which is wrecking havoc with my practice.  I can sort of search in Dolphin but that is a pain.
Comment 6 Sandro Knauß 2017-04-08 22:19:38 UTC
As this bug report is closed and and also the duplicate is now have been solved it is part of Debian to backport the patch.
Comment 7 John White 2017-04-09 17:45:18 UTC
Thank you!

Do you have any clue when Debian is going to upload the kde fix?

John

On 04/08/2017 03:19 PM, Sandro Knauß wrote:
> https://bugs.kde.org/show_bug.cgi?id=377499
>
> --- Comment #6 from Sandro Knauß <sknauss@kde.org> ---
> As this bug report is closed and and also the duplicate is now have been solved
> it is part of Debian to backport the patch.
>