Bug 377440 - KWIN crashes when starting saved VBOX client with two screens.
Summary: KWIN crashes when starting saved VBOX client with two screens.
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.4
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-09 23:07 UTC by Eric
Modified: 2017-03-10 06:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2017-03-09 23:07:28 UTC
Application: kwin_x11 (5.8.3)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.4.49-16-default x86_64
Distribution: "openSUSE Leap 42.2"

-- Information about the crash:
- What I was doing when the application crashed:
Starting VBOX saved client from a shortcut on the desktop.
VirtualBox Graphical User Interface
Version 5.1.14 r112924 (Qt5.6.1)

Symptom have only started occuring in the last few weeks after some OpenSUSE updates. Virtual Box version has been installed and stable since the release of this version.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f457c988940 (LWP 2474))]

Thread 7 (Thread 0x7f44c0d65700 (LWP 2632)):
#0  0x00007f457c0fdb03 in select () at /lib64/libc.so.6
#1  0x00007f45797d0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007f45797d20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007f45797d2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f4579781fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f45795bcf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f45741ae9c8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007f45795c19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007f457c3c6734 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f457c104d3d in clone () at /lib64/libc.so.6

Thread 6 (Thread 0x7f4552ffe700 (LWP 2585)):
#0  0x00007f457c3cb0af in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f457875793b in  () at /usr/lib64/libQt5Script.so.5
#2  0x00007f4578757969 in  () at /usr/lib64/libQt5Script.so.5
#3  0x00007f457c3c6734 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f457c104d3d in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7f454179e700 (LWP 2584)):
#0  0x00007f457c3cb0af in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f4550ed7533 in  () at /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f4550ed6d57 in  () at /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f457c3c6734 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f457c104d3d in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7f4553fff700 (LWP 2554)):
#0  0x00007f457c0fdb03 in select () at /lib64/libc.so.6
#1  0x00007f45797d0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007f45797d20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007f45797d2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f4579781fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f45795bcf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f45741ae9c8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007f45795c19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007f457c3c6734 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f457c104d3d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f4561864700 (LWP 2514)):
#0  0x00007f457c0fdb03 in select () at /lib64/libc.so.6
#1  0x00007f45797d0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007f45797d20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007f45797d2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f4579781fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f45795bcf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f457338f1d5 in  () at /usr/lib64/libQt5DBus.so.5
#7  0x00007f45795c19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007f457c3c6734 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f457c104d3d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f45630b7700 (LWP 2510)):
#0  0x00007f457c0fc49d in poll () at /lib64/libc.so.6
#1  0x00007f457b2833e2 in  () at /usr/lib64/libxcb.so.1
#2  0x00007f457b284fcf in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007f4563d67839 in  () at /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f45795c19e9 in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007f457c3c6734 in start_thread () at /lib64/libpthread.so.0
#6  0x00007f457c104d3d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f457c988940 (LWP 2474)):
[KCrash Handler]
#6  0x00007f457419ade0 in QQmlBinding::write(QQmlPropertyData const&, QV4::Value const&, bool, QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib64/libQt5Qml.so.5
#7  0x00007f457419c25a in QQmlBinding::update(QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib64/libQt5Qml.so.5
#8  0x00007f45741a5306 in  () at /usr/lib64/libQt5Qml.so.5
#9  0x00007f457413394b in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () at /usr/lib64/libQt5Qml.so.5
#10 0x00007f4574133a07 in QQmlComponentPrivate::completeCreate() () at /usr/lib64/libQt5Qml.so.5
#11 0x00007f4574133890 in QQmlComponent::create(QQmlContext*) () at /usr/lib64/libQt5Qml.so.5
#12 0x00007f45605c07cf in Aurorae::Decoration::init() (this=0x22146a0) at /usr/src/debug/kwin-5.8.3/plugins/kdecorations/aurorae/src/aurorae.cpp:316
#13 0x00007f457bd28047 in KWin::Decoration::DecorationBridge::createDecoration(KWin::AbstractClient*) (this=0x1467420, client=client@entry=0x212bf10) at /usr/src/debug/kwin-5.8.3/decorations/decorationbridge.cpp:260
#14 0x00007f457bc0c891 in KWin::Client::createDecoration(QRect const&) (this=this@entry=0x212bf10, oldgeom=...) at /usr/src/debug/kwin-5.8.3/client.cpp:393
#15 0x00007f457bc0d5ab in KWin::Client::updateDecoration(bool, bool) (this=0x212bf10, check_workspace_pos=<optimized out>, force=<optimized out>) at /usr/src/debug/kwin-5.8.3/client.cpp:380
#16 0x00007f457bc6eed6 in KWin::Client::manage(unsigned int, bool) (this=this@entry=0x212bf10, w=w@entry=92274721, isMapped=isMapped@entry=false) at /usr/src/debug/kwin-5.8.3/manage.cpp:390
#17 0x00007f457bbf0994 in KWin::Workspace::createClient(unsigned int, bool) (this=this@entry=0x150eb70, w=92274721, is_mapped=is_mapped@entry=false) at /usr/src/debug/kwin-5.8.3/workspace.cpp:517
#18 0x00007f457bc5d0e0 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) (this=0x150eb70, e=0x7f455c00a3f0) at /usr/src/debug/kwin-5.8.3/events.cpp:421
#19 0x00007f4579781270 in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () at /usr/lib64/libQt5Core.so.5
#20 0x00007f4563d65be4 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () at /usr/lib64/libQt5XcbQpa.so.5
#21 0x00007f4563d67c3b in QXcbConnection::processXcbEvents() () at /usr/lib64/libQt5XcbQpa.so.5
#22 0x00007f45797af166 in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#23 0x00007f457a48ae3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#24 0x00007f457a48f49a in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#25 0x00007f4579783fc5 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#26 0x00007f4579785daa in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQt5Core.so.5
#27 0x00007f45797d24b4 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#28 0x00007f4563dc994d in  () at /usr/lib64/libQt5XcbQpa.so.5
#29 0x00007f4579781fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#30 0x00007f4579789ec6 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#31 0x00007f457c5e49cc in kdemain(int, char**) (argc=1, argv=0x7fffa17698c8) at /usr/src/debug/kwin-5.8.3/main_x11.cpp:466
#32 0x00007f457c03b6e5 in __libc_start_main () at /lib64/libc.so.6
#33 0x0000000000400809 in _start () at ../sysdeps/x86_64/start.S:118

Report to https://bugs.kde.org/
Comment 1 Martin Flöser 2017-03-10 06:14:10 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***