Bug 377354 - Do NOT delete 'frames in the same naming scheme' (out of frame range) when exporting
Summary: Do NOT delete 'frames in the same naming scheme' (out of frame range) when ex...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Animation (show other bugs)
Version: 3.1.2
Platform: unspecified Unspecified
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 378175 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-07 19:23 UTC by gordie.lachance+dev
Modified: 2018-09-26 09:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gordie.lachance+dev 2017-03-07 19:23:37 UTC
Hi, when I export my animation and that some files have the same naming scheme, I got the following message :

"Frames with the same naming scheme exist in the destination directory.  The are going to be deleted, continue ?"

Then the whole sequence is deleted.

Only the files from the frame range exported should be deleted.

Why ?
Let's say I have an animation of 1000 frames but I just changed 20 of them.
The 1000 frames are deleted...  
And I have to render the whole sequence again :/

By the way, files are not moved to the trash bin but are really deleted, so you can't restore them.

Thanks !
Comment 1 Halla Rempt 2017-03-27 19:46:46 UTC
*** Bug 378175 has been marked as a duplicate of this bug. ***
Comment 2 joupent 2018-09-25 12:38:28 UTC
Git commit d2717fd53982bac921d9ab767ca15454c7ec9ed5 by Jouni Pentikäinen.
Committed on 25/09/2018 at 12:37.
Pushed by jounip into branch 'master'.

Delete existing frame files only within exported range

M  +13   -0    libs/ui/dialogs/KisAsyncAnimationFramesSaveDialog.cpp

https://commits.kde.org/krita/d2717fd53982bac921d9ab767ca15454c7ec9ed5
Comment 3 Halla Rempt 2018-09-26 09:11:39 UTC
Git commit 20fb785bbe8ff6032dd9cab5d393b4c4b2f0fd3a by Boudewijn Rempt, on behalf of Jouni Pentikäinen.
Committed on 26/09/2018 at 09:10.
Pushed by rempt into branch 'krita/4.1'.

Delete existing frame files only within exported range

M  +13   -0    libs/ui/dialogs/KisAsyncAnimationFramesSaveDialog.cpp

https://commits.kde.org/krita/20fb785bbe8ff6032dd9cab5d393b4c4b2f0fd3a