Bug 375976 - appmenu not shown for gtk apps
Summary: appmenu not shown for gtk apps
Alias: None
Product: plasmashell
Classification: Plasma
Component: Global Menu (show other bugs)
Version: 5.9.0
Platform: Neon Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
: 376232 393071 (view as bug list)
Depends on:
Reported: 2017-02-03 21:56 UTC by rockonthemoonfm
Modified: 2018-08-28 16:32 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.13.0


Note You need to log in before you can comment on or make changes to this bug.
Description rockonthemoonfm 2017-02-03 21:56:48 UTC
Firefox, Libreoffice.. any gtk application has no app menu.
Is there any solution? Any missing dependency?
Comment 1 Kai Uwe Broulik 2017-02-09 14:58:19 UTC
*** Bug 376232 has been marked as a duplicate of this bug. ***
Comment 2 Aristide 2017-02-11 16:47:12 UTC
Same problem here. 

For libreoffice : I have try to install gtk support. Menu bar disappear from Libreoffice apps, but not exported into Global Menubar widget. 

About Firefox : Menus of global menubar appear, but click on elements do nothing. 

On Gimp, Inkscape : Menubar is not exported into global menu.
Comment 3 PGillespie 2017-03-03 03:32:38 UTC
Updated to Plasma 5.9.3. Global menu still doesn't work with LibreOffice. Haven't tested with other applications.

How is this still unconfirmed after so many reports?
Comment 4 Kai Uwe Broulik 2017-03-03 07:37:38 UTC
The confirmed state doesn't have a consistent meaning to us. I set it to confirmed when I know that I will definitely work on fixing it soon'ish and/or already know roughly how which isn't the case here.

Also, constantly reporting that it still doesn't work won't get it magically fixed. GTK doesn't support the global menu protocol we use anymore and therefore it won't ever work unless we support theirs which is declared a "non-stable protocol" by them, so I don't see how it can be implemented without a huge maintenance burden I am not willing to take.
Comment 5 PGillespie 2017-03-03 12:08:12 UTC
Actually Kal, I appreciate your comment; and wish you and others would make it a practice to comment like this more often. 

There's nothing less helpful or frustrating to everyday users than the silence of seeming indifference. I would love it if the global menu worked, but your explanation puts that to rest.
Comment 6 JonnyRobbie 2017-06-12 23:29:57 UTC
I understand that it may not be easy to move gtk appmenu to the global widget. However I don't understand the necessity to remove it altogether. Let Qt apps have its globalmenu and leave incapable gtk aps with its local menu.

What I don't understand is why do the gtk apps need to lose their menu altogether? Clearly kwin (or whichever component is responsible) is capable and even acting on removing those menus from gtk apps, why not just leave it alone then?
Comment 7 Kai Uwe Broulik 2017-06-13 07:31:03 UTC
I don't know? If the app does stupid things, it does stupid things. LibreOffice with GTK seems to react to the dbus menu service being around in some way and then hides its menu bar... there's nothing I can do about this.
Comment 8 JonnyRobbie 2017-06-13 09:23:02 UTC
Certainly, but even gtk apps show the appmenu again if I restore 'Menubar Style: In application' setting. So there has to be something in plasma telling LibreOffice to hide the menu. I don't think it's the gtk app hiding it.
Comment 9 joergister 2017-10-17 20:55:13 UTC
For me on Plasma 5.11.1 it works fine: KDE applications have their global menu (at least under X) and GTK or QT4 applications have their local menu. Libreoffice firefox, GIMP.. They all have their local menu. Even an audacity flatpak has its own local menu. 

Is this the case for you too? Or do you still have problems with menus that are hidden?
Comment 10 JonnyRobbie 2017-10-18 08:06:11 UTC
$ plasmashell --version
plasmashell 5.11.1
Using local/plasma5-applets-active-window-control-git r147.341276f-1
with 'System Settings-Application Style-Widget Style-Menubar Style' set to 'Application Menu Widget'.

Konsole (for example) has properly rendered menu: https://i.imgur.com/Vg7E3eZ.png
LOcalc has missing menu: https://i.imgur.com/x6qs7AN.png
it is worth noting, that the menu is missing with SAL_USE_VCLPLUGIN=gtk3, I'd understand that the gtk menu is not supported, I got it, but then it shouldn't touch the menu at all and leave it alone and not hide it without replacement.
Using SAL_USE_VCLPLUGIN=kde4, the menu is still there, but LO is hideous: https://i.imgur.com/qXmY2Kl.png (not to mention, it still probably has that ugly gradient with dark theme)
Comment 11 Kai Uwe Broulik 2017-10-18 08:26:19 UTC
If LibreOffice decides to be stupid and hide the menu, that's their fault.
Comment 12 joergister 2017-10-20 14:09:41 UTC
well it works for me using SAL_USE_VCLPLUGIN=gtk as well as it does for you using SAL_USE_VCLPLUGIN=kde4 and I'm fine with that. Using a local menu in non Qt5 applications is OK for me.

BTW there is progress on porting the LO VCL plugin for KDE Plasma to Qt5. 
Perhaps this makes it possible to use LO with global menu some day
Comment 13 joergister 2017-10-20 14:23:24 UTC
BTW under Wayland there are only local menus available at the moment; global menu don't work under Wayland. https://bugs.kde.org/show_bug.cgi?id=385880
Comment 14 Bronson 2017-10-20 20:46:36 UTC
Id love to see the locally integrated menu on plasma. Its such a great screen space saver! Ubuntu had it right in unity 7.

Ive found some old threads that looks like others may be trying to get it up and running:
Comment 15 Venca B Spam 2017-10-24 12:15:35 UTC
I can confirm it still does not work for LibreOffice and Plasma 5.11.1.

Although I filled a new bug https://bugs.documentfoundation.org/show_bug.cgi?id=113397 I am interested what is necessary to do on which side to support this business requirement ("Have global menu for all applications running on my/your laptop").
Comment 16 Kai Uwe Broulik 2017-10-24 13:12:13 UTC
I'm wondering if the port of their UI backend to Qt5 (which supports global menu out of the box) will help here? See https://eang.it/libreoffice-conference-2017/
Comment 17 Antonio Rojas 2018-04-12 21:03:15 UTC
*** Bug 393071 has been marked as a duplicate of this bug. ***