Bug 375559 - Broken plasma panels and window decorations on wayland with Qt 5.8
Summary: Broken plasma panels and window decorations on wayland with Qt 5.8
Status: RESOLVED DUPLICATE of bug 375539
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.8.95
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-25 18:14 UTC by tobi291019
Modified: 2017-01-27 08:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tobi291019 2017-01-25 18:14:56 UTC
One can drag around panels and the desktop background freely as if they were normal windows (they also can be focused, selected through Alt+Tab etc.), panels configured to show on the bottom of the screen get condensed into the top left corner and there are no decorations on Qt wayland windows, X11 programs are working fine however.

Functionality of panels and windows however is fine, one can e.g. minimize a window fine from the task manager

As a note: The decorations have been been broken ever since the Qt 5.8 rc, even with Plasma 5.7, could not test the panels at the time though as plasmashell used to crash with it (which appears to be fixed for me since the official Qt release)

Reproducible: Always

Steps to Reproduce:
1. Start the plasma wayland session
2. Try opening any windows etc.

Expected Results:
Panels and window decorations working properly as in X11

Running Arch Linux x86_64, kde-unstable and testing repos, which ships Qt 5.8 and Plasma 5.8.95 (beta)
Comment 1 Martin Flöser 2017-01-25 18:50:11 UTC

*** This bug has been marked as a duplicate of bug 375539 ***
Comment 2 Martin Flöser 2017-01-26 17:39:32 UTC
> As a note: The decorations have been been broken ever since the Qt 5.8
> rc,

Did you also try some beta releases of Qt 5.8 where it was still 
working? If yes that could help a lot to find the regression.
Comment 3 tobi291019 2017-01-27 05:15:46 UTC
> Did you also try some beta releases of Qt 5.8 where it was still 
> working? If yes that could help a lot to find the regression.

I haven't tried those yet, but I'll see if I can get any different results using the beta and alpha releases.
Comment 4 tobi291019 2017-01-27 08:27:16 UTC
I've built the beta, rc a release qwayland module against the released Qt 5.8.

With beta everything appears to be working fine as expected. (decorations and panels work, except that the "windows can cover" does not properly bring up the panel when fully covered by another window, not sure if that is even implemented yet)

With rc plasmashell and krunner crash and the decorations do not appear anymore

With release plasmashell and krunner run again, but the previously mentioned bug stays (as expected)

Interestingly, it seems to depend on what version of qwayland gets loaded by the client (e.g. Dolphin) and not by kwin.