Bug 375400 - KWIN crashes at start of second application
Summary: KWIN crashes at start of second application
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-22 06:06 UTC by Rüdiger Bente
Modified: 2017-01-22 08:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kwin qdbus support information (4.75 KB, text/plain)
2017-01-22 06:06 UTC, Rüdiger Bente
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rüdiger Bente 2017-01-22 06:06:01 UTC
Created attachment 103582 [details]
kwin qdbus support information

After login, starting the second application, kwin crashes. Does no matter, which are this application, most of the time is start first Firefox and after that Thunderbird, but the problem occurs on other scenarios as well.
Got some debug information:
 Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6905958940 (LWP 1552))]

Thread 4 (Thread 0x7f684ffff700 (LWP 1763)):
#0  0x00007f69054439e3 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f6903c47e5f in qt_safe_select (nfds=15, fdread=fdread@entry=0x7f68480df878, fdwrite=fdwrite@entry=0x7f68480dfb08, fdexcept=fdexcept@entry=0x7f68480dfd98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f6903c4995e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f68480dfd98, writefds=0x7f68480dfb08, readfds=0x7f68480df878, nfds=<optimized out>, this=0x7f6848146070) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f68480df6e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f6903c49e8e in QEventDispatcherUNIX::processEvents (this=0x7f6848146070, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f6903bf3b4a in QEventLoop::exec (this=this@entry=0x7f684fffec60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f6903a10834 in QThread::exec (this=this@entry=0x2c6d270) at thread/qthread.cpp:503
#7  0x00007f68fe5263c5 in QQmlThreadPrivate::run (this=0x2c6d270) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f6903a157be in QThreadPrivate::start (arg=0x2c6d270) at thread/qthread_unix.cpp:331
#9  0x00007f68ff3c96ba in start_thread (arg=0x7f684ffff700) at pthread_create.c:333
#10 0x00007f690544d82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f68db7fe700 (LWP 1586)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f6902b9dbd4 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007f6902b9dc19 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007f68ff3c96ba in start_thread (arg=0x7f68db7fe700) at pthread_create.c:333
#4  0x00007f690544d82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f68e1515700 (LWP 1583)):
#0  0x00007f6903a0dd5f in QBasicAtomicOps<8>::testAndSetRelaxed<QMutexData*> (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=0x1, _q_value=@0x290b638: 0x0) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86.h:259
#1  QGenericAtomicOps<QBasicAtomicOps<8> >::testAndSetRelease<QMutexData*, QMutexData*> (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=<optimized out>, _q_value=@0x290b638: 0x0) at ../../include/QtCore/../../src/corelib/thread/qgenericatomic.h:175
#2  QBasicAtomicPointer<QMutexData>::testAndSetRelease (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=<optimized out>, this=this@entry=0x290b638) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:278
#3  QBasicMutex::fastTryUnlock (current=<synthetic pointer>, this=this@entry=0x290b638) at thread/qmutex.h:85
#4  QMutex::unlock (this=this@entry=0x290b638) at thread/qmutex.cpp:264
#5  0x00007f6903c49d83 in QMutexLocker::unlock (this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:138
#6  QMutexLocker::~QMutexLocker (this=<synthetic pointer>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:132
#7  QThreadData::canWaitLocked (this=<optimized out>) at ../../include/QtCore/5.5.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:240
#8  QEventDispatcherUNIX::processEvents (this=0x7f68d40008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:582
#9  0x00007f6903bf3b4a in QEventLoop::exec (this=this@entry=0x7f68e1514c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#10 0x00007f6903a10834 in QThread::exec (this=this@entry=0x28aa9d0) at thread/qthread.cpp:503
#11 0x00007f68fe5263c5 in QQmlThreadPrivate::run (this=0x28aa9d0) at qml/ftw/qqmlthread.cpp:141
#12 0x00007f6903a157be in QThreadPrivate::start (arg=0x28aa9d0) at thread/qthread_unix.cpp:331
#13 0x00007f68ff3c96ba in start_thread (arg=0x7f68e1515700) at pthread_create.c:333
#14 0x00007f690544d82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f6905958940 (LWP 1552)):
[KCrash Handler]
#6  QV4::Managed::d (this=0x0) at jsruntime/qv4managed_p.h:134
#7  QV4::Managed::as<QV4::RegExpObject> (this=0x0) at jsruntime/qv4managed_p.h:182
#8  toVariant (e=0x2e84f70, value=..., typeHint=typeHint@entry=39, createJSValueForObjects=createJSValueForObjects@entry=true, visitedObjects=visitedObjects@entry=0x0) at jsruntime/qv4engine.cpp:1281
#9  0x00007f68fe3f0294 in QV4::ExecutionEngine::toVariant (this=<optimized out>, value=..., typeHint=typeHint@entry=39, createJSValueForObjects=createJSValueForObjects@entry=true) at jsruntime/qv4engine.cpp:1192
#10 0x00007f68fe4a4a50 in QQmlPropertyPrivate::writeBinding (object=0x34ae9a0, core=..., context=0x2ab1780, expression=expression@entry=0x34aa640, result=..., isUndefined=isUndefined@entry=false, flags=...) at qml/qqmlproperty.cpp:1548
#11 0x00007f68fe5128cf in QQmlBinding::update (this=0x34aa620, flags=...) at qml/qqmlbinding.cpp:198
#12 0x00007f68fe51be06 in QQmlAbstractBinding::setEnabled (f=..., e=true, this=0x34aa658) at ../../include/QtQml/5.5.1/QtQml/private/../../../../../src/qml/qml/qqmlabstractbinding_p.h:110
#13 QQmlObjectCreator::finalize (this=0x32fe710, interrupt=...) at qml/qqmlobjectcreator.cpp:1194
#14 0x00007f68fe4a686e in QQmlComponentPrivate::complete (enginePriv=0x2aa9c20, state=0x2c6a3d0) at qml/qqmlcomponent.cpp:928
#15 0x00007f68fe4a6937 in QQmlComponentPrivate::completeCreate (this=0x2c6a330) at qml/qqmlcomponent.cpp:964
#16 0x00007f68fe4a67a0 in QQmlComponent::create (this=0x2b08700, context=0x2c756b0) at qml/qqmlcomponent.cpp:791
#17 0x00007f68e174b137 in Aurorae::Decoration::init (this=0x2c756d0) at /build/kwin-2AFxJo/kwin-5.5.5/clients/aurorae/src/aurorae.cpp:316
#18 0x00007f690505b1e4 in KWin::Decoration::DecorationBridge::createDecoration (this=0x2804e50, client=client@entry=0x2af8a60) at /build/kwin-2AFxJo/kwin-5.5.5/decorations/decorationbridge.cpp:243
#19 0x00007f6904f45929 in KWin::Client::createDecoration (this=this@entry=0x2af8a60, oldgeom=...) at /build/kwin-2AFxJo/kwin-5.5.5/client.cpp:397
#20 0x00007f6904f4f35b in KWin::Client::updateDecoration (this=this@entry=0x2af8a60, check_workspace_pos=check_workspace_pos@entry=false, force=force@entry=false) at /build/kwin-2AFxJo/kwin-5.5.5/client.cpp:384
#21 0x00007f6904fa010c in KWin::Client::manage (this=this@entry=0x2af8a60, w=w@entry=111149060, isMapped=isMapped@entry=false) at /build/kwin-2AFxJo/kwin-5.5.5/manage.cpp:385
#22 0x00007f6904f316df in KWin::Workspace::createClient (this=this@entry=0x27fbe50, w=111149060, is_mapped=is_mapped@entry=false) at /build/kwin-2AFxJo/kwin-5.5.5/workspace.cpp:484
#23 0x00007f6904f866ac in KWin::Workspace::workspaceEvent (this=0x27fbe50, e=0x7f68e8002b90) at /build/kwin-2AFxJo/kwin-5.5.5/events.cpp:417
#24 0x00007f6903bf2cff in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f68e8002b90, result=result@entry=0x7fffa921d2a8) at kernel/qabstracteventdispatcher.cpp:460
#25 0x00007f68ee66e0a4 in QXcbConnection::handleXcbEvent (this=this@entry=0x2514470, event=event@entry=0x7f68e8002b90) at qxcbconnection.cpp:1044
#26 0x00007f68ee66ee53 in QXcbConnection::processXcbEvents (this=0x2514470) at qxcbconnection.cpp:1532
#27 0x00007f6903c25c01 in QObject::event (this=0x2514470, e=<optimized out>) at kernel/qobject.cpp:1239
#28 0x00007f69044e905c in QApplicationPrivate::notify_helper (this=this@entry=0x250d280, receiver=receiver@entry=0x2514470, e=e@entry=0x7f68e8002310) at kernel/qapplication.cpp:3716
#29 0x00007f69044ee516 in QApplication::notify (this=0x7fffa921d8c0, receiver=0x2514470, e=0x7f68e8002310) at kernel/qapplication.cpp:3499
#30 0x00007f6903bf638b in QCoreApplication::notifyInternal (this=0x7fffa921d8c0, receiver=0x2514470, event=event@entry=0x7f68e8002310) at kernel/qcoreapplication.cpp:965
#31 0x00007f6903bf8786 in QCoreApplication::sendEvent (event=0x7f68e8002310, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:224
#32 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x24fd5f0) at kernel/qcoreapplication.cpp:1593
#33 0x00007f6903c49d52 in QEventDispatcherUNIX::processEvents (this=0x2541a60, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#34 0x00007f68ee6d34dd in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#35 0x00007f6903bf3b4a in QEventLoop::exec (this=this@entry=0x7fffa921d7e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#36 0x00007f6903bfbbec in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#37 0x00007f6903f2fbfc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1542
#38 0x00007f69044e5495 in QApplication::exec () at kernel/qapplication.cpp:2976
#39 0x00007f6905715504 in kdemain (argc=1, argv=0x7fffa921da28) at /build/kwin-2AFxJo/kwin-5.5.5/main_x11.cpp:308
#40 0x00007f6905367830 in __libc_start_main (main=0x400780 <main(int, char**)>, argc=1, argv=0x7fffa921da28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa921da18) at ../csu/libc-start.c:291
#41 0x00000000004007b9 in _start ()


OS-version: Ubuntu 16.04.1 LTS
kde-plasma-version: 5.5.5
Qt-version: 5.5.1
kernel-version: 4.4.0-22-generic   64-bit
Computer is a Acer Aspire E1-531 with 2x Intel Pentium B960 @ 2.2 GHz and 8 GB memory
X-Server version 11.0
Open-GL version 3.0 Mesa 11.2.0
KWin support information attached as file.


After restart kwin, everything went well until logoff.
Comment 1 Martin Flöser 2017-01-22 08:53:54 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***