Bug 375389 - Kwin chrashes when adding new album
Summary: Kwin chrashes when adding new album
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.3
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-01-21 21:30 UTC by Peter Wendel
Modified: 2017-01-24 06:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wendel 2017-01-21 21:30:33 UTC
Application: kwin_x11 (5.8.3)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.4.36-8-default x86_64
Distribution: "openSUSE Leap 42.2"

-- Information about the crash:
I use two screens.

Kwin chrashes when clicking on add ne album in digiKam

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f81c86c6940 (LWP 2725))]

Thread 6 (Thread 0x7f81a5d31700 (LWP 14351)):
#0  0x00007f81c7e24b03 in select () at /lib64/libc.so.6
#1  0x00007f81c54e0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007f81c54e20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007f81c54e2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f81c5491fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f81c52ccf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f81bfe669b8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007f81c52d19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007f81c80f2734 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f81c7e2bd3d in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7f8197f4f700 (LWP 2990)):
#0  0x00007f81c80f70af in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f81c445593b in  () at /usr/lib64/libQt5Script.so.5
#2  0x00007f81c4455969 in  () at /usr/lib64/libQt5Script.so.5
#3  0x00007f81c80f2734 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f81c7e2bd3d in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7f81a5041700 (LWP 2754)):
#0  0x00007f81c7e24b03 in select () at /lib64/libc.so.6
#1  0x00007f81c54e0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007f81c54e20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007f81c54e2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f81c5491fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f81c52ccf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f81bfe669b8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007f81c52d19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007f81c80f2734 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f81c7e2bd3d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f81a7379700 (LWP 2734)):
#0  0x00007f81c7e24b03 in select () at /lib64/libc.so.6
#1  0x00007f81c54e0849 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () at /usr/lib64/libQt5Core.so.5
#2  0x00007f81c54e20c3 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () at /usr/lib64/libQt5Core.so.5
#3  0x00007f81c54e2527 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f81c5491fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f81c52ccf1a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007f81bf0391d5 in  () at /usr/lib64/libQt5DBus.so.5
#7  0x00007f81c52d19e9 in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007f81c80f2734 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f81c7e2bd3d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f81ad549700 (LWP 2726)):
#0  0x00007f81c7e2349d in poll () at /lib64/libc.so.6
#1  0x00007f81c6fa53e2 in  () at /usr/lib64/libxcb.so.1
#2  0x00007f81c6fa6fcf in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007f81ae643839 in  () at /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f81c52d19e9 in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007f81c80f2734 in start_thread () at /lib64/libpthread.so.0
#6  0x00007f81c7e2bd3d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f81c86c6940 (LWP 2725)):
[KCrash Handler]
#6  0x00007f81bfe52dd0 in QQmlBinding::write(QQmlPropertyData const&, QV4::Value const&, bool, QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib64/libQt5Qml.so.5
#7  0x00007f81bfe5424a in QQmlBinding::update(QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib64/libQt5Qml.so.5
#8  0x00007f81bfe5d2f6 in  () at /usr/lib64/libQt5Qml.so.5
#9  0x00007f81bfdeb93b in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () at /usr/lib64/libQt5Qml.so.5
#10 0x00007f81bfdeb9f7 in QQmlComponentPrivate::completeCreate() () at /usr/lib64/libQt5Qml.so.5
#11 0x00007f81bfdeb880 in QQmlComponent::create(QQmlContext*) () at /usr/lib64/libQt5Qml.so.5
#12 0x00007f81a50887cf in  () at /usr/lib64/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#13 0x00007f81c7a4e047 in  () at /usr/lib64/libkwin.so.5
#14 0x00007f81c7932891 in KWin::Client::createDecoration(QRect const&) () at /usr/lib64/libkwin.so.5
#15 0x00007f81c79335ab in KWin::Client::updateDecoration(bool, bool) () at /usr/lib64/libkwin.so.5
#16 0x00007f81c7994ed6 in KWin::Client::manage(unsigned int, bool) () at /usr/lib64/libkwin.so.5
#17 0x00007f81c7916994 in KWin::Workspace::createClient(unsigned int, bool) () at /usr/lib64/libkwin.so.5
#18 0x00007f81c79830e0 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () at /usr/lib64/libkwin.so.5
#19 0x00007f81c5491270 in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () at /usr/lib64/libQt5Core.so.5
#20 0x00007f81ae641be4 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () at /usr/lib64/libQt5XcbQpa.so.5
#21 0x00007f81ae643c3b in QXcbConnection::processXcbEvents() () at /usr/lib64/libQt5XcbQpa.so.5
#22 0x00007f81c54bf166 in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#23 0x00007f81c619ee3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#24 0x00007f81c61a349a in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#25 0x00007f81c5493fc5 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#26 0x00007f81c5495daa in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQt5Core.so.5
#27 0x00007f81c54e24b4 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#28 0x00007f81ae6a594d in  () at /usr/lib64/libQt5XcbQpa.so.5
#29 0x00007f81c5491fdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#30 0x00007f81c5499ec6 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#31 0x00007f81c83139cc in kdemain () at /usr/lib64/libkdeinit5_kwin_x11.so
#32 0x00007f81c7d626e5 in __libc_start_main () at /lib64/libc.so.6
#33 0x0000000000400809 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2017-01-22 08:51:18 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***
Comment 2 Peter Wendel 2017-01-22 14:18:26 UTC
I'm already using breeze window decoration. It prevents ImageWriter fromm crashing kwin, but others still do when opening additional windows.
Comment 3 Martin Flöser 2017-01-22 16:11:56 UTC
Am 2017-01-22 15:18, schrieb Peter Wendel:
> COMMENT # 2 [1] ON BUG 375389 [2] FROM PETER WENDEL
> 
> I'm already using breeze window decoration. It prevents ImageWriter
> fromm
> crashing kwin, but others still do when opening additional windows.

Bug #375407 clearly says you use an aurorae decoration.
Comment 4 Peter Wendel 2017-01-23 17:14:42 UTC
But in this bug (375389) breeze-dark window-decoration is used.
Comment 5 Martin Flöser 2017-01-23 18:11:42 UTC
(In reply to Peter Wendel from comment #4)
> But in this bug (375389) breeze-dark window-decoration is used.

no this bug is not about breeze. Your initial comment clearly shows a backtrace of aurorae. If you have an issue with breeze: report a new bug. No dev can understand that you are talking about a breeze bug in a report clearly about aurorae.
Comment 6 Peter Wendel 2017-01-23 19:44:32 UTC
You marked it as duplicate. 
I only used your kde-tool for reporting a bug.

So this is a new bug with brezze but the same behaviour of kwin as in aurorae.
It quite seems something is wrong with kwin not with any kind of decoration, when this happens in breeze and aurorae.
Comment 7 Martin Flöser 2017-01-24 06:13:34 UTC
This is a technical bug tracker and in order to fix bugs we need to keep 
to some rules. One of the rules is "one issue per bug report" another is 
"the issue is described in the first comment". You reported a crash 
through our crash reporting tool. This crash is in Aurorae. Thus this 
bug report is about the issue about aurorae and nothing else. If you 
want to report another issue, please report a new bug.

For us developers it's impossible to manage bugs if reports are about 
multiple and different issues. Please understand this. We get every day 
for KWin about 5 new bug reports. One of our main task is just to manage 
them. Fixing happens at a different time. In order to fix bugs the 
reports need to be in a high quality. They must be precise. A developer 
must be able to look at it and understand where the bug is. If a bug 
report mentions multiple issues in different areas it's not possible. In 
this specific case: a developer will look at the first comment, see the 
well known Aurorae issue and move on.

So I kindly ask to leave this bug report as a duplicate and to report 
any other issue as a new bug report.

*** This bug has been marked as a duplicate of bug 361236 ***