Bug 375303 - KDenLive 16.12.1 Windows Port - 'Full Luma' Option Misbehaving
Summary: KDenLive 16.12.1 Windows Port - 'Full Luma' Option Misbehaving
Status: RESOLVED WORKSFORME
Alias: None
Product: kdenlive
Classification: Unclassified
Component: Video Display & Export (show other bugs)
Version: 16.12.1
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-19 16:38 UTC by bryanworsley
Modified: 2020-10-12 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
fritzibaby: timeline_corruption+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bryanworsley 2017-01-19 16:38:44 UTC
The effect of applying the 'Full Luma' Option in the Windows port of KDenLive 16.12.1 (tested on Win7 x64) is different from that of the linux version of 16.12.1 running on Kubuntu 16.10 AMD64. Specifically, when applied to 'full range' (0-255) YUV 4:2:2 inputs it results in clipping to Limited 16-235 range when the expected outcome is compression (scaling) to 16-235 range. 

The issue and implications are explained in more detail, along with with examples, in the KDenLive Forum thread:

https://forum.kde.org/viewtopic.php?f=265&t=138529
Comment 1 emohr 2018-10-11 19:19:45 UTC
Please try with the actual Kdenlive version 18.08.1
Comment 2 emohr 2020-09-12 15:56:09 UTC
Please try with version 20.08.1. In this version comma/point decimal separator issue and redning issues on Windows is solved.
Comment 3 Bug Janitor Service 2020-09-27 04:33:10 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2020-10-12 04:33:13 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!