Bug 374808 - Dependency on QtWebEngine might make KDE non-(free/libre)
Summary: Dependency on QtWebEngine might make KDE non-(free/libre)
Status: RESOLVED NOT A BUG
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified All
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-09 12:12 UTC by Adonay Felipe Nogueira
Modified: 2017-07-15 22:54 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adonay Felipe Nogueira 2017-01-09 12:12:35 UTC
Hi KDE,

I'm a free/libre software activist from Brazil, and I have an important suggestion to make:

Over the years, the KDE project has contributed significantly to the spread of the free/libre software movement's goals, while also keeping the project's resources a friendly and informative place for every contributor, and for this purpose, you all have my gratitude.

However, recently, we free/libre software activists became aware of an issue which can change the status of KDE from free/libre software to non-(free/libre) software.

The issue, to put it simply, is that with the rescent rise of QtWeEngine, and since QtWebEngine "is" the entire [non-(free/libre) Chromium] platform (words taken from Qt Wiki), and since more and more components of the KDE project become dependent on QtWebEngine, this creates a chain reaction which affects the KDE project if not acted upon in time.

I have taken the time to draw some suggestions, although they were in no way checked against any other context or variable that might make them doable or not. Here are the suggestions:

- Contribute to the project responsible for QtWebEngine ways to completely remove the non-(free/libre) parts of the platform before releasing the complete and corresponding source files to the general public.

- Contribute to the Chromium project ways to completely remove the non-(free/libre) parts of the platform before releasing the complete and corresponding source files to the general public.

- Make a policy against usage of QtWebEngine in KDE project or subprojects.

- Fork either QtWebEngine or Chromium and completely remove the non-(free/libre) parts of the platform before releasing the complete and corresponding source files to the general public.

Of course, reporting this issue without leaving a basis of evidence isn't polite, so here is a link to a discussion which also has other links to more detailed reports: <https://lists.gnu.org/archive/html/libreplanet-discuss/2017-01/msg00001.html>, feel free to subscribe to the related mailing list and ask for input there.

As a final congratulation note: I thank you for your work once again, and I believe we can solve this issue so as to make good digital inclusion towards a free/libre digital society, specially here in Brazil, where most free/libre software related events always have a talk or panel related to the KDE project.


Respectfully, Adonay.
Comment 1 Christoph Feck 2017-01-09 21:53:39 UTC
The KDE bug tracker is the wrong medium to discuss these issues. Please post your message to the QtWebEngine mailing list.

http://lists.qt-project.org/mailman/listinfo/qtwebengine
Comment 2 Lukas Ba. 2017-01-18 22:59:07 UTC
Packages you have to remove when removing qt5-webengine, since they depend on qt5-webengine (on Arch Linux).

akonadi-contacts akonadi-calendar kdepim-runtime libkdepim kalarm mailimporter pimcommon kdepim-apps-libs mailcommon messagelib libgravatar
Comment 3 markuss 2017-01-19 05:05:09 UTC
Numerous Linux distributors reviewed the code base and came to the conclusion that it's fully free software.
Comment 4 Kai Koehne 2017-06-07 12:26:31 UTC
Qt WebEngine developer here. I'd just like to point out that the referenced discussion in libreplanet is based on a misunderstanding of one sentence on wiki.qt.io that I fixed as soon as I heard about this. Qt WebEngine is _not_ Chromium in the sense that we're blindly copying all of the chromium git. We do remove quite a bit actually, including binary blobs, home-calling functionality ...
Comment 5 Adonay Felipe Nogueira 2017-07-15 22:54:09 UTC
Thank you for the comments so far, and also for the corrections. :)

We will be reviewing the issue in question in more detail in the future. Currently, we are lacking an updated review. From the references I have made so far to the thread on the libreplanet-discuss mailing list one can see that I already made those involved aware of the recent updates, and also suggested for an updated review, although I can't say surely when it will be made.

In any case, I hope QtWebEngine has taken the reviews (although old) into consideration and tries to solve the problematic things (mainly the ones possibly related to software freedom, and secondly those related to privacy and security).