Bug 374120 - Add option to display all whitespace/invisible/control characters (i.e. \n)
Summary: Add option to display all whitespace/invisible/control characters (i.e. \n)
Status: RESOLVED DUPLICATE of bug 342811
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2016-12-24 17:33 UTC by nicholas
Modified: 2019-02-20 00:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicholas 2016-12-24 17:33:36 UTC
Kate version 16.12

kate does not seem to have the ability to display control characters i.e. \n. This makes an otherwise great application useless for example inspecting or troubleshooting and input file during coding e.g. json. Could we have display option display of control characters?
Comment 1 Christoph Feck 2016-12-30 16:54:34 UTC
\n is the newline character, which you can 'see' because the line breaks. Are you talking about a missing trailing newline at the end of the file? There is an option forcing it on save.
Comment 2 nicholas 2016-12-30 19:15:45 UTC
On Friday, 30 December 2016 16:54:34 CET you wrote:
> https://bugs.kde.org/show_bug.cgi?id=374120
> 
> --- Comment #1 from Christoph Feck <cfeck@kde.org> ---
> \n is the newline character, which you can 'see' because the line breaks.
> Are you talking about a missing trailing newline at the end of the file?
> There is an option forcing it on save.

its not that clear, for example journalctl spits out single json records split 
on new lines. 
Since the id numbers are enourmous + other codes, combined with word wrapping 
it is very difficult to see any new lines (jagged mess). depending on the width 
of the kate window it can be impossible to see.

atom has the 'show invisibles' and sublime has equivlent. i have just looked 
in atom and found they used the ¬ symbol, upon review i think this would be 
much better.
Comment 3 Nate Graham 2019-02-20 00:02:10 UTC

*** This bug has been marked as a duplicate of bug 342811 ***