Bug 373989 - Kmail 5.4 / akonadi agents hogging cpu cores
Summary: Kmail 5.4 / akonadi agents hogging cpu cores
Status: RESOLVED DUPLICATE of bug 373443
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Mail Dispatcher Agent (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-21 08:27 UTC by PeterF
Modified: 2017-01-06 22:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of processes running (107.33 KB, image/png)
2016-12-21 08:27 UTC, PeterF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PeterF 2016-12-21 08:27:16 UTC
Created attachment 102916 [details]
Screenshot of processes running

Running Kmail 5.4 on ArchLinux. 
I have three akonadi agents running wild (see screenshot). Tried to logoff and login again, but it did not fix the problem.
I have also tried to abort the processes via "akonadi-console" but this had no effect either.
Comment 1 PeterF 2016-12-21 12:30:28 UTC
I was able to partially resolve the issue, by issuing "akonadictl stop".
I have then deleted the "config" and "dat" files in ~/.config/akonadi
(maildespatcher, migration_assistant and notes).
When I restarted kmail2 it shows only the "akonadi_notes_agent" with 25% usage.
Kindly investigate
Comment 2 Rewarp 2016-12-28 16:16:14 UTC
Possible duplicate of https://bugs.kde.org/show_bug.cgi?id=373443
Comment 3 Daniel Vrátil 2017-01-06 22:06:55 UTC

*** This bug has been marked as a duplicate of bug 373443 ***