Bug 373969 - Delete action does not work with keyboard shortcut
Summary: Delete action does not work with keyboard shortcut
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-20 18:24 UTC by Samuel Gilbert
Modified: 2017-08-21 06:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Gilbert 2016-12-20 18:24:10 UTC
The delete message action no longer works with the SHIFT-DEL keyboard shortcut.  Setting the shortcut to something else (I tested with SHIFT-P) or adding an delete icon in the toolbar does work.

This is in Version 5.4.0 Using :
KDE Frameworks 5.29.0
Qt 5.7.1 (built against 5.7.1)
The xcb windowing system


Expected behaviour :

When viewing the message list, pressing SHIFT-DEL should delete the selected messages.


Current behaviour :

In the message list, when one or more messages are selected pressing SHIFT-DEL does nothing.
Comment 1 Marc Schmitzer 2017-01-15 14:39:45 UTC
I think I'm experiencing the same issue. Specifically, changing the selection in the message list sets focus to the message preview pane. There, Shift-Del does not work (but e.g. Del alone for "move to trash" works). On the message list itself, Shift+Del does work (if you manage to get focus there).

I don't know which of the two (focus change or no shift+del on preview pane) is new, but it's quite aggravating in combination.

Version: kmail-16.08.3 on Fedora 25
Comment 2 Kunszt Arpad 2017-08-21 06:37:15 UTC
I also suffer from this bug. I can delete only once after the KMail started but then nothing happens. If I change the shortcut to something else I can delete once more again but then it doesn't work again.

It's also working when I select the message again, so it could be a focus issue.

It's very annoying as I used to use Shift+Del since KMail 1.x era.

Currently I'm using KMail 5.5.3.