Bug 373899 - Krusader Crashes on Quit, since update to 2.5 then back to 2.4-beta3
Summary: Krusader Crashes on Quit, since update to 2.5 then back to 2.4-beta3
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: krusader
Classification: Applications
Component: general (show other bugs)
Version: 2.4.0-beta3 "Single Step"
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Krusader Bugs Distribution List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-12-19 17:16 UTC by Landis
Modified: 2018-05-06 00:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Landis 2016-12-19 17:16:21 UTC
Application: krusader (2.4.0-beta3 "Single Step")
KDE Platform Version: 4.14.9
Qt Version: 4.8.6
Operating System: Linux 3.16.7-53-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Close (Quit) Krusader.
Crash.
Everytime I close krusader.
krusader works just fine while open and working.
I have No issues with the function of krusader. I use it to transfer data to and from servers all the time. again, no issue in fuction. Just when Quitting, Crahs, Everytime.

I've changed installed version from opensuse repo to kde: extra repo to ??
I had updated to 2.5 and it crashed on every exit and it needs qt5.
I do NOT want, Ever, plasma5 on my system. It is ugly Junk.

So, I down graded back to 2.4.0-beta3
Now, All version crash on quit since installing krusader 2.5
I've checked and double checked dependencies. All seems right??

Other apps that crash on exit: guadyadeque and sometimes smplayer. They claim some kind of .cache/font issue.
Everything else is great.

The crash can be reproduced every time.

-- Backtrace:
Application: Krusader (krusader), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8ac7d19780 (LWP 31071))]

Thread 2 (Thread 0x7f8ab5048700 (LWP 31072)):
#0  0x00007f8ac41f42bd in poll () from /lib64/libc.so.6
#1  0x00007f8ac09cbbe4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8ac09cbcec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8ac4ef50de in QEventDispatcherGlib::processEvents (this=0x7f8ab00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#4  0x00007f8ac4ec6e6f in QEventLoop::processEvents (this=this@entry=0x7f8ab5047e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8ac4ec7165 in QEventLoop::exec (this=this@entry=0x7f8ab5047e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8ac4dc40bf in QThread::exec (this=this@entry=0x2905890) at thread/qthread.cpp:538
#7  0x00007f8ac4ea8783 in QInotifyFileSystemWatcherEngine::run (this=0x2905890) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f8ac4dc679f in QThreadPrivate::start (arg=0x2905890) at thread/qthread_unix.cpp:349
#9  0x00007f8ac1fb40a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f8ac41fc6ed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f8ac7d19780 (LWP 31071)):
[KCrash Handler]
#6  0x00007f8ac55fbd29 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2919080, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f8ac55fbda9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2919080, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f8ac561407c in QWidgetBackingStore::~QWidgetBackingStore (this=0x2b2ca00, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f8ac5450709 in QWidgetBackingStoreTracker::destroy (this=0x2955030) at kernel/qwidget.cpp:225
#10 0x00007f8ac54508a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x27b78f0) at kernel/qwidget.cpp:1833
#11 0x00007f8ac5450abd in QWidgetPrivate::~QWidgetPrivate (this=0x27b78f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0x00007f8ac5450d49 in QWidgetPrivate::~QWidgetPrivate (this=0x27b78f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0x00007f8ac4ee10b5 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x27f57b0, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x27f57a8, __in_chrg=<optimized out>) at kernel/qobject.cpp:844
#16 0x00007f8ac54594cc in QWidget::~QWidget (this=0x27f57a8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0x00007f8ac74e17b9 in ~Private (this=0x27f5780, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.14.9/kdeui/kernel/kstartupinfo.cpp:125
#18 KStartupInfo::~KStartupInfo (this=0x27b45b0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.14.9/kdeui/kernel/kstartupinfo.cpp:220
#19 0x00007f8ac74e1849 in KStartupInfo::~KStartupInfo (this=0x27b45b0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.14.9/kdeui/kernel/kstartupinfo.cpp:221
#20 0x00007f8ac4edeae8 in QObjectPrivate::deleteChildren (this=this@entry=0x2640ac0) at kernel/qobject.cpp:1944
#21 0x00007f8ac4ee107f in QObject::~QObject (this=0x7ffcddc4db80, __in_chrg=<optimized out>) at kernel/qobject.cpp:954
#22 0x00007f8ac540e789 in QApplication::~QApplication (this=0x7ffcddc4db80, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1098
#23 0x0000000000451ada in ?? ()
#24 0x00007f8ac4136b05 in __libc_start_main () from /lib64/libc.so.6
#25 0x000000000045341b in _start ()

Possible duplicates by query: bug 344044, bug 343150, bug 342543, bug 330038.

Reported using DrKonqi
Comment 1 Alex Bikadorov 2016-12-19 19:58:37 UTC
You already reported this bug yourself: bug 343150. And it is still a duplicate.

And (if nobody wants to correct me) we are not supporting the KDE4 version anymore.

*** This bug has been marked as a duplicate of bug 261539 ***