Bug 373871 - New mails are not inserted into the database
Summary: New mails are not inserted into the database
Status: RESOLVED DUPLICATE of bug 373782
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: GIT (master)
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-19 00:11 UTC by Luis Silva
Modified: 2016-12-25 17:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Silva 2016-12-19 00:11:21 UTC
New mails are not inserted into the database because of the following error:
org.kde.pim.akonadiserver: DATABASE ERROR:
org.kde.pim.akonadiserver:   Error code: 1292
org.kde.pim.akonadiserver:   DB error:  "Incorrect datetime value: '0000-00-00 00:00:00' for column 'datetime' at row 1"
org.kde.pim.akonadiserver:   Error text: "Incorrect datetime value: '0000-00-00 00:00:00' for column 'datetime' at row 1 QMYSQL3: Unable to execute statement"
org.kde.pim.akonadiserver:   Query: "INSERT INTO PimItemTable (rev, remoteId, remoteRevision, gid, collectionId, mimeTypeId, datetime, atime, dirty, size) VALUES (:0, :1, :2, :3, :4, :5, :6, :7, :8, :9)"
org.kde.pim.akonadiserver: Error during insertion into table "PimItemTable" "Incorrect datetime value: '0000-00-00 00:00:00' for column 'datetime' at row 1 QMYSQL3: Unable to execute statement"
org.kde.pim.akonadicore: Creating/updating items from the akonadi database failed: "Unknown error."
org.kde.pim.akonadicore: "Unknown error."
org.kde.pim.akonadicore: Creating/updating items from the akonadi database failed: "Failed to append item"
org.kde.pim.akonadicore: Error during ItemSync:  "Failed to append item"
Comment 1 Piotr Belniak 2016-12-19 09:19:35 UTC
I am not sure how to vote for the fix - so adding comment as it affects my kmail too.
Comment 2 abyss.andrey 2016-12-20 13:38:04 UTC
Confirm the bug
Can't retrieve any mail messages

I'm using KDE Neon 5.8
KDE Plasma 5.8.4
KDE Frameworks 5.29.0
Qt 5.7.0
Kernel 4.4.0-53-generic
x64

$mysql -V
mysql  Ver 14.14 Distrib 5.7.16, for Linux (x86_64) using  EditLine wrapper
Comment 3 T Zachmann 2016-12-25 17:42:14 UTC
There is a workaround described in bug 373782.

*** This bug has been marked as a duplicate of bug 373782 ***