Bug 373785 - kwin crash in apper
Summary: kwin crash in apper
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-12-17 19:35 UTC by Larry
Modified: 2016-12-18 13:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Standar error with Breeze (3.35 KB, text/x-log)
2016-12-18 13:07 UTC, Larry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Larry 2016-12-17 19:35:56 UTC
Application: kwin_x11 (5.8.4)

Qt Version: 5.7.0
Frameworks Version: 5.27.0
Operating System: Linux 4.8.13-300.fc25.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed: I loaded apper and tried to browse a category.  I tried to browse several categories.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1838518940 (LWP 10768))]

Thread 6 (Thread 0x7f1828b9d700 (LWP 31032)):
#0  0x00007f18488ae0d1 in ppoll () from /lib64/libc.so.6
#1  0x00007f18496b0021 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /lib64/libQt5Core.so.5
#2  0x00007f18496b1536 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#3  0x00007f184966507a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007f18494c2673 in QThread::exec() () from /lib64/libQt5Core.so.5
#5  0x00007f185017f735 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#6  0x00007f18494c6a4a in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#7  0x00007f184b6db6ca in start_thread () from /lib64/libpthread.so.0
#8  0x00007f18488b9f6f in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f18298a2700 (LWP 28032)):
#0  0x00007f18488ae0d1 in ppoll () from /lib64/libc.so.6
#1  0x00007f18496b0021 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /lib64/libQt5Core.so.5
#2  0x00007f18496b1536 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#3  0x00007f184966507a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007f18494c2673 in QThread::exec() () from /lib64/libQt5Core.so.5
#5  0x00007f185017f735 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#6  0x00007f18494c6a4a in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#7  0x00007f184b6db6ca in start_thread () from /lib64/libpthread.so.0
#8  0x00007f18488b9f6f in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f1807fff700 (LWP 10779)):
#0  0x00007f184b6e1460 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1850f27bd4 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /lib64/libQt5Script.so.5
#2  0x00007f1850f27c19 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib64/libQt5Script.so.5
#3  0x00007f184b6db6ca in start_thread () from /lib64/libpthread.so.0
#4  0x00007f18488b9f6f in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f1816c1c700 (LWP 10776)):
#0  0x00007f18488ae0d1 in ppoll () from /lib64/libc.so.6
#1  0x00007f18496b0021 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /lib64/libQt5Core.so.5
#2  0x00007f18496b1536 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#3  0x00007f184966507a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007f18494c2673 in QThread::exec() () from /lib64/libQt5Core.so.5
#5  0x00007f185017f735 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#6  0x00007f18494c6a4a in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#7  0x00007f184b6db6ca in start_thread () from /lib64/libpthread.so.0
#8  0x00007f18488b9f6f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f182b0fa700 (LWP 10773)):
#0  0x00007f18488ae0d1 in ppoll () from /lib64/libc.so.6
#1  0x00007f18496b0021 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /lib64/libQt5Core.so.5
#2  0x00007f18496b1536 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#3  0x00007f184966507a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007f18494c2673 in QThread::exec() () from /lib64/libQt5Core.so.5
#5  0x00007f184b1d77a9 in QDBusConnectionManager::run() () from /lib64/libQt5DBus.so.5
#6  0x00007f18494c6a4a in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#7  0x00007f184b6db6ca in start_thread () from /lib64/libpthread.so.0
#8  0x00007f18488b9f6f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1838518940 (LWP 10768)):
[KCrash Handler]
#6  0x00007f185016adb0 in QQmlBinding::write(QQmlPropertyData const&, QV4::Value const&, bool, QFlags<QQmlPropertyPrivate::WriteFlag>) () from /lib64/libQt5Qml.so.5
#7  0x00007f185016bd15 in QQmlBinding::update(QFlags<QQmlPropertyPrivate::WriteFlag>) () from /lib64/libQt5Qml.so.5
#8  0x00007f18501759f5 in QQmlObjectCreator::finalize(QQmlInstantiationInterrupt&) () from /lib64/libQt5Qml.so.5
#9  0x00007f18500ff2ce in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () from /lib64/libQt5Qml.so.5
#10 0x00007f18500ff397 in QQmlComponentPrivate::completeCreate() () from /lib64/libQt5Qml.so.5
#11 0x00007f18500ff200 in QQmlComponent::create(QQmlContext*) () from /lib64/libQt5Qml.so.5
#12 0x00007f1828e198b7 in Aurorae::Decoration::init() () from /usr/lib64/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#13 0x00007f18519450c9 in KWin::Decoration::DecorationBridge::createDecoration(KWin::AbstractClient*) () from /lib64/libkwin.so.5
#14 0x00007f1851825262 in KWin::Client::createDecoration(QRect const&) () from /lib64/libkwin.so.5
#15 0x00007f1851825e4d in KWin::Client::updateDecoration(bool, bool) () from /lib64/libkwin.so.5
#16 0x00007f1851884e75 in KWin::Client::manage(unsigned int, bool) () from /lib64/libkwin.so.5
#17 0x00007f18518086f4 in KWin::Workspace::createClient(unsigned int, bool) () from /lib64/libkwin.so.5
#18 0x00007f1851872087 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /lib64/libkwin.so.5
#19 0x00007f184966412c in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () from /lib64/libQt5Core.so.5
#20 0x00007f18318931f4 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () from /lib64/libQt5XcbQpa.so.5
#21 0x00007f1831893e85 in QXcbConnection::processXcbEvents() () from /lib64/libQt5XcbQpa.so.5
#22 0x00007f184968e0a9 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#23 0x00007f1849eae96c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#24 0x00007f1849eb6111 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#25 0x00007f18496660ea in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#26 0x00007f18496687d0 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#27 0x00007f18496b13ab in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#28 0x00007f183190a7ed in QUnixEventDispatcherQPA::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5XcbQpa.so.5
#29 0x00007f184966507a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#30 0x00007f184966cb7c in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#31 0x00007f1851c490b6 in kdemain () from /lib64/libkdeinit5_kwin_x11.so
#32 0x00007f18487d2401 in __libc_start_main () from /lib64/libc.so.6
#33 0x000055ed9a96dcca in _start ()

Possible duplicates by query: bug 373472, bug 373170, bug 372015, bug 371929, bug 371824.

Reported using DrKonqi
Comment 1 Larry 2016-12-17 19:43:37 UTC
I don't know if it's relevant but I did enable DRI3 in response to https://bugzilla.redhat.com/show_bug.cgi?id=1399396.  Before enabling DRI3, loading apper and selecting a category (any category) would cause the bug above fairly consistently.
Comment 2 Martin Flöser 2016-12-18 08:53:03 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***
Comment 3 Larry 2016-12-18 13:07:15 UTC
Created attachment 102854 [details]
Standar error with Breeze

Still fails but appears different