Bug 373565 - the name of libs have 'SOVERSION' (literally) in the name
Summary: the name of libs have 'SOVERSION' (literally) in the name
Status: RESOLVED FIXED
Alias: None
Product: kalzium
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mageia RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kalzium Developers
URL:
Keywords: release_blocker
Depends on:
Blocks:
 
Reported: 2016-12-12 10:37 UTC by David Geiger
Modified: 2016-12-14 17:46 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Geiger 2016-12-12 10:37:44 UTC
Hi,

build latest 16.11.90 release make the name of their libs with extension 'SONAME' literally:

/usr/lib64/libcompoundviewer.so
/usr/lib64/libcompoundviewer.so.SOVERSION
/usr/lib64/libscience.so
/usr/lib64/libscience.so.SOVERSION


Reproducible: Always

Steps to Reproduce:
1.build
2.list the files


Actual Results:  
name of libs contains a '.SONAME' extension

Expected Results:  
name of libs contains the version number(?) extension
Comment 1 Christoph Feck 2016-12-12 23:05:47 UTC
Adding release manager, because this looks like a release blocker.
Comment 2 Luigi Toscano 2016-12-13 00:00:03 UTC
Both libraries use GENERIC_LIB_VERSION and GENERIC_LIB_SOVERSION, which were exported by kdelibs4. The fix could be easy.
Comment 3 Unknown 2016-12-13 00:49:10 UTC
Git commit e16b0159acc01efcdc8b51b04b8eb6303b16b0db by Luigi Toscano.
Committed on 13/12/2016 at 00:05.
Pushed by ltoscano into branch 'Applications/16.12'.

Fix the soname of kalzium internal libraries

GENERIC_LIB_VERSION and GENERIC_LIB_SOVERSION where exported by kdelibs4.
Define local variables for the version of the libraries.

M  +5    -0    CMakeLists.txt
M  +2    -2    compoundviewer/CMakeLists.txt
M  +1    -1    libscience/CMakeLists.txt

https://commits.kde.org/kalzium/e16b0159acc01efcdc8b51b04b8eb6303b16b0db