Bug 373442 - Migration Agent spins at 100% CPU after upgrade from 4:16.08.2+p16.04+git20161117.2322-0 to 4:16.08.3+p16.04+git20161207.0319-0
Summary: Migration Agent spins at 100% CPU after upgrade from 4:16.08.2+p16.04+git2016...
Status: RESOLVED DUPLICATE of bug 373443
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Migration (show other bugs)
Version: 5.3.2
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-08 22:19 UTC by Gunter Ohrner
Modified: 2017-01-06 21:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gunter Ohrner 2016-12-08 22:19:45 UTC
After today's KDE Neon update from Akonadi 4:16.08.2+p16.04+git20161117.2007-0 to 4:16.08.3+p16.04+git20161208.0216-0, Migration Agent spins at 100% CPU.

It starts doing this immediately after login and also continues immediately after an "akonadictl restart".

Upon "akonadictl stop", Migration Agent crashes instead of shutting down cleanly.
Comment 1 Gunter Ohrner 2016-12-09 09:08:45 UTC
In Akonadi console, this Agent is never displayed as running or online, but labeled with an unconnected plug icon and shown as offline. Meanwhile, it's happily spinning away, eating CPU and causing lots of noise due to the CPU fan having to run at full speed...

The only workaround I could find so far was entirely removing this Akonadi Agent using the Akonadi console. I'm not sure what effects this might have, however...

What option's do I have to determine why this agent is not initialising correctly but (apparently) enters an infinite loop instead? What's it doing?
Comment 2 Andreas 2016-12-23 10:28:54 UTC
I see this as well with the kde neon release. Besides the migration-agent eating CPU, kmail does not show me my mail from imap accounts anymore and sending mails fails with database errors. Removing account and adding it back did not help. Removing .local/share/akonad neither.
Comment 3 Gunter Ohrner 2017-01-06 10:03:05 UTC
Related to bug 373443, appears to be fixed on master and branch head.
Comment 4 Daniel Vrátil 2017-01-06 21:57:20 UTC

*** This bug has been marked as a duplicate of bug 373443 ***