Bug 373131 - plasmashell freezes irretrievably every few minutes -- needs to be killed
Summary: plasmashell freezes irretrievably every few minutes -- needs to be killed
Status: RESOLVED DUPLICATE of bug 373427
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.8.4
Platform: Debian unstable Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
: 373697 (view as bug list)
Depends on:
Reported: 2016-12-01 09:51 UTC by arne anka
Modified: 2017-09-08 18:15 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:

Video sequence that demonstrates this bug (3.08 MB, video/x-matroska)
2017-01-06 09:06 UTC, Roland Tapken
Rolan's GDB trace (10.35 KB, text/plain)
2017-01-18 13:53 UTC, David Edmundson
xorg file (2.01 KB, text/plain)
2017-01-28 15:43 UTC, Kestutis

Note You need to log in before you can comment on or make changes to this bug.
Description arne anka 2016-12-01 09:51:02 UTC
since one of the latest updates (about thursday), plasmashell suddenly freezes every few minutes -- sometimes every 2 or 3, mostly after 20 or 40 minutes.

i am not sure what features exactly fall under "plasmashell", but logout via ctrl+alt+del works (logout selection comes up), window switching via alt+tab works as well.
only the panels seem to be affected -- they're frozen, clock doesn't update anymore and no window can be selected from the taskbar.

it seems to happen more frequently the more windows are open, but that is just an impression. 

trying to kill plasmashell via kquitapp5 in that case produces this:

$ kquitapp5 plasmashell
"Quitting application plasmashell failed. Error reported was:\n\n     org.freedesktop.DBus.Error.NoReply : Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

there's nothing in .xsession-errors, or any other logs, and since there seem to be no debug packages available in debian/sid I can't even produce a useful dump with drkonqui

any hints what I can do to narrow the cause down?

- xserver-xorg-video-radeon 1:7.8.0-1+b1
- dbus-x11 1.10.14-1
- kernel 4.8.0-1-amd64 #1 SMP Debian 4.8.7-1 (2016-11-13) x86_64 GNU/Linux
- SSD crucial mx300
Comment 1 Thomas Florek 2016-12-02 19:01:36 UTC
I confirm @arne anka's findings on my install.
Debian unstable, Fully upgraded.
Kernel: 4.8.11-towo.3-siduction-amd64 x86_64 (64 bit) Desktop: KDE Plasma 5.8.4
Comment 2 arne anka 2016-12-02 19:19:31 UTC
@thflorek: do you have an SSD?
I am trying to figure out if this is related to that hardware change
Comment 3 Syd Alsobrook 2016-12-02 19:35:37 UTC
I can confirm this issue.

I have two machines at the same patch level, one Radeon, one Intel video. The Intel system does not exhibit this issue.

Debian Sid
Kernel: 4.8.0-1-amd64
xserver-xorg-video-radeon: 1:7.8.0-1+b1-amd64
kdeplasma-addons-data: 4:5.8.4-1-all
libkf5plasma5:amd64: 5.28.0-1-amd64
libkf5plasmaquick5:amd64: 5.28.0-1-amd64
libplasma-geolocation-interface5: 4:5.8.4-1-amd64
libplasma3: 4:4.14.26-1-amd64
plasma-applet-redshift-control: 1.0.17-1-all
plasma-dataengines-addons: 4:5.8.4-1-amd64
plasma-desktop: 4:5.8.4-1-amd64
plasma-desktop-data: 4:5.8.4-1-all
plasma-discover: 5.8.3-1-amd64
plasma-discover-common: 5.8.3-1-all
plasma-framework: 5.28.0-1-amd64
plasma-integration: 5.8.4-1-amd64
plasma-mediacenter: 5.7.3-1-amd64
plasma-nm: 4:5.8.4-1-amd64
plasma-pa: 4:5.8.4-1-amd64
plasma-runner-installer: 3.0.2-1+b1-amd64
plasma-runner-telepathy-contact: 15.08.3-1-amd64
plasma-runners-addons: 4:5.8.4-1-amd64
plasma-scriptengine-javascript: 4:16.08.3-1-amd64
plasma-scriptengine-python: 4:4.11.13-2-all
plasma-scriptengine-superkaramba: 4:4.14.2-1-amd64
plasma-scriptengine-webkit: 4:4.11.13-2-amd64
plasma-theme-oxygen: 4:5.8.4-1-amd64
plasma-wallpapers-addons: 4:5.8.4-1-amd64
plasma-widget-folderview: 4:16.04.1-1-amd64
plasma-widget-lancelot: 4:4.14.2-1-amd64
plasma-widget-menubar: 0.2.0-2-amd64
plasma-widget-message-indicator: 0.5.8-3-amd64
plasma-widget-smooth-tasks: 1flupp0~hg20120610-2+b1-amd64
plasma-widgets-addons: 4:5.8.4-1-amd64
plasma-workspace: 4:5.8.4-1-amd64
plasma-workspace-wallpapers: 4:5.8.4-1-all
plasma-workspace-wayland: 4:5.8.4-1-amd64
Comment 4 Thomas Florek 2016-12-02 23:37:01 UTC
No, @arne anka, here is no SSD built-in.

Some detailed info on my rig:

CPU~Dual core Intel Core2 Duo E7400
Kernel: 4.8.12-towo.1-siduction-amd64
HDD: 2000.4GB
Graphics: NVIDIA GT218 [GeForce 210]
Display Server: X.Org 1.19.0 drivers: nouveau
GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 13.0.2

kde-plasma-desktop               5:91     
kdeplasma-addons-data            4:5.8.4-1
libkf5plasma5:amd64              5.28.0-1 
libkf5plasmaquick5:amd64         5.28.0-1 
libplasma-geolocation-interface5 4:5.8.4-1
libplasma3                       4:4.14.26
plasma-dataengines-addons        4:5.8.4-1
plasma-desktop                   4:5.8.4-1
plasma-desktop-data              4:5.8.4-1
plasma-framework                 5.28.0-1 
plasma-integration               5.8.4-1  
plasma-nm                        4:5.8.4-1
plasma-pa                        4:5.8.4-1
plasma-runners-addons            4:5.8.4-1
plasma-scriptengine-javascript   4:16.08.3
plasma-theme-oxygen              4:5.8.4-1
plasma-wallpapers-addons         4:5.8.4-1
plasma-widget-cwp                1.11.1-1 
plasma-widget-folderview         4:16.04.1
plasma-widgets-addons            4:5.8.4-1
plasma-workspace                 4:5.8.4-1
plasma-workspace-wallpapers      4:5.8.4-1
plasma-workspace-wayland         4:5.8.4-1
Comment 5 advocatux 2016-12-03 10:21:38 UTC
I'm suffering this bug too, but there's a quick workaround until someone finds and fixes the root cause.

When the freeze happens, change to a tty (v.g. Ctrl+Alt+F1) and then go back to the graphic session (v.g. Alt+F7) and everything will work normal, at least for a while. Then repeat the process.

OpenGL vendor string:                   X.Org
OpenGL renderer string:                 Gallium 0.4 on AMD CAICOS (DRM 2.46.0 / 4.8.0-1-amd64, LLVM 3.9.0)
OpenGL version string:                  3.3 (Core Profile) Mesa 13.0.2
OpenGL shading language version string: 3.30
Driver:                                 R600G
GPU class:                              NI
OpenGL version:                         3.3
GLSL version:                           3.30
Mesa version:                           13.0.2
X server version:                       1.19
Linux kernel version:                   4.8
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
Comment 6 Thomas Florek 2016-12-03 12:00:10 UTC
Regarding @advocatux's workaround:
Here login sometimes works, sometimes only after restarting runlevel 5, sometimes login stops after kde icon on black background appeared but not reaching plasma desktop.
@advocatux, just out of curiosity:
Did you use some special command to get the software info you posted?
Comment 7 advocatux 2016-12-03 12:36:09 UTC
>Here login sometimes works, sometimes only after restarting runlevel 5, sometimes login stops after kde icon on black background appeared but not reaching plasma desktop.

@thflorek, my login works every time, and about the kde logo on black background, only once it kept like hanged for several minutes but it reached plasma desktop eventually.

How much time do you wait when that event happens to your machine?

>Did you use some special command to get the software info you posted?

No, it's just some info extracted from .xsession-errors
Comment 8 Thomas Florek 2016-12-03 14:45:18 UTC
I wait no longer than about two minutes, then my patience expires.
Afterwards I change runlevels via terminal and login again, sometimes not only once.
Comment 9 Syd Alsobrook 2016-12-03 17:50:07 UTC
You do not need to relogin.

Alt-F2 brings up krunner.
Run "pkill -f plasmashell"

Alt-F2 again:
Run "plasmashell"

Repeat as needed.

Sometimes is works for a few hours, others a few minutes.
Comment 10 Thomas Florek 2016-12-03 21:55:47 UTC
Many thanks for your hints, Syd.
Let us hope, that this nasty bug will soon be fixed.
Comment 11 Thomas Florek 2016-12-03 22:06:06 UTC
Many thanks for your hints, Syd.
Let us hope, that this nasty bug will soon be fixed.
Comment 12 Syd Alsobrook 2016-12-03 23:39:15 UTC
(In reply to thflorek from comment #10)
> Many thanks for your hints, Syd.
> Let us hope, that this nasty bug will soon be fixed.

You are welcome, I am sure it will be soon.

The system I am having the issue with has a readeon graphics card, at work. My home system is an Interl and is not having the issue. I back reved the xorg driver but that was late on Friday. I'll report more on Monday. If you are also radeon, go back the the previous driver and see what happens. Might be sooner than I can report.

The new versions are:
xserver-xorg-video-vesa:amd64 1:2.3.4-1+b2
xserver-xorg-video-fbdev:amd64 1:0.4.4-1+b5
xserver-xorg-video-radeon:amd64 1:7.8.0-1+b1
xserver-xorg-input-mouse:amd64 1:1.9.2-1+b1
xserver-xorg-input-kbd:amd64 1:1.9.0-1+b1
xserver-xorg-input-evdev:amd64 1:2.10.4-1+b1
xserver-xorg-core:amd64 2:1.19.0-2
Comment 13 kilian.cavalotti.work 2016-12-05 19:28:21 UTC
I can confirm the exact same behavior here, on an Intel-based system.
Same workaround works (switching to VT and back) for a few minutes, before the next freeze.

xserver-xorg 1:7.7+18
xserver-xorg-core 2:1.19.0-2
xserver-xorg-input-all 1:7.7+18
xserver-xorg-input-evdev 1:2.10.4-1+b1
xserver-xorg-input-libinput 0.22.0-1+b1
xserver-xorg-input-mouse 1:1.9.2-1+b1
xserver-xorg-input-synaptics 1.9.0-1+b1
xserver-xorg-input-wacom 0.33.0-1+b1
xserver-xorg-video-all 1:7.7+18
xserver-xorg-video-amdgpu 1.2.0-1+b1
xserver-xorg-video-ati 1:7.8.0-1+b1
xserver-xorg-video-cirrus 1:1.5.3-1+b2
xserver-xorg-video-fbdev 1:0.4.4-1+b5
xserver-xorg-video-intel 2:2.99.917+git20161105-1+b1
xserver-xorg-video-mach64 6.9.5-1+b2
xserver-xorg-video-mga 1:1.6.4-2+b1
xserver-xorg-video-neomagic 1:1.2.9-1+b2
xserver-xorg-video-nouveau 1:1.0.13-1+b1
xserver-xorg-video-qxl 0.1.4+20161126git4d7160c-1
xserver-xorg-video-r128 6.10.1-2+b1
xserver-xorg-video-radeon 1:7.8.0-1+b1
xserver-xorg-video-savage 1:2.3.8-2+b1
xserver-xorg-video-tdfx 1:1.4.6-2+b1
xserver-xorg-video-trident 1:1.3.7-2+b1
xserver-xorg-video-vesa 1:2.3.4-1+b2
xserver-xorg-video-vmware 1:13.2.1-1+b1

plasma-dataengines-addons 4:5.8.4-1
plasma-desktop 4:5.8.4-1
plasma-desktop-data 4:5.8.4-1
plasma-discover 5.8.3-1
plasma-discover-common 5.8.3-1
plasma-framework 5.28.0-1
plasma-integration 5.8.4-1
plasma-nm 4:5.8.4-1
plasma-pa 4:5.8.4-1
plasma-runners-addons 4:5.8.4-1
plasma-scriptengine-javascript 4:16.08.3-1
plasma-scriptengine-superkaramba 4:4.14.2-1
plasma-wallpapers-addons 4:5.8.4-1
plasma-workspace 4:5.8.4-1
Comment 14 Syd Alsobrook 2016-12-06 00:09:54 UTC
(In reply to Syd Alsobrook from comment #12)
> The new versions are:
> xserver-xorg-video-radeon:amd64 1:7.8.0-1+b1
> xserver-xorg-core:amd64 2:1.19.0-2

This were the wrong version numbers. The freeze was happening with those versions.

I worked all of today without having to restart plasmashell. The versions in use today are:

xserver-xorg-video-radeon:amd64 1:7.8.0-1
xserver-xorg-core:amd64 2:1.18.4-2
Comment 15 kilian.cavalotti.work 2016-12-07 16:46:16 UTC
Downgrading xserver-xorg-core to 1.18.4-2 indeed seems to fix the issue.
Comment 16 arne anka 2016-12-13 19:53:39 UTC
well, downgrading isn't an option for me.
but after putting the settings given at the comment of

11-25-2016, 05:18 AM 


> https://www.linuxquestions.org/questions/slackware-14/lags-and-freezes-on-ati-rs880-%5Bradeon-hd-4290%5D-with-new-xf86-video-ati-7-8-0-a-4175594206/

into my xorg.conf (need a custom one anyway), today for the first time in weeks I did not experience those freezes.

not sure, how much KDE the issue is -- I see this with plasmashell and chromium (though that could be a consequence of plasmashell issues).
Comment 17 David Edmundson 2016-12-14 14:10:48 UTC
Not much we can do about it. 

We have to wait to communicate with the Xorg drivers, and we have to except them to work.

Thanks for doing the investigation.
Comment 18 Thomas Florek 2016-12-17 08:45:54 UTC
There is hope now:  
[quote]xorg-server (2:1.19.0-3) unstable; urgency=medium
  * Cherry-pick upstream commit d6da2086951,
    Revert "damage: Make damageRegionProcessPending take a damage not a
    drawable". Fixes a crash caused by trying to free an invalid pointer.
    Closes: #847025, #848321.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Fri, 16 Dec 2016 19:39:45 +0100[/quote]
Comment 19 Thomas Florek 2016-12-19 08:21:50 UTC
Unfortunately annoying bug did not disappear.
Comment 20 Roland Tapken 2016-12-19 20:06:06 UTC
Subscribe... still freezes on 1.19.0-3.

Debian Stretch with HD Graphics 520 (Latitude 7270).
Comment 21 Roland Tapken 2016-12-21 10:15:42 UTC
Please change status since this bug seems not to be resolved with xserver-xorg-core_1.19.0-3_amd64.deb and xserver-common_1.19.0-3_all.deb.
Comment 22 Christoph Feck 2016-12-21 19:09:13 UTC
Who said that it is fixed? Has it actually been reported to xorg developers yet? Comment #18 just mentions a crash fix, which is unrelated to a freeze.
Comment 23 David Edmundson 2016-12-23 14:02:17 UTC
*** Bug 373697 has been marked as a duplicate of this bug. ***
Comment 24 Adriano Vilela 2016-12-27 18:36:11 UTC
Has this actually been resolved upstream? I'm running xserver-common version 1.19.0-3 (Debian unstable) and I'm still affected by this. If I force the use of DRI3 in /etc/X11/xorg.conf (I'm using the radeon driver), the problem goes way. However, this causes another, worse problem: when I resize the window of a GTK application, my plasma desktop goes crazy with all sorts of artifacts, windows flashing, etc. When this happens, I can switch to the other virtual desktops using the Pager applet, but I cannot go back to the virtual desktop containing the resized GTK application.
Comment 25 Roland Tapken 2017-01-06 09:06:13 UTC
Created attachment 103223 [details]
Video sequence that demonstrates this bug

After doing some research with the intention to find a way to reproduce this bug I'm not anymore convinced that this is not a KDE bug.

(1) plasmashell crashes on KDE window operations like closing a window, but only if there is activity in the system tray. I could not crash plasmashell reproducible when there was no activity in the system tray, also it DOES crash randomly without an obvious reason (but maybe it's still related to system tray activity, because there are often things like notification popups). I've attached a short video sequence to demonstrate the bug. Have a look at the file transfer indicator in the second part of the video - it stops when plasmashell crashed.

(2) Nothing like this happens when closing a GTK window or when using Cinnamon as desktop manager
Comment 26 David Edmundson 2017-01-18 13:53:03 UTC
Created attachment 103482 [details]
Rolan's GDB trace

Copying and pasting the result of a private email thread with Roland.

He had exact the same backtrace as Stefan in 373697
(attached anwyay)

and enforcing DRI3 did resolve the issue. Despite using an Intel driver not an ATI one.
Comment 27 kilian.cavalotti.work 2017-01-18 19:32:24 UTC
Enforcing DRI3 indeed solves the issue, but it generates recurring artifacts where parts of the screen seem to flicker until they're repainted. SO it's a workaround at best, but not a solution.
Comment 28 David Edmundson 2017-01-19 02:41:52 UTC

*** This bug has been marked as a duplicate of bug 373427 ***
Comment 29 Kestutis 2017-01-28 15:43:19 UTC
Created attachment 103685 [details]
xorg file
Comment 30 Kestutis 2017-01-28 15:44:32 UTC
Hi, fresh install of Stretch RC1 x64  on Vostro 1700 with Nvidia G84M [GeForce 8600M GT] using nouveau drivers. 
Plasmashell freezing every few minutes, but like others , I was able to use krunner to kill and restart plasmashell.
What I did (pure luck, i'm  noob here) was, restarted into single mode (killing sddm from other session Ctrl+Alt+F1 didnt work, as sddm restarted right away for some reason)
I ran 'X -configure' to generate xorg.conf file, as there was none in /etc/X11/ and copied it to this directory. Restarted laptop, and running for second day without hickup.
I'll try to attach my xorg.conf, so developers might find the cause, or a fix.
if you need more information, please tell me HOW to do it, as I said I am noob.
Comment 31 sedrubal 2017-01-28 16:37:34 UTC
@ Kestutis: As you can read above, this one is a dup of bug 373427 and as you can read there, it was fixed with xorg-x11-server-1.19.1 ;)
Comment 32 Arisbel Hechavarría Rojas 2017-09-08 18:15:17 UTC
Hello, now in Debian testing (buster) I have same error.