Bug 373098 - Plasma crash after returning from standby
Summary: Plasma crash after returning from standby
Status: RESOLVED DUPLICATE of bug 372963
Alias: None
Product: plasmashell
Classification: Plasma
Component: generic-crash (show other bugs)
Version: 5.8.3
Platform: openSUSE Linux
: NOR crash
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-30 06:15 UTC by Pieter Botha
Modified: 2016-12-12 11:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Stack trace (12.44 KB, text/plain)
2016-11-30 06:15 UTC, Pieter Botha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pieter Botha 2016-11-30 06:15:31 UTC
Created attachment 102536 [details]
Stack trace

The stack trace looks different from that of bug 372614 as such I'm reporting a new crash. The same system and setup applies as that of 372614 with the same multi screen return from standby scenario.
Comment 1 Marco Martin 2016-12-12 10:41:26 UTC
pasting inline 
Thread 1 (Thread 0x7ffb4ee9a8c0 (LWP 1578)):
[KCrash Handler]
#6  0x00007ffb4e8a7724 in PlasmaQuick::ContainmentView::containment() const (this=0x30206e656582) at /usr/include/qt5/QtCore/qsharedpointer_impl.h:604
#7  0x00007ffb4e8a7724 in PlasmaQuick::ContainmentView::containment() const (this=0x30206e656582) at /usr/include/qt5/QtCore/qpointer.h:86
#8  0x00007ffb4e8a7724 in PlasmaQuick::ContainmentView::containment() const (this=0x30206e656582) at /usr/include/qt5/QtCore/qpointer.h:92
#9  0x00007ffb4e8a7724 in PlasmaQuick::ContainmentView::containment() const (this=0x4d1dce0) at /usr/src/debug/plasma-framework-5.28.0/src/plasmaquick/containmentview.cpp:263
#10 0x000000000043f208 in ShellCorona::screenForContainment(Plasma::Containment const*) const (this=0x1115840, containment=<optimized out>) at /usr/src/debug/plasma-workspace-5.8.3/shell/shellcorona.cpp:1802
#11 0x000000000043f155 in ShellCorona::screenForContainment(Plasma::Containment const*) const (this=0x1115840, containment=<optimized out>) at /usr/src/debug/plasma-workspace-5.8.3/shell/shellcorona.cpp:1794
#12 0x00007ffa86c2b7ce in NotificationsApplet::onScreenChanges() (this=0x583a240) at /usr/src/debug/plasma-workspace-5.8.3/applets/notifications/lib/notificationsapplet.cpp:65
#13 0x00007ffb48e2721e in QMetaObject::activate(QObject*, int, int, void**) (a=0x7ffc18dac800, r=0x583a240, this=<optimized out>) at ../../src/corelib/kernel/qobject_impl.h:130
#14 0x00007ffb48e2721e in QMetaObject::activate(QObject*, int, int, void**) (sender=0x7ffb4bc84c00, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3723
#15 0x00007ffb34d3bdd8 in  () at /usr/lib64/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemX11Plugin.so
#16 0x00007ffb48df832f in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) (this=<optimized out>, eventType=..., message=message@entry=0x7ffb28016c70, result=result@entry=0x7ffc18dac958) at kernel/qabstracteventdispatcher.cpp:466
#17 0x00007ffb39ae4dc4 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) (this=this@entry=0x1102340, event=event@entry=0x7ffb28016c70) at qxcbconnection.cpp:1103
#18 0x00007ffb39ae5a55 in QXcbConnection::processXcbEvents() (this=0x1102340) at qxcbconnection.cpp:1735
#19 0x00007ffb48e27d59 in QObject::event(QEvent*) (this=0x1102340, e=<optimized out>) at kernel/qobject.cpp:1263
#20 0x00007ffb49d7d92c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x1102340, e=0x7ffb2807a330) at kernel/qapplication.cpp:3799
#21 0x00007ffb49d850e1 in QApplication::notify(QObject*, QEvent*) (this=0x7ffc18dad110, receiver=0x1102340, e=0x7ffb2807a330) at kernel/qapplication.cpp:3556
#22 0x00007ffb48dfb200 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x1102340, event=event@entry=0x7ffb2807a330) at kernel/qcoreapplication.cpp:988
#23 0x00007ffb48dfd98d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (event=0x7ffb2807a330, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#24 0x00007ffb48dfd98d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x10e5fc0) at kernel/qcoreapplication.cpp:1649
#25 0x00007ffb48dfddf8 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1503
#26 0x00007ffb48e4f373 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x1127e70) at kernel/qeventdispatcher_glib.cpp:276
#27 0x00007ffb435cc677 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#28 0x00007ffb435cc8e0 in  () at /usr/lib64/libglib-2.0.so.0
#29 0x00007ffb435cc98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#30 0x00007ffb48e4f77f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x1138020, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#31 0x00007ffb48df91ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffc18dacfa0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#32 0x00007ffb48e0195c in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1261
#33 0x00007ffb49347f4c in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1639
#34 0x00007ffb49d7d885 in QApplication::exec() () at kernel/qapplication.cpp:2975
#35 0x0
Comment 2 Marco Martin 2016-12-12 11:49:48 UTC
*may* be solved in 5.8.4, needs testing there

*** This bug has been marked as a duplicate of bug 372963 ***