Bug 373073 - akonadi Server not comes up (D-Bus, Resources)
Summary: akonadi Server not comes up (D-Bus, Resources)
Status: RESOLVED DUPLICATE of bug 372236
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 4.14.2
Platform: Mint (Ubuntu based) Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-29 12:56 UTC by sbopsahl@yahoo.com
Modified: 2016-11-29 23:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sbopsahl@yahoo.com 2016-11-29 12:56:24 UTC
Akonadi Server Self-Test Report
===============================

Test 10:  ERROR
--------

Akonadi control process not registered at D-Bus.
Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 11:  ERROR
--------

Akonadi server process not registered at D-Bus.
Details: The Akonadi server process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 12:  SKIP
--------

Protocol version check not possible.
Details: Without a connection to the server it is not possible to check if the protocol version meets the requirements.

Test 13:  ERROR
--------

No resource agents found.
Details: No resource agents have been found, Akonadi is not usable without at least one. This usually means that no resource agents are installed or that there is a setup problem. The following paths have been searched: '/usr/share/akonadi/agents'. The XDG_DATA_DIRS environment variable is set to '/usr/share:/usr/share/kde-plasma:/usr/local/share/:/usr/share/:/usr/share/mdm/'; make sure this includes all paths where Akonadi agents are installed.

Directory listing of '/usr/share/akonadi/agents':
akonadinepomukfeederagent.desktop
akonotesresource.desktop
archivemailagent.desktop
birthdaysresource.desktop
contactsresource.desktop
davgroupwareresource.desktop
facebookresource.desktop
folderarchiveagent.desktop
followupreminder.desktop
gcalresource.desktop
googlecalendarresource.desktop
googlecontactsresource.desktop
googledataresource.desktop
icaldirresource.desktop
icalresource.desktop
imapresource.desktop
invitationsagent.desktop
kabcresource.desktop
kalarmdirresource.desktop
kalarmresource.desktop
kcalresource.desktop
kdeaccountsresource.desktop
kolabproxyresource.desktop
kolabresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
maildispatcheragent.desktop
mailfilteragent.desktop
mboxresource.desktop
migrationagent.desktop
mixedmaildirresource.desktop
mtdummyresource.desktop
newmailnotifieragent.desktop
nntpresource.desktop
notesagent.desktop
notesresource.desktop
openxchangeresource.desktop
pop3resource.desktop
sendlateragent.desktop
vcarddirresource.desktop
vcardresource.desktop

Environment variable XDG_DATA_DIRS is set to '/usr/share:/usr/share/kde-plasma:/usr/local/share/:/usr/share/:/usr/share/mdm/'

Test 14:  ERROR
--------

Current Akonadi server error log found.
Details: The Akonadi server reported errors during its current startup. The log can be found in <a href='/home/family/.local/share/akonadi/akonadiserver.error'>/home/family/.local/share/akonadi/akonadiserver.error</a>.

File content of '/home/family/.local/share/akonadi/akonadiserver.error':
Database process exited unexpectedly during initial connection! 
executable: "/usr/sbin/mysqld-akonadi" 
arguments: ("--defaults-file=/home/family/.local/share/akonadi/mysql.conf", "--datadir=/home/family/.local/share/akonadi/db_data/", "--socket=/tmp/akonadi-family.sF1V6y/mysql.socket") 
stdout: "" 
stderr: "/usr/sbin/mysqld: Error on realpath() on '/var/lib/mysql-files' (Error 2)
161129 13:36:50 [ERROR] Failed to access directory for --secure-file-priv. Please make sure that directory exists and is accessible by MySQL Server. Supplied value : /var/lib/mysql-files
161129 13:36:50 [ERROR] Aborting

" 
exit code: 1 
process error: "Unknown error" 
"[
0: akonadiserver() [0x418967]
1: akonadiserver() [0x418bc2]
2: /lib/x86_64-linux-gnu/libc.so.6(+0x36cb0) [0x7f18fa1a5cb0]
3: /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37) [0x7f18fa1a5c37]
4: /lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7f18fa1a9028]
5: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x102) [0x7f18fb9a7c92]
6: akonadiserver() [0x41aa6d]
7: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0xb0) [0x7f18fba42470]
8: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x11ab3d) [0x7f18fba51b3d]
9: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x31) [0x7f18fba5a721]
10: akonadiserver() [0x47faa9]
11: akonadiserver() [0x41b6b7]
12: akonadiserver() [0x41dd45]
13: akonadiserver() [0x4e23a4]
14: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x24e) [0x7f18fbaccc1e]
15: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x6d) [0x7f18fbab44dd]
16: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x1ed) [0x7f18fbab7b3d]
17: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x1aaf83) [0x7f18fbae1f83]
18: /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x254) [0x7f18f9874e04]
19: /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x49048) [0x7f18f9875048]
20: /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f18f98750ec]
21: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x71) [0x7f18fbae17a1]
22: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x2f) [0x7f18fbab30af]
23: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x175) [0x7f18fbab33a5]
24: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN16QCoreApplication4execEv+0x89) [0x7f18fbab8b79]
25: akonadiserver() [0x412ef5]
26: /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f18fa190f45]
27: akonadiserver() [0x4138be]
]
" 


Test 15:  ERROR
--------

Previous Akonadi server error log found.
Details: The Akonadi server reported errors during its previous startup. The log can be found in <a href='/home/family/.local/share/akonadi/akonadiserver.error.old'>/home/family/.local/share/akonadi/akonadiserver.error.old</a>.

File content of '/home/family/.local/share/akonadi/akonadiserver.error.old':
Database process exited unexpectedly during initial connection! 
executable: "/usr/sbin/mysqld-akonadi" 
arguments: ("--defaults-file=/home/family/.local/share/akonadi/mysql.conf", "--datadir=/home/family/.local/share/akonadi/db_data/", "--socket=/tmp/akonadi-family.sF1V6y/mysql.socket") 
stdout: "" 
stderr: "/usr/sbin/mysqld: Error on realpath() on '/var/lib/mysql-files' (Error 2)
161129 13:36:50 [ERROR] Failed to access directory for --secure-file-priv. Please make sure that directory exists and is accessible by MySQL Server. Supplied value : /var/lib/mysql-files
161129 13:36:50 [ERROR] Aborting

" 
exit code: 1 
process error: "Unknown error" 
"[
0: akonadiserver() [0x418967]
1: akonadiserver() [0x418bc2]
2: /lib/x86_64-linux-gnu/libc.so.6(+0x36cb0) [0x7f50c852ccb0]
3: /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37) [0x7f50c852cc37]
4: /lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7f50c8530028]
5: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x102) [0x7f50c9d2ec92]
6: akonadiserver() [0x41aa6d]
7: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0xb0) [0x7f50c9dc9470]
8: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x11ab3d) [0x7f50c9dd8b3d]
9: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x31) [0x7f50c9de1721]
10: akonadiserver() [0x47faa9]
11: akonadiserver() [0x41b6b7]
12: akonadiserver() [0x41dd45]
13: akonadiserver() [0x4e23a4]
14: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x24e) [0x7f50c9e53c1e]
15: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x6d) [0x7f50c9e3b4dd]
16: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x1ed) [0x7f50c9e3eb3d]
17: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x1aaf83) [0x7f50c9e68f83]
18: /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x254) [0x7f50c7bfbe04]
19: /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x49048) [0x7f50c7bfc048]
20: /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f50c7bfc0ec]
21: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x71) [0x7f50c9e687a1]
22: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x2f) [0x7f50c9e3a0af]
23: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x175) [0x7f50c9e3a3a5]
24: /usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN16QCoreApplication4execEv+0x89) [0x7f50c9e3fb79]
25: akonadiserver() [0x412ef5]
26: /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f50c8517f45]
27: akonadiserver() [0x4138be]
]
"
Comment 1 Christoph Feck 2016-11-29 23:05:27 UTC

*** This bug has been marked as a duplicate of bug 372236 ***