Bug 372824 - PIM Events Plugin crashes plasmashell
Summary: PIM Events Plugin crashes plasmashell
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 373111 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-23 09:12 UTC by Rokas Kupstys
Modified: 2017-01-06 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.4.0


Attachments
plasmashell crashlog (12.88 KB, text/plain)
2016-11-23 09:12 UTC, Rokas Kupstys
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rokas Kupstys 2016-11-23 09:12:10 UTC
Created attachment 102405 [details]
plasmashell crashlog

Akonadi version is 5.3.3 as reported by "akonadictl --version".

On every startup plasmashell crashes and restarts. System tray displays crash notification. Crash log is attached.

PIM Events plugin is enabled so i can see events in calendar. I have added nextcloud to akonadi to fetch calendar data from. Everything works as expected - calendar events and contact birthdays are displayed in calendar widget.

Enabled PIM Events Plugin options:
enabled - Birthdays & Anniversaries
enabled - nextcloud callendar & contacts > default (callendar)
disabled - nextcloud callendar & contacts > Contact birthdays
enabled - Search > Declined Invitations
enabled - Search > Open Invitations

When PIM Events Plugin in calendar settings is disabled plasmashell no longer crashes on startup. When PIM Events Plugin is enabled once again it crashes plasmashell once, after plasmashell restarts everything works as expected.

P.S. I do realize crashlog is of limited use. I am sorry about that, but archlinux package maintainers are hostile to debug information in packages therefore i am simply unable to provide more useful crash log.
Comment 1 Daniel Vrátil 2016-12-02 21:30:45 UTC
Git commit 9b2176758ac1649a7090947795d6c62bc3ac4835 by Daniel Vrátil.
Committed on 02/12/2016 at 21:28.
Pushed by dvratil into branch 'Applications/16.12'.

PimEventsPlugin: catch PayloadException
FIXED-IN: 5.4.0

M  +6    -1    plugins/plasma/pimeventsplugin/eventmodel.cpp

https://commits.kde.org/kdepim-addons/9b2176758ac1649a7090947795d6c62bc3ac4835
Comment 2 Daniel Vrátil 2017-01-06 22:00:06 UTC
*** Bug 373111 has been marked as a duplicate of this bug. ***