Bug 372782 - kadressbook crashes on wily
Summary: kadressbook crashes on wily
Status: RESOLVED DUPLICATE of bug 365944
Alias: None
Product: kaddressbook
Classification: Applications
Component: general (show other bugs)
Version: 5.2.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-11-22 10:59 UTC by Hans-Peter Guggenbichler
Modified: 2017-01-17 11:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Peter Guggenbichler 2016-11-22 10:59:17 UTC
Application: kaddressbook (5.2.3)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.8.0-27-generic i686
Distribution: Ubuntu 16.10

-- Information about the crash:
Some time ago kaddressbook started crashing. I removed akonadi config and everything (it was somehow related to birthdays of contacts) and kaddressbook was working fine for a month. Then I recgonized, that I don't get birthday reminders. I enable 'Birthdays and Anniversary" agent in akonadiconsole and - bang - now kaddressbook crashes again every time I want to start it. It does so even that I have removed the agent again.

The crash can be reproduced every time.

-- Backtrace:
Application: KAddressBook (kaddressbook), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xace3d840 (LWP 3619))]

Thread 10 (Thread 0xa3623b40 (LWP 3643)):
#0  0xb774ad05 in __kernel_vsyscall ()
#1  0xb4178c3c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/pthread_cond_wait.S:187
#2  0xa68e6c8a in ?? () from /usr/lib/i386-linux-gnu/dri/r600_dri.so
#3  0xb4173305 in start_thread (arg=0xa3623b40) at pthread_create.c:333
#4  0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 9 (Thread 0xa7618b40 (LWP 3641)):
#0  timerSourceCheck (source=0xa9604c80) at kernel/qeventdispatcher_glib.cpp:168
#1  0xb402907e in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb40296a1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4029844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb612d214 in QEventDispatcherGlib::processEvents (this=0xa9603388, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#5  0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#6  0xb5ef1d15 in QThread::exec (this=0x8bedf48) at thread/qthread.cpp:500
#7  0xb5ef1df8 in QThread::run (this=0x8bedf48) at thread/qthread.cpp:567
#8  0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#9  0xb4173305 in start_thread (arg=0xa7618b40) at pthread_create.c:333
#10 0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 8 (Thread 0xa7e19b40 (LWP 3639)):
#0  0xb4028b27 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4029614 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4029844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb612d214 in QEventDispatcherGlib::processEvents (this=0xa8c03178, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#4  0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#5  0xb5ef1d15 in QThread::exec (this=0x8be6760) at thread/qthread.cpp:500
#6  0xb5ef1df8 in QThread::run (this=0x8be6760) at thread/qthread.cpp:567
#7  0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#8  0xb4173305 in start_thread (arg=0xa7e19b40) at pthread_create.c:333
#9  0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 7 (Thread 0xa87efb40 (LWP 3637)):
#0  __GI___pthread_getspecific (key=4) at pthread_getspecific.c:65
#1  0xb40705f4 in g_private_get () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4051c9c in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4029834 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb612d214 in QEventDispatcherGlib::processEvents (this=0x8b6e4b0, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#5  0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#6  0xb5ef1d15 in QThread::exec (this=0x8b7f700) at thread/qthread.cpp:500
#7  0xb5ef1df8 in QThread::run (this=0x8b7f700) at thread/qthread.cpp:567
#8  0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#9  0xb4173305 in start_thread (arg=0xa87efb40) at pthread_create.c:333
#10 0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 6 (Thread 0xa95ffb40 (LWP 3634)):
#0  0xb4070a78 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb402927e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4029779 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4029844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb612d214 in QEventDispatcherGlib::processEvents (this=0xa8c00470, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#5  0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#6  0xb5ef1d15 in QThread::exec (this=0x8b1bdf0) at thread/qthread.cpp:500
#7  0xb5ef1df8 in QThread::run (this=0x8b1bdf0) at thread/qthread.cpp:567
#8  0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#9  0xb4173305 in start_thread (arg=0xa95ffb40) at pthread_create.c:333
#10 0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 5 (Thread 0xa9fffb40 (LWP 3632)):
#0  0xb774ad05 in __kernel_vsyscall ()
#1  0xb5be311f in read () at ../sysdeps/unix/syscall-template.S:84
#2  0xb406f6c5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb402916d in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb40296a1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4029844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb612d214 in QEventDispatcherGlib::processEvents (this=0xa9600470, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#7  0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5ef1d15 in QThread::exec (this=0x8afe5e0) at thread/qthread.cpp:500
#9  0xb5ef1df8 in QThread::run (this=0x8afe5e0) at thread/qthread.cpp:567
#10 0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#11 0xb4173305 in start_thread (arg=0xa9fffb40) at pthread_create.c:333
#12 0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 4 (Thread 0xaa9f4b40 (LWP 3630)):
#0  0xb4026472 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4028acb in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4029614 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4029844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb612d214 in QEventDispatcherGlib::processEvents (this=0xaa000470, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#5  0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#6  0xb5ef1d15 in QThread::exec (this=0x8aee388) at thread/qthread.cpp:500
#7  0xb5ef1df8 in QThread::run (this=0x8aee388) at thread/qthread.cpp:567
#8  0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#9  0xb4173305 in start_thread (arg=0xaa9f4b40) at pthread_create.c:333
#10 0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 3 (Thread 0xabd99b40 (LWP 3626)):
#0  0xb774ad05 in __kernel_vsyscall ()
#1  0xb5bea3df in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb4039170 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb402970c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4029844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb612d214 in QEventDispatcherGlib::processEvents (this=0xab400470, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#6  0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#7  0xb5ef1d15 in QThread::exec (this=0xb58b56e0 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#8  0xb582073c in QDBusConnectionManager::run (this=0xb58b56e0 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:171
#9  0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#10 0xb4173305 in start_thread (arg=0xabd99b40) at pthread_create.c:333
#11 0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 2 (Thread 0xac83db40 (LWP 3625)):
#0  0xb774ad05 in __kernel_vsyscall ()
#1  0xb5bea3df in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb379341d in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb379559b in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xac9607e3 in QXcbEventReader::run (this=0x8a65868) at qxcbconnection.cpp:1325
#5  0xb5ef742a in QThreadPrivate::start (arg=<optimized out>) at thread/qthread_unix.cpp:341
#6  0xb4173305 in start_thread (arg=0xac83db40) at pthread_create.c:333
#7  0xb5bf447e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 1 (Thread 0xace3d840 (LWP 3619)):
[KCrash Handler]
#7  0xb4fc0ca6 in Akonadi::Tag::isValid() const () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#8  0xb506e60a in Akonadi::TagModel::data(QModelIndex const&, int) const () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#9  0xb766b329 in ?? () from /usr/lib/i386-linux-gnu/libkaddressbookprivate.so.5
#10 0xb61026eb in QtPrivate::QSlotObjectBase::call (a=0xbfb05adc, r=0x8b73be0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject_impl.h:124
#11 QMetaObject::activate (sender=<optimized out>, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3715
#12 0xb6102bad in QMetaObject::activate (sender=0x8bc2990, m=0xb634af94 <QAbstractItemModel::staticMetaObject>, local_signal_index=10, argv=0xbfb05adc) at kernel/qobject.cpp:3595
#13 0xb6182d01 in QAbstractItemModel::rowsInserted (this=0x8bc2990, _t1=..., _t2=<optimized out>, _t3=<optimized out>) at .moc/moc_qabstractitemmodel.cpp:601
#14 0xb6073fc9 in QAbstractItemModel::endInsertRows (this=0x8bc2990) at itemmodels/qabstractitemmodel.cpp:2624
#15 0xb50708ee in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#16 0xb507107a in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#17 0xb506d910 in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#18 0xb610266f in QMetaObject::activate (sender=<optimized out>, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3730
#19 0xb6102bad in QMetaObject::activate (sender=0x8b82238, m=0xb50fe3a8 <Akonadi::TagFetchJob::staticMetaObject>, local_signal_index=0, argv=0xbfb05d94) at kernel/qobject.cpp:3595
#20 0xb501a561 in Akonadi::TagFetchJob::tagsReceived(QVector<Akonadi::Tag> const&) () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#21 0xb501bd9d in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#22 0xb4ffbe26 in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#23 0xb4ffcd8b in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#24 0xb60ff3f0 in QMetaCallEvent::placeMetaCall (this=0x8c96a68, object=0x8b82238) at kernel/qobject.cpp:495
#25 0xb6103183 in QObject::event (this=0x8b82238, e=0x8c96a68) at kernel/qobject.cpp:1256
#26 0xb6a0c04a in QApplicationPrivate::notify_helper (this=0x8a4bfb0, receiver=0x8b82238, e=0x8c96a68) at kernel/qapplication.cpp:3804
#27 0xb6a1184c in QApplication::notify (this=0xbfb063f8, receiver=0x8b82238, e=0x8c96a68) at kernel/qapplication.cpp:3561
#28 0xb60d24ad in QCoreApplication::notifyInternal2 (receiver=0x8b82238, event=0x8c96a68) at kernel/qcoreapplication.cpp:1015
#29 0xb60d536e in QCoreApplication::sendEvent (event=0x8c96a68, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=<optimized out>, event_type=<optimized out>, data=0x8a4ab38) at kernel/qcoreapplication.cpp:1650
#31 0xb60d5877 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1508
#32 0xb612ce03 in postEventSourceDispatch (s=0x8a7fdd8) at kernel/qeventdispatcher_glib.cpp:270
#33 0xb40294d9 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb4029779 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb4029844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb612d1f3 in QEventDispatcherGlib::processEvents (this=0x8a88038, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#37 0xac99a521 in QPAEventDispatcherGlib::processEvents (this=0x8a88038, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#38 0xb60cfdad in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:204
#39 0xb60d907f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#40 0xb64117b1 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1602
#41 0xb6a08cc4 in QApplication::exec () at kernel/qapplication.cpp:2979
#42 0x0804c5a7 in ?? ()
#43 0xb5b23276 in __libc_start_main (main=0x804c230, argc=1, argv=0xbfb064e4, init=0x804dd60 <__libc_csu_init>, fini=0x804ddc0 <__libc_csu_fini>, rtld_fini=0xb775b8a0 <_dl_fini>, stack_end=0xbfb064dc) at ../csu/libc-start.c:291
#44 0x0804c743 in _start ()

Possible duplicates by query: bug 370402, bug 357228.

Reported using DrKonqi
Comment 1 Denis Kurz 2017-01-17 11:16:52 UTC

*** This bug has been marked as a duplicate of bug 365944 ***