Bug 372711 - kaddressbook crashes on startup
Summary: kaddressbook crashes on startup
Status: RESOLVED DUPLICATE of bug 365944
Alias: None
Product: kaddressbook
Classification: Applications
Component: general (show other bugs)
Version: 5.2.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-11-20 21:08 UTC by versuemer
Modified: 2017-01-17 11:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description versuemer 2016-11-20 21:08:31 UTC
Application: kaddressbook (5.2.3)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.8.0-27-generic i686
Distribution: Ubuntu 16.10

-- Information about the crash:
- What I was doing when the application crashed:
starting the application
- Custom settings of the application:
carddav source on baikal. calendars from the same source are working. Birthdays from adressbooks are shown in calendar too.

The crash can be reproduced every time.

-- Backtrace:
Application: KAddressBook (kaddressbook), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xacecf840 (LWP 2139))]

Thread 11 (Thread 0xa3095b40 (LWP 2155)):
#0  0xb77d1d05 in __kernel_vsyscall ()
#1  0xb420ac3c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/pthread_cond_wait.S:187
#2  0xa6b35a2a in ?? () from /usr/lib/i386-linux-gnu/dri/swrast_dri.so
#3  0xb4205305 in start_thread (arg=0xa3095b40) at pthread_create.c:333
#4  0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 10 (Thread 0xa3896b40 (LWP 2154)):
#0  0xb77d1d05 in __kernel_vsyscall ()
#1  0xb420ac3c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/pthread_cond_wait.S:187
#2  0xa6b35a2a in ?? () from /usr/lib/i386-linux-gnu/dri/swrast_dri.so
#3  0xb4205305 in start_thread (arg=0xa3896b40) at pthread_create.c:333
#4  0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 9 (Thread 0xa788eb40 (LWP 2152)):
#0  0xb77d1d05 in __kernel_vsyscall ()
#1  0xb77d1999 in __vdso_clock_gettime ()
#2  0xb5c93791 in __GI___clock_gettime (clock_id=1, tp=0xa788df04) at ../sysdeps/unix/clock_gettime.c:115
#3  0xb60256b8 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#4  0xb61bcbc2 in QTimerInfoList::updateCurrentTime() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#5  0xb61bd104 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb61be6e9 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb40bab37 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb40bb614 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb61bf214 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#12 0xb5f83d15 in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#13 0xb5f83df8 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#14 0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#15 0xb4205305 in start_thread (arg=0xa788eb40) at pthread_create.c:333
#16 0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 8 (Thread 0xa808fb40 (LWP 2150)):
#0  0xb77d1d05 in __kernel_vsyscall ()
#1  0xb5c7511f in read () at ../sysdeps/unix/syscall-template.S:84
#2  0xb41016c5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb40bb16d in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb40bb6a1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb61bf214 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb5f83d15 in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb5f83df8 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb4205305 in start_thread (arg=0xa808fb40) at pthread_create.c:333
#12 0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 7 (Thread 0xa8a3ab40 (LWP 2148)):
#0  0xb40bb08b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb40bb6a1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb61bf214 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#4  0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#5  0xb5f83d15 in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb5f83df8 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb4205305 in start_thread (arg=0xa8a3ab40) at pthread_create.c:333
#9  0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 6 (Thread 0xa97feb40 (LWP 2146)):
#0  0xb5c9376d in __GI___clock_gettime (clock_id=1, tp=0xa97fdf04) at ../sysdeps/unix/clock_gettime.c:93
#1  0xb60256b8 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#2  0xb61bcbc2 in QTimerInfoList::updateCurrentTime() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#3  0xb61bd104 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#4  0xb61be6e9 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#5  0xb40bab37 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb40bb614 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb61bf214 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb5f83d15 in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb5f83df8 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#12 0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#13 0xb4205305 in start_thread (arg=0xa97feb40) at pthread_create.c:333
#14 0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 5 (Thread 0xa9fffb40 (LWP 2143)):
#0  0xb5cc0225 in __x86.get_pc_thunk.di () from /lib/i386-linux-gnu/libc.so.6
#1  0xb5c930a9 in __libc_disable_asynccancel (oldtype=0) at ../nptl/cancellation.c:66
#2  0xb5c75128 in read () at ../sysdeps/unix/syscall-template.S:84
#3  0xb41016c5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb40bb16d in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb40bb6a1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb61bf214 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb5f83d15 in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb5f83df8 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#12 0xb4205305 in start_thread (arg=0xa9fffb40) at pthread_create.c:333
#13 0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 4 (Thread 0xaa9f4b40 (LWP 2142)):
#0  0xb77d1d05 in __kernel_vsyscall ()
#1  0xb5c7c3df in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb40cb170 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb40bb70c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb61bf214 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb5f83d15 in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb5f83df8 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb4205305 in start_thread (arg=0xaa9f4b40) at pthread_create.c:333
#11 0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 3 (Thread 0xabdebb40 (LWP 2141)):
#0  0xb40ba48d in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb40bb5a8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb61bf214 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#4  0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#5  0xb5f83d15 in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb58b273c in ?? () from /usr/lib/i386-linux-gnu/libQt5DBus.so.5
#7  0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb4205305 in start_thread (arg=0xabdebb40) at pthread_create.c:333
#9  0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 2 (Thread 0xac916b40 (LWP 2140)):
#0  0xb77d1d05 in __kernel_vsyscall ()
#1  0xb5c7c3df in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb382541d in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb382759b in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xaca347e3 in ?? () from /usr/lib/i386-linux-gnu/libQt5XcbQpa.so.5
#5  0xb5f8942a in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb4205305 in start_thread (arg=0xac916b40) at pthread_create.c:333
#7  0xb5c8647e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:113

Thread 1 (Thread 0xacecf840 (LWP 2139)):
[KCrash Handler]
#7  0xb5052ca6 in Akonadi::Tag::isValid() const () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#8  0xb510060a in Akonadi::TagModel::data(QModelIndex const&, int) const () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#9  0xb76fd329 in ?? () from /usr/lib/i386-linux-gnu/libkaddressbookprivate.so.5
#10 0xb61946eb in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb6194bad in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#12 0xb6214d01 in QAbstractItemModel::rowsInserted(QModelIndex const&, int, int, QAbstractItemModel::QPrivateSignal) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#13 0xb6105fc9 in QAbstractItemModel::endInsertRows() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#14 0xb51028ee in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#15 0xb510307a in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#16 0xb50ff910 in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#17 0xb619466f in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#18 0xb6194bad in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#19 0xb50ac561 in Akonadi::TagFetchJob::tagsReceived(QVector<Akonadi::Tag> const&) () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#20 0xb50ac8bf in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#21 0xb619466f in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#22 0xb6194bad in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#23 0xb6218262 in QTimer::timeout(QTimer::QPrivateSignal) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#24 0xb61a1761 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#25 0xb6195146 in QObject::event(QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#26 0xb6a9e04a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#27 0xb6aa384c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#28 0xb61644ad in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#29 0xb61bdfbd in QTimerInfoList::activateTimers() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#30 0xb61be609 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#31 0xb40bb4d9 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb40bb779 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb40bb844 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb61bf1f3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#35 0xaca6e521 in ?? () from /usr/lib/i386-linux-gnu/libQt5XcbQpa.so.5
#36 0xb6161dad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#37 0xb616b07f in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#38 0xb64a37b1 in QGuiApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5
#39 0xb6a9acc4 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#40 0x0804c5a7 in ?? ()
#41 0xb5bb5276 in __libc_start_main (main=0x804c230, argc=1, argv=0xbfb5d594, init=0x804dd60 <__libc_csu_init>, fini=0x804ddc0 <__libc_csu_fini>, rtld_fini=0xb77e28a0 <_dl_fini>, stack_end=0xbfb5d58c) at ../csu/libc-start.c:291
#42 0x0804c743 in _start ()

Possible duplicates by query: bug 370402, bug 369070, bug 367749, bug 366304, bug 365944.

Reported using DrKonqi
Comment 1 Denis Kurz 2017-01-17 11:16:22 UTC

*** This bug has been marked as a duplicate of bug 365944 ***