Bug 372678 - kmail not opening link
Summary: kmail not opening link
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: misc (show other bugs)
Version: 5.3.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-19 20:51 UTC by Bob Miller
Modified: 2016-11-21 09:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.3.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Miller 2016-11-19 20:51:51 UTC
kmail opens some links, but not others. Began about 2-3 weeks ago (early Nov 2016). Links fail to open regardless of which web browser is default (konq, firefox, chrome).

Some links that kmail will not open. Older versions worked OK.
https://www.tep.com/
http://www.tep.com/doc/customer/tep-bill-back.pdf

Links that kmail will open
https://connect.secure.wellsfargo.com/auth/login/present?origin=cob&loginMode=jukePassword&serviceType=document&LOB=CONS
http://www.rentcafe.com/t/tec?ref=MTM0OTY1ODQ3-G3KKDv%2BL0p8%3D,NTc4NzM%3D-2jHqVXdhvms%3D

I cannot find any pattern between http vice https, long vice short, etc. URLs as to what kmail will and will not open.
Comment 1 Bob Miller 2016-11-19 20:53:26 UTC
The links do open in other e-mail clients like thunderbird.
Comment 3 Laurent Montel 2016-11-21 06:30:01 UTC
Hi,
Did you test to use popup menu => right click on url + open ?
Comment 4 Bob Miller 2016-11-21 06:39:45 UTC
No, I did not, because simply clicking on the URL had always worked.

Following your advice, doing a "right click" and "open URL" activated the 
link!

Working fine.

Thanks,
Bob


On Monday, 21 November 2016 06:30:01 MST you wrote:
https://bugs.kde.org/show_bug.cgi?id=372678

Laurent Montel <montel@kde.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |montel@kde.org

--- Comment #3 from Laurent Montel <montel@kde.org> ---
Hi,
Did you test to use popup menu => right click on url + open ?
Comment 5 Laurent Montel 2016-11-21 09:13:07 UTC
So it's fixed in 5.3.3 it was a regression but now it works.
Regards