Bug 372658 - Opening file picker triggers "the process for file procotol is dead unexpectedly"
Summary: Opening file picker triggers "the process for file procotol is dead unexpecte...
Status: RESOLVED WORKSFORME
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: general (show other bugs)
Version: 5.27.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-19 12:25 UTC by Germano Massullo
Modified: 2016-12-06 18:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Germano Massullo 2016-11-19 12:25:55 UTC
The moment I open Amarok, I obtain a popup saying: "the process for file procotol is dead unexpectedly"

$ amarok -d all
[cut]
amarok(2364)/kio (Slave) KIO::Slave::timeout: slave failed to connect to application pid= 2383  protocol= "file"
amarok(2364)/kio (Slave) KIO::Slave::timeout: Houston, we lost our slave, pid= 2383
amarok(2364)/kio (Slave) KIO::Slave::timeout: slave died pid =  2383
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::jobFinished: KIO::ListJob(0x55e0c7dedd40) KIO::Slave(0x55e0c7007ae0)
amarok(2364)/kio (KDirListerCache) KDirListerCache::slotResult: finished listing KUrl("file:///media/archivio")
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::slotSlaveDied: KIO::Slave(0x55e0c7007ae0)
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x620019d
Calling appendChild() on a null node does nothing.
amarok(2364)/kio (KDirListerCache) KDirListerCache::stopListingUrl: KDirLister(0x55e0c7e3ca50)  url= KUrl("file:///media/archivio")
amarok(2364)/kio (KDirListerCache) KDirListerCache::listDir: Listing directory: KUrl("file:///media")
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::doJob: KIO::SimpleJob(0x55e0c7ded4c0)
amarok: BEGIN: void BrowserCategoryList::childViewChanged() 
amarok: END__: void BrowserCategoryList::childViewChanged() [Took: 0.033s] 
amarok(2364)/kio (Slave) KIO::Slave::createSlave: createSlave "file" for KUrl("file:///media")
amarok(2364)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/run/user/1000/ksocket-userdpmVZ/amarokgx2364.slave-socket"
amarok(2364)/kio (KDirListerCache) KDirListerCache::stopListingUrl: KDirLister(0x55e0c7e3ca50)  url= KUrl("file:///media")
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::cancelJob: KIO::ListJob(0x55e0c7ded4c0) KIO::Slave(0x55e0c8bf0970)
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::cancelJob: Scheduler: killing slave  2396
amarok(2364)/kio (Slave) KIO::Slave::kill: killing slave pid 2396 ( "file://" )
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::jobFinished: KIO::ListJob(0x55e0c7ded4c0) KIO::Slave(0x55e0c8bf0970)
amarok(2364)/kio (KDirListerCache) KDirListerCache::slotResult: finished listing KUrl("file:///media")
amarok(2364)/kio (KDirListerCache) KDirListerCache::listDir: Listing directory: KUrl("file:///")
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::doJob: KIO::SimpleJob(0x55e0c8b7cbf0)
amarok: BEGIN: void BrowserCategoryList::childViewChanged() 
amarok: END__: void BrowserCategoryList::childViewChanged() [Took: 0.029s] 
amarok(2364)/kio (Slave) KIO::Slave::createSlave: createSlave "file" for KUrl("file:///")
amarok(2364)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/run/user/1000/ksocket-userdpmVZ/amarokDL2364.slave-socket"
amarok(2364)/kio (Slave) KIO::Slave::timeout: slave failed to connect to application pid= 2397  protocol= "file"
amarok(2364)/kio (Slave) KIO::Slave::timeout: Houston, we lost our slave, pid= 2397
amarok(2364)/kio (Slave) KIO::Slave::timeout: slave died pid =  2397
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::jobFinished: KIO::ListJob(0x55e0c8b7cbf0) KIO::Slave(0x55e0c8cf7b30)
amarok(2364)/kio (KDirListerCache) KDirListerCache::slotResult: finished listing KUrl("file:///")
amarok(2364)/kio (Scheduler) KIO::SchedulerPrivate::slotSlaveDied: KIO::Slave(0x55e0c8cf7b30)
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x62001b2


===========
Packages infos

# dnf list installed | grep kio
audiocd-kio.x86_64                   16.08.2-1.fc24             @updates        
audiocd-kio-doc.noarch               16.08.2-1.fc24             @updates        
audiocd-kio-libs.x86_64              16.08.2-1.fc24             @updates        
kdesdk-kioslaves.x86_64              16.08.2-1.fc24             @updates        
kf5-kio-core.x86_64                  5.27.0-1.fc24              @updates        
kf5-kio-core-libs.x86_64             5.27.0-1.fc24              @updates        
kf5-kio-debuginfo.x86_64             5.27.0-1.fc24              @updates-debuginfo
kf5-kio-doc.noarch                   5.27.0-1.fc24              @updates        
kf5-kio-file-widgets.x86_64          5.27.0-1.fc24              @updates        
kf5-kio-gui.x86_64                   5.27.0-1.fc24              @updates        
kf5-kio-ntlm.x86_64                  5.27.0-1.fc24              @updates        
kf5-kio-widgets.x86_64               5.27.0-1.fc24              @updates        
kf5-kio-widgets-libs.x86_64          5.27.0-1.fc24              @updates        
kio-extras.x86_64                    16.08.2-1.fc24             @updates        
kio-upnp-ms.x86_64                   1.0.0-9.20111102git.fc24   @@commandline   
kio_msits.x86_64                     7:16.08.2-1.fc24           @updates        
kio_mtp.x86_64                       0.75-13.20141221gitc418634.fc24
kio_sysinfo.x86_64                   20090930-13.fc24           @@commandline


# rpm -q plasma-desktop
plasma-desktop-5.8.3-2.fc24.x86_64

# rpm -q amarok
amarok-2.8.90-7.fc24.x86_64
Comment 1 Bhushan Shah 2016-11-19 12:35:08 UTC
I've seen more reports of kioslave processes dying including sftp. I wonder what changed in kio?
Comment 2 Germano Massullo 2016-11-23 20:28:43 UTC
This happens on all Qt based applications
Comment 3 Rex Dieter 2016-12-06 14:11:37 UTC
For posterity, some more documented ways to debug ioslaves,
https://community.kde.org/Guidelines_and_HOWTOs/Debugging/Debugging_IOSlaves
Comment 4 Germano Massullo 2016-12-06 18:35:25 UTC
I could not retrieve logs with the guide I followed because the affected
application use KDE libs 4, not KDE Framework 5.
I followed [1] and the moment I run
kdeinit4
Konsole showed some messages about ~/. files, but I haven't paid
attention to them. Suddenly the problem disappeared. I even tried to
relogin, reboot the system, but there is no way to reproduce it again.
This is very strange because I experienced it for ~ more than an entire
week...
Anyway, thanks to Rex Dieter and Pino Toscano

[1]:
https://community.kde.org/Guidelines_and_HOWTOs/Debugging/Debugging_IOSlaves#GUI_.28Qt4.2Fkdelibs4_instructions.29