Bug 372501 - Plasmashell crashes when disconnecting display during suspend-to-RAM
Summary: Plasmashell crashes when disconnecting display during suspend-to-RAM
Status: RESOLVED DUPLICATE of bug 371991
Alias: None
Product: plasmashell
Classification: Plasma
Component: generic-multiscreen (show other bugs)
Version: 5.8.3
Platform: Arch Linux Linux
: NOR crash
Target Milestone: 1.0
Assignee: Aleix Pol
URL:
Keywords: drkonqi
: 372751 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-15 11:03 UTC by jdrees
Modified: 2016-11-24 11:22 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdrees 2016-11-15 11:03:11 UTC
Application: plasmashell (5.8.3)

Qt Version: 5.7.0
Frameworks Version: 5.27.0
Operating System: Linux 4.8.6-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
Always after waking up from suspend-to-RAM, plasmashell encounters a segmentation fault. This only occurs when I disconnect my Laptop's external display during suspend.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa070eaf7c0 (LWP 16481))]

Thread 19 (Thread 0x7f9f5fc99700 (LWP 19531)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 18 (Thread 0x7f9f7c935700 (LWP 19408)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 17 (Thread 0x7f9f7d566700 (LWP 19407)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 16 (Thread 0x7f9f7e197700 (LWP 19093)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 15 (Thread 0x7f9f7ee1a700 (LWP 18548)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 14 (Thread 0x7f9f7fc98700 (LWP 18259)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 13 (Thread 0x7f9f90902700 (LWP 18258)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 12 (Thread 0x7f9f915f3700 (LWP 18257)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 11 (Thread 0x7f9f91e67700 (LWP 18256)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 10 (Thread 0x7f9f933fe700 (LWP 16498)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 9 (Thread 0x7f9f9a8ab700 (LWP 16496)):
#0  0x00007fa06a5c748d in poll () at /usr/lib/libc.so.6
#1  0x00007fa065889786 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fa06588989c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fa06aee972b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fa06ae9323a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007fa06acb60f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f9f9cdd70a7 in KCupsConnection::run() () at /usr/lib/libkcupslib.so
#7  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7f9fb3fff700 (LWP 16492)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa06acbbc2b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa06ec27395 in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007fa06ec27c8a in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 7 (Thread 0x7f9fb9532700 (LWP 16490)):
#0  0x00007fa06a5c34ed in read () at /usr/lib/libc.so.6
#1  0x00007fa0658cda10 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fa065889235 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007fa065889724 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fa06588989c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007fa06aee972b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007fa06ae9323a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007fa06acb60f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007fa06ebb8856 in  () at /usr/lib/libQt5Quick.so.5
#9  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#10 0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#11 0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7fa047bdf700 (LWP 16486)):
#0  0x00007fa069dd010f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa070648ac4 in  () at /usr/lib/libQt5Script.so.5
#2  0x00007fa070648b09 in  () at /usr/lib/libQt5Script.so.5
#3  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7fa0519c8700 (LWP 16485)):
#0  0x00007fa06a5c748d in poll () at /usr/lib/libc.so.6
#1  0x00007fa065889786 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fa06588989c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fa06aee972b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fa06ae9323a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007fa06acb60f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007fa06e0192d5 in  () at /usr/lib/libQt5Qml.so.5
#7  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7fa0537c8700 (LWP 16484)):
#0  0x00007fa06a5c748d in poll () at /usr/lib/libc.so.6
#1  0x00007fa065889786 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fa06588989c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fa06aee972b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fa06ae9323a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007fa06acb60f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007fa06e0192d5 in  () at /usr/lib/libQt5Qml.so.5
#7  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7fa059299700 (LWP 16483)):
#0  0x00007fa06a5c748d in poll () at /usr/lib/libc.so.6
#1  0x00007fa065889786 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fa06588989c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fa06aee972b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fa06ae9323a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007fa06acb60f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007fa06ba36e55 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7fa05b2ed700 (LWP 16482)):
#0  0x00007fa06a5c748d in poll () at /usr/lib/libc.so.6
#1  0x00007fa06f5888e0 in  () at /usr/lib/libxcb.so.1
#2  0x00007fa06f58a679 in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007fa05d65d449 in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007fa06acbad78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa069dca454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa06a5d07df in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7fa070eaf7c0 (LWP 16481)):
[KCrash Handler]
#6  0x00007fa06b40c740 in QScreen::geometry() const () at /usr/lib/libQt5Gui.so.5
#7  0x00000000004307e2 in  ()
#8  0x000000000043444b in  ()
#9  0x00007fa06b3eee15 in QWindow::event(QEvent*) () at /usr/lib/libQt5Gui.so.5
#10 0x00007fa06ec5c883 in QQuickWindow::event(QEvent*) () at /usr/lib/libQt5Quick.so.5
#11 0x0000000000431843 in  ()
#12 0x00007fa06bdffe0c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#13 0x00007fa06be07581 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#14 0x00007fa06ae94de0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#15 0x00007fa06b3dfd5a in QGuiApplicationPrivate::processGeometryChangeEvent(QWindowSystemInterfacePrivate::GeometryChangeEvent*) () at /usr/lib/libQt5Gui.so.5
#16 0x00007fa06b3dffa9 in QGuiApplicationPrivate::processWindowScreenChangedEvent(QWindowSystemInterfacePrivate::WindowScreenChangedEvent*) () at /usr/lib/libQt5Gui.so.5
#17 0x00007fa06b3e4ec5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /usr/lib/libQt5Gui.so.5
#18 0x00007fa06b3c2cab in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Gui.so.5
#19 0x00007fa05d6932f0 in  () at /usr/lib/libQt5XcbQpa.so.5
#20 0x00007fa065889587 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#21 0x00007fa0658897f0 in  () at /usr/lib/libglib-2.0.so.0
#22 0x00007fa06588989c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#23 0x00007fa06aee970f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#24 0x00007fa06ae9323a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#25 0x00007fa06ae9b73c in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#26 0x000000000041c8b2 in  ()
#27 0x00007fa06a508291 in __libc_start_main () at /usr/lib/libc.so.6
#28 0x000000000041cc3a in _start ()

Reported using DrKonqi
Comment 1 Marco Martin 2016-11-16 12:30:27 UTC
it *may* be fixed in 5.8.4
Comment 2 franz.bergesund 2016-11-18 09:54:04 UTC
I have been hit by what appears the same problem on openSUSE:

Application: plasmashell (5.8.3)

Qt Version: 5.7.0
Frameworks Version: 5.27.0
Operating System: Linux 4.8.7-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:

* Connect the computer (DELL latitude E6430s, with intel CPU and graphic card)
  via a DELL docking station to an external screen
* wake up the computer
* work
* put the computer to sleep
* disconnect from the docking station
* wake the computer
* plasmashell has crashed in the mean while
* plasmashell restarts by itself within a minute and DrKonqi appears

The crash happened to me already twice in the last few days.
It was months since the last time I had serious and similar issues with double
screen.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0fa6a148c0 (LWP 2057))]

Thread 11 (Thread 0x7f0ebb7ff700 (LWP 29138)):
#0  0x00007f0f94df1a7d in pa_pstream_unref () at /usr/lib64/pulseaudio/libpulsecommon-9.0.so
#1  0x00007f0f94df1fb9 in  () at /usr/lib64/pulseaudio/libpulsecommon-9.0.so
#2  0x00007f0f94df283a in  () at /usr/lib64/pulseaudio/libpulsecommon-9.0.so
#3  0x00007f0f9597b65c in pa_mainloop_dispatch () at /usr/lib64/libpulse.so.0
#4  0x00007f0f9597ba5c in pa_mainloop_iterate () at /usr/lib64/libpulse.so.0
#5  0x00007f0f9597bb00 in pa_mainloop_run () at /usr/lib64/libpulse.so.0
#6  0x00007f0f95989b29 in  () at /usr/lib64/libpulse.so.0
#7  0x00007f0f94e021e8 in  () at /usr/lib64/pulseaudio/libpulsecommon-9.0.so
#8  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 10 (Thread 0x7f0ec6bde700 (LWP 29137)):
#0  0x00007f0f9b1a3ea9 in g_mutex_lock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007f0f9b15dd85 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f0f9b15e79b in  () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f0fa09e179b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0ec0003300, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0ec6bddce0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#6  0x00007f0fa07b98b3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#7  0x00007f0fa3aeaa75 in  () at /usr/lib64/libQt5Qml.so.5
#8  0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x5da8000) at thread/qthread_unix.cpp:344
#9  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#10 0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 9 (Thread 0x7f0ed889a700 (LWP 3354)):
#0  0x00007f0f9b1a3ea0 in g_mutex_lock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007f0f9b15e832 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f0fa09e179b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0ecc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0ed8899d00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#5  0x00007f0fa07b98b3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#6  0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x4a7d240) at thread/qthread_unix.cpp:344
#7  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#8  0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 8 (Thread 0x7f0ed9ff0700 (LWP 3346)):
#0  0x00007f0fa00c268d in poll () at /lib64/libc.so.6
#1  0x00007f0f9b15e876 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f0fa09e179b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0ed40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0ed9fefcc0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#5  0x00007f0fa07b98b3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#6  0x00007f0edc51adf7 in KCupsConnection::run() () at /usr/lib64/libkcupslib.so
#7  0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x4a385b0) at thread/qthread_unix.cpp:344
#8  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 7 (Thread 0x7f0eed794700 (LWP 2911)):
#0  0x00007f0f9b1a3ea9 in g_mutex_lock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007f0f9b15e832 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f0fa09e179b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0ee80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0eed793c90, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#5  0x00007f0fa07b98b3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#6  0x00007f0fa4679646 in  () at /usr/lib64/libQt5Quick.so.5
#7  0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x20116b0) at thread/qthread_unix.cpp:344
#8  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#9  0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 6 (Thread 0x7f0f84ce0700 (LWP 2463)):
#0  0x00007f0f9f8ca10f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f0fa60f1834 in  () at /usr/lib64/libQt5Script.so.5
#2  0x00007f0fa60f1879 in  () at /usr/lib64/libQt5Script.so.5
#3  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7f0f86a06700 (LWP 2227)):
#0  0x00007f0fa686d562 in _dl_update_slotinfo () at /lib64/ld-linux-x86-64.so.2
#1  0x00007f0fa686d7ac in update_get_addr () at /lib64/ld-linux-x86-64.so.2
#2  0x00007f0fa07bd3f6 in QThreadData::current(bool) () at thread/qthread_unix.cpp:189
#3  0x00007f0fa07bd3f6 in QThreadData::current(bool) (createIfNecessary=createIfNecessary@entry=true) at thread/qthread_unix.cpp:220
#4  0x00007f0fa09e0eea in postEventSourcePrepare(GSource*, gint*) (s=0x7f0f740012d0, timeout=0x7f0f86a05b14) at kernel/qeventdispatcher_glib.cpp:252
#5  0x00007f0f9b15dd79 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#6  0x00007f0f9b15e79b in  () at /usr/lib64/libglib-2.0.so.0
#7  0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#8  0x00007f0fa09e179b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0f740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#9  0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0f86a05ce0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#10 0x00007f0fa07b98b3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#11 0x00007f0fa3aeaa75 in  () at /usr/lib64/libQt5Qml.so.5
#12 0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x18a36b0) at thread/qthread_unix.cpp:344
#13 0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#14 0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7f0f87fff700 (LWP 2133)):
#0  0x00007f0fa07b5709 in QMutex::lock() (__m2=<optimized out>, __m1=std::memory_order_acquire, __p2=<optimized out>, __p1=@0x7f0f87ffea78: 0x0, this=0x1834e00) at /usr/include/c++/6/bits/atomic_base.h:752
#1  0x00007f0fa07b5709 in QMutex::lock() (__m=std::memory_order_acquire, __p2=<optimized out>, __p1=@0x7f0f87ffea78: 0x0, this=0x1834e00) at /usr/include/c++/6/atomic:475
#2  0x00007f0fa07b5709 in QMutex::lock() (currentValue=<synthetic pointer>, newValue=<optimized out>, expectedValue=0x0, _q_value=...) at ../../src/corelib/arch/qatomic_cxx11.h:165
#3  0x00007f0fa07b5709 in QMutex::lock() (currentValue=<synthetic pointer>, newValue=<optimized out>, expectedValue=0x0, this=0x1834e00) at ../../src/corelib/thread/qbasicatomic.h:259
#4  0x00007f0fa07b5709 in QMutex::lock() (current=<synthetic pointer>, this=0x1834e00) at thread/qmutex.h:89
#5  0x00007f0fa07b5709 in QMutex::lock() (this=this@entry=0x1834e00) at thread/qmutex.cpp:225
#6  0x00007f0fa09e0f0f in postEventSourcePrepare(GSource*, gint*) (m=0x1834e00, this=<synthetic pointer>) at ../../src/corelib/thread/qmutex.h:137
#7  0x00007f0fa09e0f0f in postEventSourcePrepare(GSource*, gint*) (this=0x1834dd0) at ../../src/corelib/thread/qthread_p.h:253
#8  0x00007f0fa09e0f0f in postEventSourcePrepare(GSource*, gint*) (s=0x7f0f7c0012d0, timeout=0x7f0f87ffeb14) at kernel/qeventdispatcher_glib.cpp:259
#9  0x00007f0f9b15dd79 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#10 0x00007f0f9b15e79b in  () at /usr/lib64/libglib-2.0.so.0
#11 0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#12 0x00007f0fa09e179b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0f7c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#13 0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0f87ffece0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#14 0x00007f0fa07b98b3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#15 0x00007f0fa3aeaa75 in  () at /usr/lib64/libQt5Qml.so.5
#16 0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x18387a0) at thread/qthread_unix.cpp:344
#17 0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#18 0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f0f8f304700 (LWP 2084)):
#0  0x00007f0fa00c268d in poll () at /lib64/libc.so.6
#1  0x00007f0fa50363e0 in  () at /usr/lib64/libxcb.so.1
#2  0x00007f0fa5038179 in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007f0f9166b5f9 in QXcbEventReader::run() (this=0x176d230) at qxcbconnection.cpp:1337
#4  0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x176d230) at thread/qthread_unix.cpp:344
#5  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#6  0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f0f93be1700 (LWP 2078)):
#0  0x00007f0f9b1a3ec4 in g_mutex_unlock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007f0f9b15e204 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f0f9b15e814 in  () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f0fa09e179b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0f880008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0f93be0cd0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#6  0x00007f0fa07b98b3 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#7  0x00007f0fa153b3e5 in  () at /usr/lib64/libQt5DBus.so.5
#8  0x00007f0fa07be558 in QThreadPrivate::start(void*) (arg=0x7f0fa17acd20) at thread/qthread_unix.cpp:344
#9  0x00007f0f9f8c4454 in start_thread () at /lib64/libpthread.so.0
#10 0x00007f0fa00cb39f in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f0fa6a148c0 (LWP 2057)):
[KCrash Handler]
#6  0x00007f0fa642c174 in PlasmaQuick::ContainmentView::containment() const () at /usr/lib64/libKF5PlasmaQuick.so.5
#7  0x000000000043f208 in ShellCorona::screenForContainment(Plasma::Containment const*) const (this=0x1832e10, containment=<optimized out>) at /usr/src/debug/plasma-workspace-5.8.3/shell/shellcorona.cpp:1802
#8  0x000000000043f155 in ShellCorona::screenForContainment(Plasma::Containment const*) const (this=0x1832e10, containment=<optimized out>) at /usr/src/debug/plasma-workspace-5.8.3/shell/shellcorona.cpp:1794
#9  0x00007f0edd63a7ce in NotificationsApplet::onScreenChanges() (this=0x4639b70) at /usr/src/debug/plasma-workspace-5.8.3/applets/notifications/lib/notificationsapplet.cpp:65
#10 0x00007f0fa09b921e in QMetaObject::activate(QObject*, int, int, void**) (a=0x7fff109bfb20, r=0x4639b70, this=<optimized out>) at ../../src/corelib/kernel/qobject_impl.h:130
#11 0x00007f0fa09b921e in QMetaObject::activate(QObject*, int, int, void**) (sender=0x7f0fa3816c00, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3723
#12 0x00007f0f8c8b2dd8 in  () at /usr/lib64/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemX11Plugin.so
#13 0x00007f0fa098a32f in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) (this=<optimized out>, eventType=..., message=message@entry=0x7f0f800178f0, result=result@entry=0x7fff109bfc78) at kernel/qabstracteventdispatcher.cpp:466
#14 0x00007f0f9166cdc4 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) (this=this@entry=0x1761360, event=event@entry=0x7f0f800178f0) at qxcbconnection.cpp:1103
#15 0x00007f0f9166da55 in QXcbConnection::processXcbEvents() (this=0x1761360) at qxcbconnection.cpp:1735
#16 0x00007f0fa09b9d59 in QObject::event(QEvent*) (this=0x1761360, e=<optimized out>) at kernel/qobject.cpp:1263
#17 0x00007f0fa190f92c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x1761360, e=0x7f0f80026fd0) at kernel/qapplication.cpp:3799
#18 0x00007f0fa19170e1 in QApplication::notify(QObject*, QEvent*) (this=0x7fff109c0430, receiver=0x1761360, e=0x7f0f80026fd0) at kernel/qapplication.cpp:3556
#19 0x00007f0fa098d200 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x1761360, event=event@entry=0x7f0f80026fd0) at kernel/qcoreapplication.cpp:988
#20 0x00007f0fa098f98d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (event=0x7f0f80026fd0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#21 0x00007f0fa098f98d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1743850) at kernel/qcoreapplication.cpp:1649
#22 0x00007f0fa098fdf8 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1503
#23 0x00007f0fa09e1373 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x1782d80) at kernel/qeventdispatcher_glib.cpp:276
#24 0x00007f0f9b15e677 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#25 0x00007f0f9b15e8e0 in  () at /usr/lib64/libglib-2.0.so.0
#26 0x00007f0f9b15e98c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#27 0x00007f0fa09e177f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x17a7310, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#28 0x00007f0fa098b1ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fff109c02c0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#29 0x00007f0fa099395c in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1261
#30 0x00007f0fa0ed9f4c in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1639
#31 0x00007f0fa190f885 in QApplication::exec() () at kernel/qapplication.cpp:2975
#32 0x000000000041e972 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/plasma-workspace-5.8.3/shell/main.cpp:166
Comment 3 franz.bergesund 2016-11-18 10:05:40 UTC
Update: now I could disconnect without issues
Comment 4 Marco Martin 2016-11-21 09:59:52 UTC
(In reply to franz.bergesund from comment #3)
> Update: now I could disconnect without issues

this with a post 5.8.3 update, like master or 5.8 branch?
Comment 5 franz.bergesund 2016-11-21 10:03:01 UTC
(In reply to Marco Martin from comment #4)
> (In reply to franz.bergesund from comment #3)
> > Update: now I could disconnect without issues
> 
> this with a post 5.8.3 update, like master or 5.8 branch?

Nope. Exactly same software stack as the report.
It just didn't crash. So evidently it doesn't always happen.

[sorry for not being clearer]
Comment 6 David Edmundson 2016-11-21 16:04:41 UTC

*** This bug has been marked as a duplicate of bug 371991 ***
Comment 7 Marco Martin 2016-11-24 11:22:27 UTC
*** Bug 372751 has been marked as a duplicate of this bug. ***